Exercise 1: Three Point Bending Using ANSYS Workbench

Contents
Goals.............................................................................................................................................................................. 1
Beam under 3-Pt Bending..................................................................................................................................... 2
Taking advantage of symmetries........................................................................................................................ 3
Starting and Configuring ANSYS Workbench................................................................................................ 4
A.  Pre-Processing: Setting up the Model............................................................................................................... 6
   A.1 Defining the Geometry............................................................................................................................... 6
   A.2 Material Properties....................................................................................................................................... 7
   A.3 Material Properties Assignment ................................................................................................................ 8
   A.4 Meshing.......................................................................................................................................................... 8
   A.5 Applying Loads and Boundary Conditions ................................................................................................. 10
B.  Solving............................................................................................................................................................... 11
C.  Post-Processing: Evaluating the Solution..................................................................................................... 11
   C.1 Specifying Result Items.................................................................................................................................. 11
   C.2 Total Deformation......................................................................................................................................... 12
   C.3 Visualizing Stresses & Strains.................................................................................................................... 13
D.  Bonus Task: Parameterization & Optimization ......................................................................................... 15
   D.1 Parameterizing the Beam Geometry........................................................................................................ 15
   D.2 Output Parameters...................................................................................................................................... 17
   D.3 Optimization............................................................................................................................................... 18

Goals
This exercise will teach you how to perform a simple, yet complete, finite element analysis (FEA) consisting of pre-processing, solving the FE model and subsequent post-processing using the static structural module of ANSYS Workbench.
Beam under 3-Pt Bending

We want to simulate a beam under three point bending with a force $F$ applied at the center as shown in Figure 1.

![Beam under three point bending diagram](image)

Figure 1: Beam under three point bending

The following geometry and material data are required to model our problem:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>$F$</td>
<td>500,000 N</td>
<td></td>
</tr>
<tr>
<td>$L$</td>
<td>2,000 mm</td>
<td></td>
</tr>
<tr>
<td>$h$</td>
<td>60 mm</td>
<td></td>
</tr>
<tr>
<td>$t$</td>
<td>20 mm</td>
<td></td>
</tr>
<tr>
<td>$E$</td>
<td>210,000 N/mm²</td>
<td></td>
</tr>
<tr>
<td>$\nu$</td>
<td>0.3</td>
<td></td>
</tr>
<tr>
<td>$\sigma_{\text{yield}}$</td>
<td>235 N/mm²</td>
<td></td>
</tr>
</tbody>
</table>

Table 1: Geometry and material data.

### Questions

With respect to this classic two-dimensional mechanical problem, we can state two questions:

1. Will the beam break? Where would it fail?
2. Assuming that it will not fail, what would be the maximum deflection $w$?
Taking advantage of symmetries

Can we take advantage of symmetries? Please, draw a simplified beam model, which takes advantage of potential symmetries (Figure 2).

Choose appropriate boundary conditions for the simplified beam such that

- you would get the same displacement results than for the 3-pt bending
- all rigid body movements are fixed.

Figure 2: Space for drawing a simplified beam model taking advantage of symmetries.

This is the system that we now want to simulate using ANSYS.
Starting and Configuring ANSYS Workbench

First, log in using your credentials. From the Windows start menu select and run ANSYS Workbench (Figure 3), opening up ANSYS Workbench’s project view (Figure 4).

![Figure 3: Starting ANSYS Workbench](image)

**Important:** Please make sure to choose the right license type. After you have launched Workbench go to **Tools → License Preferences** and make sure that **ANSYS Academic Teach Advanced** is the default (i.e.: top-most) license option (Figure 5). Otherwise, use the **Move up** and **Move down** buttons to correct and finally **Apply** the settings.

Do **not** choose “ANSYS Academic Research” as the default license!
Figure 4: A new (and yet empty) ANSYS Workbench session

The Toolbox contains pre-configured analysis systems, which form the building blocks of each Workbench project.

The project schematic visualizes the work- and data-flow between the different project components and modules.

Figure 5: Configuring the license settings
A. Pre-Processing: Setting up the Model

Before building the actual model, you need to create a new static-structural FE analysis by dragging and dropping the **Static Structural** analysis system onto the empty project schematic (Figure 6).

![Figure 6: Creating a new static structural analysis system](image)

A.1 Defining the Geometry

In the newly created analysis system, double click the **Geometry** cell to start up the **Design-Modeler** module; choose the desired units.

Create the solid beam by choosing (from the main menu) **Create → Primitives → Box**. Use the **Details** pane to specify the desired dimensions of the new primitive.

Please ensure that the origin of the coordinate system is located on the plane and at the center of the cross section of the beam. The beam’s long axis must be oriented along the global \(x\)-axis (Figure 7).
A.2 Material Properties

Material models define the mechanical behavior of the components of the FE model. We will use a simple linear-elastic and isotropic material model to represent the behavior of our steel beam.

In your static structural analysis system in the Workbench project view, double click the Engineering Data cell. This opens up a window titled Outline of Schematic A2: Engineering Data. “Structural steel” is the default material and is always predefined. Click the row beneath (where it says “Click here to add a new material”) and enter any name for your new material.

In the Toolbox to the left, expand the Linear Elastic node and drag and drop Isotropic Elasticity onto the Material column of your material (Figure 8).

Enter the appropriate values into the Properties window (Young’s modulus, Poisson’s ratio), before clicking Return to Project.
A.3 Material Properties Assignment

In the project view, double click the Model cell to launch the Mechanical module. Your geometry should be imported automatically.

Make sure that the correct material model is assigned: In the Mechanical module’s Outline pane (to the left) select the solid body representing the beam (under the Geometry node). Then select the material in the Details pane (Details → Material → Assignment).

A.4 Meshing

The next pre-processing step is concerned with discretizing the continuous solid body geometry, also known as meshing.

The outline tree view also contains a node called Mesh with a little yellow flash symbol. Right click on Mesh and select Insert → Mapped Face Meshing from the context menu (Figure 9). Select all 6 faces of the beam and click Scope → Geometry → Apply in the details pane of the Mapped Face Meshing node.

In the same way, add a Sizing sub-node to the Mesh node. This time, select the whole body and again apply your selection. In the Details pane of the (Body) Sizing node, select Definition → Type → Element Size and set the element size to 15 mm. In the Outline, right click on Mesh → Generate Mesh. The result should resemble Figure 10.
Figure 9: Adding a meshing method

Figure 10: Meshed beam in ANSYS Mechanical (536 elements)
A.5 Applying Loads and Boundary Conditions

We now have to apply the loads and boundary conditions in such a way that the FE model represents our ideas from Figure 2.

We therefore fix all degrees of freedom of one end. In the Outline right click on the Static Structural (A5) node and select Insert → Fixed Support from the context menu. Select an appropriate face of your solid body to be fixed.

Next, we need to apply the force to the other end of the beam. Again, right click on the Static Structural (A5) node, but this time Insert → Force. Select the correct face and apply a force of the appropriate magnitude and direction. The result should resemble Figure 11.

Figure 11: The model after applying loads and boundary conditions
B. Solving
Because this is a simple linear problem, we do not need to modify the solver options manually (Analysis Settings in the Outline). Instead, simply right click on the Static Structural (A5) node and select Solve. This will bring up a status window, which should disappear again after a few seconds of computing.

C. Post-Processing: Evaluating the Solution
The primary results of an FEA are nodal displacements. Strains and stresses are computed on demand as a post-processing step based on the determined displacement field.

C.1 Specifying Result Items
Up until now, ANSYS only offers the solver log under Solution (A6) → Solution Information. To visualize the results we are interested in, add the following Items to the Solution (A6) node (Figure 12):

- Total Deformation
- Normal Elastic Strain (in the beams axial direction)
- Normal Stress (in the beams axial direction)
- Equivalent (von Mises) Stress

Right click on Solution (A6) and select Evaluate All Results.

Figure 12: Analysis outline with added post-processing items
C.2 Total Deformation

When performing FE analyses, it is always wise to first perform some plausibility checking. Create a contour plot of the total deformation (Figure 13).

The predicted displacements seem to be totally fine at first glance. On closer look the maximum total displacement is more than 1000 mm, according to the scale to the left!

The issue with this plot is that by default ANSYS automatically scales the displayed deformations so that they are “easily visible.” For very small displacements this behavior is totally fine, as they wouldn’t be visible at all otherwise. In our case, however, this setting is deceptive. Changing the scaling factor to 1.0 (Results toolbar) yields a completely different picture, making it crystal clear that something has gone wrong – awfully wrong:

![Figure 13: (Scaled) contour plot of the total displacements.](Figure 13)

![Figure 14: (Unscaled) contour plot of the total displacements](Figure 14)
The reason for this huge displacement is that in Table 1, we (deliberately) assumed a much too high force. If we correct the force to be $F = 5000 \text{ N}$ instead, we get the following (unscaled) deformation plot:

![Unscaled deformation plot](image)

**Figure 15:** (Unscaled) contour plot of the total deformations after applying the correct load

### C.3 Visualizing Stresses & Strains

Now that we have corrected our model, we can try to answer the question, whether the beam will be able to resist the given load or if it will fail. For that, create contour plots of the component strain and stress along the $x$-axis to investigate tensile and compressive stresses (Figure 16, Figure 17). For ductile materials like steel, the von Mises yield criterion can be used to predict, whether the material is likely to deform plastically. We therefore also plot the von Mises (equivalent) stresses (Figure 18).

![Elastic normal strain along x](image)

**Figure 16:** Elastic normal strain along $x$

![Elastic normal stress along x](image)

**Figure 17:** Elastic normal stress along $x$
1. Will the beam break? If so, where would it fail?

With the corrected force ($F = 5,000$ N) the beam will not break. The maximal predicted von Mises stress reaches values of $\sigma_{\text{pred}} \approx 220$ N/mm$^2$, and thus less than the ultimate yield stress of $\sigma_{\text{yield}} = 235$ N/mm$^2$. That means the failure criterion $\sigma_{\text{pred}} > \sigma_{\text{yield}}$ is not fulfilled. The difference between the two values however is small ($\sigma_{\text{pred}}$ reaches 94 % of $\sigma_{\text{yield}}$). Many technical applications require a safety factor (SF) of 2.0 or higher. In our example, the safety factor $\text{SF} = \sigma_{\text{yield}}/\sigma_{\text{pred}}$ is much smaller.

The critical region where we would expect the beam to start failing is located at the left end of the half beam, at the location of maximum stresses. For the full length beam the critical region would therefore be located in the middle of the beam where the force was applied.

2. Assuming that it would not fail, what would be the maximum deflection $w$?

We predicted a maximum deflection of $w = 11$ mm appearing at the free end (right side) of the simplified half model. The full length beam under three point bending will show a maximum deflection of the same amount in the middle.
D. Bonus Task: Parameterization & Optimization

Given that we trust the predictions of our model, we now know that the beam can hardly handle the desired load without safety issues. Thus, one might be interested in how the beam has to be changed to meet the safety factor goal of 2.0. In this optional task, we are therefore now going to optimize the thickness of the beam such that we achieve a SF ≥ 2.0 while using a minimum amount of material, as we don’t want to waste expensive steel. This is typical example for a constrained optimization problem.

D.1 Parameterizing the Beam Geometry

First, we have to define the input parameters that the optimization procedure shall optimize later on. For the sake of simplicity, we will only optimize a single parameter, the beam's thickness.

Open the DesignModeler and select the beam primitive from the Tree Outline. In the Details View click the empty box next to the FD8, Diagonal Z Component entry (or whatever component you chose to use as the thickness of the beam); a blue D should now appear inside the box (Figure 19). Then enter an appropriate parameter name into the dialog window and click OK.

As we want the origin to always be located at the center of the cross section, we also need to parameterize FD5, Point 1 Z Coordinate (i.e. the coordinates of the first corner of the box primitive). We will make this a derived parameter (i.e. dependent on BeamThickness) in the next step. For now, perform the same steps as before and call this new parameter something like “BeamZOffset.”

Back in the Project View, you will notice that there appeared an additional Parameter Set block right beneath the Static Structural analysis system. Notice how there is only one arrow going from the Parameter Set to the analysis system; this means that we have defined input parameters so far.
Double click on the Parameter Set block to edit the parameter properties. As BeamZOffset should always be $-\frac{\text{BeamThickness}}{2}$, enter a corresponding arithmetic expression in the properties outline for parameter P2 ($=\text{BeamZOffset}$). Note that you have to use the internal parameter ID P1 instead of BeamThickness (Figure 21).

While we are at it, click on the cell with the light-gray New name entry (ID: New input parameter) to define a new constant. Call it TensileYieldStrength and assign it a value of 235 [MPa] (units must be given in brackets). We will use that later on to compute the safety factor for the current design.
D.2 Output Parameters

To express our objective, we also need an output parameter. Enter the Mechanical module (double click on the Results cell in the Static Structural analysis block). In the details pane of the Equivalent Stress solution item, make the maximum stress an output parameter (Figure 22).

Figure 22: Defining an output parameter
Return to the project view and double click on the **Parameter Set** block. The output parameter P3 - Equivalent Stress Maximum should now be visible under Output Parameters. As we did before with the TensileYieldStrength, define a new derived parameter SafetyFactor as

$$\text{SafetyFactor} = \frac{\text{TensileYieldStrength}}{\text{EquivalentStressMaximum}}$$

(Figure 23).

![Figure 23 Defining the SafetyFactor parameter](image)

### D.3 Optimization

Back in the **Project View** drag and drop the **Response Surface Optimization** system from the **Toolbox → Design Exploration** onto the project schematic (Figure 24).
D.3.1 Design of Experiments

To be able to optimize the BeamThickness based on a response surface (= regression model), we first need to produce some samples (input-output pairs) based on the full FE model. Double click the Design of Experiments cell to define how the BeamThickness input parameter should be sampled (input range, sample size, distribution): First make sure, that you use a Central Composite Design (select the Design of Experiments row in the Outline of Schematic B2, then set the Design of Experiments Type in the Properties windows beneath; Figure 25).
Next, select the input parameter P1 (BeamThickness) and set its lower and upper bound to 20 and 60 respectively (i.e. we assume the optimum thickness is somewhere between 20 and 60 mm; Figure 26).

Figure 26 Defining the optimization domain
TensileYieldStrength is a constant and should not vary. Thus, uncheck the Enabled check box right to the P4 – TensileYieldStrength row in the Outline of Schematic B2: Design of Experiments window.

Right click on the Design of Experiments row and select Update; this generates the five design points (= five samples) and evaluates these five differently parameterized FE models. Afterwards, click Return to Project.

D.3.2 Fitting & Visualizing the Response Surface

In the Project View, double click on the Response Surface cell. In the newly opened Properties of Schematic B3: Response Surface window, make sure that the Response Surface Type (= regression model) under Meta Model is set to Full 2nd Order Polynomials.

Right click on Response Surface and select Update to fit the response surface model to the sample points. When ANSYS is done, select the Goodness of Fit node under the Metrics node. The plot as well as the computed error metrics shows that the quadratic surrogate model is able to predict the behavior of the full FE model (Figure 27).

![Figure 27 Goodness of fit plot (prediction based on the response surface model vs. FE model)](image-url)
We can also plot the created model (= response surface) itself by selecting the Response node from Response Points → Response Point. Set the $x$-axis to BeamThickness and the $y$-axis to Equivalent Stress Maximum to produce a plot resembling Figure 28. From this plot we can already tell, that the ideal thickness should be located somewhere around 35 mm.

![Figure 28 Response surface plot (max. von Mises stress vs. beam thickness)](image)

When you are done investigating the response surface, click Return to Project.

**D.3.3 Defining Objectives and Constraints**

Double click the Optimization cell to configure the optimization options. In the Properties of Schematic B4: Optimization window, select Screening as the Optimization Method and set the Number of Samples to 10,000.

Next, select the Objectives and Constraints row. In the table to the right (Table of Schematic B4: Optimization) add constraints and objectives as shown in Figure 29.
Figure 29 Objectives and constraints definitions

D.3.4 Determining the Optimal Thickness

Then right click on Optimization and select Update to run the optimization procedure. After the optimization is finished, ANSYS by default displays three candidate points (= beam thicknesses) that meet our optimization goals (Figure 30).

Candidate Point 1 seems to be the best bet for an optimum thickness. To check whether this response surface based optimum agrees with the prediction of the FE model, right click on Candidate Point 1 and select Verify by Design Point Update. This will initiate a full FEA using a BeamThickness of 36.55 mm. As it turns out, the predicted safety factor is almost identical with the one determined via the FE model; we can therefore safely accept BeamThickness = 36.55 mm as the optimal beam thickness (Figure 31).