Quartus |1 Introduction Using VHDL Design

This tutorial presents an introduction to the Quartus® Il CAD system. It gives a general overview of a typi-
cal CAD flow for designing circuits that are implemented by using FPGA devices, and shows how this flow is
realized in the Quartus Il software. The design processisillustrated by giving step-by-step instructions for using
the Quartus |1 software to implement avery simple circuit in an Altera FPGA device.

The Quartus Il system includes full support for al of the popular methods of entering a description of the
desired circuit into a CAD system. This tutorial makes use of the VHDL design entry method, in which the user
specifies the desired circuit in the VHDL hardware description language. Two other versions of this tutorial are
also available; one uses the Verilog hardware description language and the other is based on defining the desired
circuit in the form of a schematic diagram.

The last step in the design process involves configuring the designed circuit in an actual FPGA device. To
show how thisisdone, it is assumed that the user has access to the Altera DE2 Development and Education board
connected to a computer that has Quartus Il software installed. A reader who does not have access to the DE2
board will still find the tutorial useful to learn how the FPGA programming and configuration task is performed.

The screen captures in the tutorial were obtained using the Quartus Il version 7.1; if other versions of the
software are used, some of the images may be dlightly different.
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Computer Aided Design (CAD) software makes it easy to implement a desired logic circuit by using a pro-
grammable logic device, such as a field-programmable gate array (FPGA) chip. A typical FPGA CAD flow is
illustrated in Figure 1.
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Figure 1. Typica CAD flow.

The CAD flow involves the following steps:

e Design Entry — the desired circuit is specified either by means of a schematic diagram, or by using a
hardware description language, such as VHDL or Verilog

e Synthesis—the entered design is synthesized into acircuit that consists of the logic elements (LEs) provided
in the FPGA chip

e Functional Simulation —the synthesized circuit istested to verify itsfunctional correctness; this simulation
does not take into account any timing issues



e Fitting — the CAD Fitter tool determines the placement of the LEs defined in the netlist into the LES in
an actual FPGA chip; it also chooses routing wires in the chip to make the required connections between
specific LEs

e Timing Analysis — propagation delays along the various paths in the fitted circuit are analyzed to provide
an indication of the expected performance of the circuit

e Timing Simulation —thefitted circuit istested to verify both its functional correctness and timing

e Programming and Configuration — the designed circuit isimplemented in a physical FPGA chip by pro-
gramming the configuration switches that configure the LEs and establish the required wiring connections

This tutorial introduces the basic features of the Quartus Il software. It shows how the software can be used to
design and implement a circuit specified by using the VHDL hardware description language. It makes use of the
graphical user interface to invoke the Quartus |1 commands. Doing this tutorial, the reader will learn about:

Creating a project

Design entry using VHDL code

Synthesizing a circuit specified in VHDL code

Fitting a synthesized circuit into an Altera FPGA

Assigning the circuit inputs and outputs to specific pins on the FPGA

Simulating the designed circuit

Programming and configuring the FPGA chip on Altera’'s DE2 board

1 Getting Started

Each logic circuit, or subcircuit, being designed with Quartus |1 software is called a project. The software works
on one project at atime and keeps all information for that project in a single directory (folder) in the file system.
To begin anew logic circuit design, the first step is to create a directory to hold its files. To hold the design files
for thistutorial, we will use a directory introtutorial. The running example for this tutorial is a simple circuit for
two-way light control.

Start the Quartus |1 software. You should see a display similar to the one in Figure 2. This display consists
of several windows that provide access to al the features of Quartus Il software, which the user selects with the
computer mouse. Most of the commands provided by Quartus |1 software can be accessed by using a set of menus
that are located below the title bar. For example, in Figure 2 clicking the left mouse button on the menu named
File opens the menu shown in Figure 3. Clicking the left mouse button on the entry Exit exits from Quartus |1
software. In general, whenever the mouse is used to select something, the left button is used. Hence we will not
normally specify which button to press. In the few cases when it is necessary to use the right mouse button, it will
be specified explicitly.
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Figure 2. The main Quartus 1 display.
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For some commands it is necessary to access two or more menus in sequence. We use the convention Menul
> Menu2 > Item to indicate that to select the desired command the user should first click the left mouse button
on Menul, then within this menu click on Menu2, and then within Menu?2 click on Item. For example, File >
Exit uses the mouse to exit from the system. Many commands can be invoked by clicking on an icon displayed in
one of the toolbars. To see the command associated with an icon, position the mouse over the icon and a tooltip
will appear that displays the command name.

1.1 Quartusll OnlineHelp

Quartus Il software provides comprehensive online documentation that answers many of the questions that may
arise when using the software. The documentation is accessed from the menu in the Help window. To get some
idea of the extent of documentation provided, it is worthwhile for the reader to browse through the Help menu.
For instance, selecting Help > How to Use Help gives an indication of what type of help is provided.

The user can quickly search through the Help topics by selecting Help > Search, which opens a dialog box
into which key words can be entered. Another method, context-sensitive help, is provided for quickly finding
documentation for specific topics. While using most applications, pressing the F1 function key on the keyboard
opens a Help display that shows the commands available for the application.

2 Starting a New Project

To start working on a new design we first have to define a new design project. Quartus Il software makes the
designer’stask easy by providing support in the form of awizard. Create a new project as follows:

1. Select File > New Project Wizard to reach the window in Figure 4, which asks for the name and directory
of the project.
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Figure 4. Creation of anew project.



2. Set the working directory to be introtutorial; of course, you can use some other directory name of your
choiceif you prefer. The project must have a name, which is usually the same as the top-level design entity
that will beincluded in the project. Choose light as the name for both the project and the top-level entity, as
shownin Figure 4. Press Next. Since we have not yet created the directory introtutorial, Quartus |1 software
displays the pop-up box in Figure 5 asking if it should create the desired directory. Click Yes, which leads
to the window in Figure 6.
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Figure 5. Quartus I software can create a new directory for the project.
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Figure 6. The wizard can include user-specified design files.

3. Thewizard makesit easy to specify which existing files (if any) should be included in the project. Assuming
that we do not have any existing files, click Next, which leads to the window in Figure 7.
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Figure 7. Choose the device family and a specific device.

4. We haveto specify thetype of devicein which the designed circuit will beimplemented. Choose Cyclone™
Il asthetarget device family. We can let Quartus |1 software select a specific device in the family, or we can
choose the device explicitly. We will take the latter approach. From the list of available devices, choose the
device called EP2C35F672C6 which isthe FPGA used on Altera’'s DE2 board. Press Next, which opensthe
window in Figure 8.
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5. The user can specify any third-party tools that should be used. A commonly used term for CAD software
for electronic circuits is EDA tools, where the acronym stands for Electronic Design Automation. Thisterm
is used in Quartus Il messages that refer to third-party tools, which are the tools developed and marketed
by companies other than Altera. Since we will rely solely on Quartus 11 tools, we will not choose any other
tools. Press Next.

6. A summary of the chosen settings appears in the screen shown in Figure 9. Press Finish, which returns to
the main Quartus |1 window, but with light specified as the new project, in the display title bar, asindicated
in Figure 10.
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Figure 9. Summary of the project settings.
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Figure 10. The Quartus |1 display for the created project.

3 Design Entry Using VHDL Code

Asadesign example, we will use the two-way light controller circuit shown in Figure 11. The circuit can be used
to control asingle light from either of the two switches, x; and x», where a closed switch correspondsto the logic
value 1. The truth table for the circuit is also given in the figure. Note that thisis just the Exclusive-OR function
of theinputs z; and x5, but we will specify it using the gates shown.
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Figure 11. The light controller circuit.

The required circuit is described by the VHDL code in Figure 12. Note that the VHDL entity is called light to
match the name given in Figure 5, which was specified when the project was created. This code can be typed into
afile by using any text editor that stores ASCI|I files, or by using the Quartus I text editing facilities. While the
file can be given any name, it is acommon designers' practice to use the same name as the name of the top-level
VHDL entity. The file name must include the extension vhd, which indicates a VHDL file. So, we will use the
name light.vhd.



LIBRARY ieee;
USE ieee.std_logic _1164.dll ;

ENTITY light IS
PORT (x1,x2: IN STD _LOGIC;
f :OUT STD_LOGIC);
END light ;

ARCHITECTURE LogicFunction OF light IS
BEGIN

f <= (x1L AND NOT x2) OR (NOT x1 AND x2);
END LogicFunction ;

Figure 12. VHDL code for the circuit in Figure 11.

3.1 Usingthe Quartus|l Text Editor

This section shows how to use the Quartus |1 Text Editor. You can skip this section if you prefer to use some other
text editor to create the VHDL source code file, which we will name light.vhd.

Select File > New to get the window in Figure 13, choose VHDL File, and click OK. This opens the Text
Editor window. Thefirst step is to specify a name for thefile that will be created. Select File > Save As to open
the pop-up box depicted in Figure 14. In the box labeled Save as type choose VHDL File. In the box labeled
File name type light. Put a checkmark in the box Add file to current project. Click Save, which puts the file
into the directory introtutorial and leads to the Text Editor window shown in Figure 15. Maximize the Text Editor
window and enter the VHDL code in Figure 12 into it. Save the file by typing File > Save, or by typing the
shortcut Ctrl-s.
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Cancel

Figure 13. Choose to prepare a VHDL file.
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Most of the commands available in the Text Editor are self-explanatory. Text is entered at the insertion point,
which is indicated by a thin vertical line. The insertion point can be moved either by using the keyboard arrow
keys or by using the mouse. Two features of the Text Editor are especially convenient for typing VHDL code.
First, the editor can display different types of VHDL statements in different colors, which is the default choice.
Second, the editor can automatically indent the text on anew line so that it matches the previousline. Such options
can be controlled by the settingsin Tools > Options > Text Editor.

3.1.1 Using VHDL Templates

The syntax of VHDL code is sometimes difficult for a designer to remember. To help with this issue, the Text
Editor provides a collection of VHDL templates. The templates provide examples of various types of VHDL
statements, such as an ENTITY declaration, a CASE statement, and assignment statements. It is worthwhile
to browse through the templates by selecting Edit > Insert Template > VHDL to become familiar with this
resource.

3.2 Adding Design Filesto a Project

Asweindicated when discussing Figure 6, you can tell Quartus Il software which design filesit should use as part
of the current project. To seethelist of filesaready included in thelight project, select Assignments > Settings,
which leads to the window in Figure 16. Asindicated on the left side of the figure, click on the item Files. An
alternative way of making this selection isto choose Project > Add/Remove Files in Project.

11



Settings - light

£

Category:
Files

Libraries Select the design files you want to include in the project. Click &dd &/l to add all design files in the
Device project directory to the project,

Operating Settings and Conditions

Voltage . X
File rarne:
Temperature

=I- Compilation Process Settings File: name Type Library | Design entyés... | HDL version Add Al

Esrly Tirning E stimate light.wid WHDL File <Mores
Incremental Compilation

EDA Tool Settings
Diesign Entry/Synthesis
Simulation
Timing Analysis
Formal Verification
Physzical Synthesis
Board-Level
=1 Analysiz & Synthesis Settings
YHDL Input
Werilog HDL Input
Default Parameters
Synthesiz Netlist Optimizations
=1~ Fitter Settings
Physical Synthesis Optimization
=1 Timing Analysis Settings
TimeGuest Timing Analyzer
=I- Clazsic Timing Analyzer Setting
Claszic Timing Analyzer Re
Agsembler
Design Aesistant — < | >
SignalTap Il Logic Analyzer
Logic Analyzer Interface a

MU

Figure 16. Settings window.

If you used the Quartus Il Text Editor to create the file and checked the box labeled Add file to current
project, as described in Section 3.1, then the light.vhd file is already a part of the project and will be listed in the
window in Figure 16. Otherwise, the file must be added to the project. So, if you did not use the Quartus Il Text
Editor, then place a copy of the file light.vhd, which you created using some other text editor, into the directory
introtutorial. To add thisfile to the project, click on the File name: button in Figure 16 to get the pop-up window
in Figure 17. Select the light.vhd file and click Open. The selected file is now indicated in the Files window of
Figure 16. Click OK to include the light.vhd file in the project. We should mention that in many cases the Quartus
Il softwareis able to automatically find the right files to use for each entity referenced in VHDL code, even if the
file has not been explicitly added to the project. However, for complex projects that involve many filesit isagood
design practice to specifically add the needed files to the project, as described above.
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4 Compiling the Designed Circuit

The VHDL code in the file light.vhd is processed by several Quartus Il tools that analyze the code, synthesize
the circuit, and generate an implementation of it for the target chip. These tools are controlled by the application
program called the Compiler.

Run the Compiler by selecting Processing > Start Compilation, or by clicking on the toolbar icon '® that
looks like a purple triangle. Asthe compilation moves through various stages, its progressis reported in awindow
on the left side of the Quartus 11 display. Successful (or unsuccessful) compilation is indicated in a pop-up box.
Acknowledgeit by clicking OK, which leadsto the Quartus |1 display in Figure 18. In the message window, at the
bottom of the figure, various messages are displayed. In case of errors, there will be appropriate messages given.

When the compilation is finished, a compilation report is produced. A window showing this report is opened
automatically, as seen in Figure 18. The window can be resized, maximized, or closed in the normal way, and it

can be opened at any time either by selecting Processing > Compilation Report or by clicking on theicon <.
The report includes a number of sections listed on the left side of its window. Figure 18 displays the Compiler
Flow Summary section, which indicates that only one logic element and three pins are needed to implement this
tiny circuit on the selected FPGA chip.
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Figure 18. Display after a successful compilation.



41 Errors

Quartus 11 software displays messages produced during compilation in the Messageswindow. If the VHDL design
fileis correct, one of the messages will state that the compilation was successful and that there are no errors.

If the Compiler does not report zero errors, then thereis at least one mistake in the VHDL code. In this case
a message corresponding to each error found will be displayed in the Messages window. Double-clicking on an
error message will highlight the offending statement in the VHDL code in the Text Editor window. Similarly, the
Compiler may display some warning messages. Their details can be explored in the same way as in the case of
error messages. The user can obtain more information about a specific error or warning message by selecting the
message and pressing the F1 function key.

To see the effect of an error, open the file light.vhd. Remove the semicolon in the statement that defines the
function f, illustrating atypographical error that is easily made. Compile the erroneous design file by clicking on
the ® icon. A pop-up box will ask if the changes made to the light.vhd file should be saved; click Yes. After
trying to compile the circuit, Quartus |1 software will display a pop-up box indicating that the compilation was not
successful. Acknowledge it by clicking OK. The compilation report summary, given in Figure 19, now confirms
the failed result. Expand the Analysis & Synthesis part of the report and then select Messages to have the
messages displayed as shown in Figure 20. Double-click on the first error message. Quartus Il software responds
by opening the light.vhd file and highlighting the statement which is affected by the error, as shown in Figure 21.
Correct the error and recompile the design.
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Figure 19. Compilation report for the failed design.
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£@= [ight.vhd Q[E@

1 LIBERARY ieee;
2 USE ieee.std logic 1164.all;
3 EENTITY light I3
4 = PORT (xl,x2 : IN 3TD_LOGIC;
5 f 3 OUT STD_LOGIC):
& END light;
7 B ARCHITECTURE LogicFunction OF light IS
g = BEGIN f<= [x1 AWND MNOT =2)OR(NOT x1 AND x2)
=] END LogicFunction;
£ >

Figure 21. Identifying the location of the error.

5 Pin Assignment

During the compilation above, the Quartus |1 Compiler was free to choose any pins on the selected FPGA to serve
as inputs and outputs. However, the DE2 board has hardwired connections between the FPGA pins and the other
components on the board. We will use two toggle switches, labeled ST, and ST, to provide the external inputs,
x1 and x, to our example circuit. These switches are connected to the FPGA pins N25 and N26, respectively. We
will connect the output f to the green light-emitting diode labeled L E DGy, which is hardwired to the FPGA pin
AE22.

Pin assignments are made by using the Assignment Editor. Select Assignments > Assignment Editor to
reach the window in Figure 22. Under Category select Pin. Double-click on the entry <<new>> which is
highlighted in blue in the column labeled To. The drop-down menu in Figure 23 will appear. Click on z1 asthe
first pin to be assigned; thiswill enter «1 in the displayed table. Follow this by double-clicking on the box to the
right of thisnew x1 entry, in the column labeled Location. Now, the drop-down menu in Figure 24 appears. Scroll
down and select PIN_N25. Instead of scrolling down the menu to find the desired pin, you can just type the name
of the pin (N25) in the Location box. Use the same procedure to assign input 22 to pin N26 and output f to pin
AE22, which resultsin the image in Figure 25. To save the assignments made, choose File > Save. You can also
simply close the Assignment Editor window, in which case a pop-up box will ask if you want to save the changes
to assignments; click Yes. Recompile the circuit, so that it will be compiled with the correct pin assignments.
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Figure 22. The Assignment Editor window.
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Figure 23. The drop-down menu displays the input and output names.
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PIN_MZ3 10 Bank 5 Row IfQ L¥D31ZZn
PIN_M24 Ij0Bank5  Row IjO LYD5125p
PIN_M25 IO Bank 5 Row IjO LVDS125n

Ij0 Bank 2 Dedicated Clock CLE1, LVDSCLKOR, Input

Ij0 Bank 2 Dedicated Clock CLED, LVDSCLKOp, Input

IjOBank 2 Row IO LVDS31p

Ij0Bank5  Row /O LYDS110p

Ij0Bank5  Row IjO LVDS124p

Ij0Bank5  Row IjO LYDS126p, DPCLKZ{DOSORCCLR

IO Bank 5 Row IjO LVDS126n

Dedirated Clock

Ij0 Bank 5 Dedicated Clock n, Input

Ij0 Bank 1 Dedicated Clock CLE3, LVDSCLK LN, Input

Ij0 Bank 1 Dedicated Clock CLEZ, LVDSCLK1p, Input

IJoBank1  RowIfD LYDS26p, DPCLKL/DOSILICOILE

IjO Bank 1 Row IfO LVDS26n

IjO Bank 1 Row IfO LVDS22n

IJoBank1  RowIfD LvDS22p

Ij Bank 2 Row Ij0 LWDS31n v

Figure 24. The available pins.
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Delete Al

--= Double-click ko create a new assignment.,

=
=3
=5
i
I
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=l + Information: | This cell specifies the pin name to which you want to make an assignment.

|
A Edit: M| |<<new>>
|T0 Location If0 Bank 1/ Standard General Function Special Function
1 |1 PIN_NZS 5 3.3 LYTTL Dedicated Clack CLK4, LYDSCLKZD, T
z |2 PIN_NZ6 3 3.3 LYTTL Dedicated Clack CLKS, LYDSCLKZN, 1
3 L F PIN_AEZZ 7 3.5-Y LYTTL Column I LYDS5155n
4 LENEN
< ¥

Figure 25. The complete assignment.

The DE2 board has fixed pin assignments. Having finished one design, the user will want to use the same
pin assignment for subsegquent designs. Going through the procedure described above becomes tedious if there
are many pins used in the design. A useful Quartus Il feature allows the user to both export and import the pin
assignments from a special file format, rather than creating them manually using the Assignment Editor. A ssimple
file format that can be used for this purpose is the comma separated value (CSV) format, which is a common text
file format that contains comma-delimited values. Thisfile format is often used in conjunction with the Microsoft
Excel spreadsheet program, but the file can also be created by hand using any plain ASCII text editor. The format
for the file for our simple project is
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To, Location
x1, PIN_N25
x2, PIN_N26
f, PIN_AE22

By adding linesto the file, any number of pin assignments can be created. Such csv files can be imported into any
design project.

If you created a pin assignment for a particular project, you can export it for use in a different project. To see
how thisis done, open again the Assignment Editor to reach the window in Figure 25. Now, select File > Export
which leads to the window in Figure 26. Here, the file light.csv is available for export. Click on Export. If you
now look in the directory introtutorial, you will see that the file light.csv has been created.

Export Pz|

Save in: |_) introtutarial j £F B
D)db

&

My Recent
Documents

-

Desktop

=]

0>

My Documents

=
=
[l
o
=
=]
=4
@

by Metwork, File name: Iiu:]h j E=port |
Flaces
Save as type: |Eomma Separated Yalue File [* cav] j Cancel

Figure 26. Exporting the pin assignment.

You can import a pin assignment by choosing Assignments > Import Assignments. This opens the dia-
logue in Figure 27 to select the file to import. Type the name of the file, including the csv extension and the full
path to the directory that holds the file, in the File Name box and press OK. Of course, you can also browseto find

the desired file.

Import Assignments @

Specify the source and categories of azsignments to import. Click LogicLock Import File Assignments
to zelect LogicLock Import File[z].

Aszsignment source
+ File name: |

" Use LogicLock Import File Assignments

[v Copy existing assignments into light.gsf bak before imparting

| Cancel

Figure 27. Importing the pin assignment.
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For convenience when using large designs, all relevant pin assignments for the DE2 board are given in the file
called DE2_pin_assignments.csv in the directory DE2_tutorials\design_files, which is included on the CD-ROM
that accompanies the DE2 board and can a so be found on Altera’'s DE2 web pages. Thisfile uses the names found
in the DE2 User Manual. If we wanted to make the pin assignments for our example circuit by importing this
file, then we would have to use the same names in our VHDL design file; namely, S\M(0), S\W(1) and LEDG(0)
for x1, x2 and f, respectively. Since these signals are specified in the DE2 pin_assignments.csv file as elements
of arrays SW and LE DG, we must refer to them in the same way in the VHDL design file. For example, in the
DE2 pin_assignments.csv file the 18 toggle switches are called SM 17] to SMQ]; since VHDL uses parentheses
rather than square brackets, these switches are referred to as SM(17) to SM0). They can aso be referred to as an
array SV(17 downto 0).

6 Simulatingthe Designed Circuit

Before implementing the designed circuit in the FPGA chip on the DE2 board, it is prudent to simulate it to
ascertain its correctness. Quartus Il software includes a simulation tool that can be used to simulate the behavior
of adesigned circuit. Before the circuit can be simulated, it is necessary to create the desired waveforms, called
test vectors, to represent the input signals. It isalso necessary to specify which outputs, as well as possible internal
points in the circuit, the designer wishes to observe. The simulator applies the test vectors to a model of the
implemented circuit and determines the expected response. We will use the Quartus |1 Waveform Editor to draw
the test vectors, asfollows:

1. Open the Waveform Editor window by selecting File > New, which gives the window shown in Figure 28.
Click on the Other Files tab to reach the window displayed in Figure 29. Choose Vector Waveform File
and click OK.

Device Design Files l Other Files ]

AHDL File

Block Diagram/S chematic File
EDIF File

SOPC Builder Spstem

Werilog HOL File

WHOL File

Cancel

Figure 28. Need to prepare anew file.
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2. The Waveform Editor window is depicted in Figure 30. Save thefile under the name light.wwf; note that this
changes the name in the displayed window. Set the desired simulation to run from 0 to 200 ns by selecting
Edit > End Time and entering 200 ns in the dialog box that pops up. Selecting View > Fit in Window
displays the entire simulation range of 0 to 200 ns in the window, as shown in Figure 31. You may wish to

New

Device Design Files  Other Files l

AHDL Include File

Block Symbal File

Chain Description File

Hexadecimal [Intel-Format] File

In-System Sources and Probes Editor File
Logic Analyzer Interface File

tdemory Initialization File

SignalT ap | Logic Analyzer File
Synopsys Design Constraints File

Tel Script File

Teut File

(X

Cancel

resize the window to its maximum size.

Figure 29. Choose to prepare atest-vector file.

B light.vwf 9((=E3
Master Time Bar: 15.95 nz 4| +| Painter: 4.7 nz Interval: 11.25 ns Start: End:
) vaa | PP 100 ns 200 ns |
I 15.95 nz 15.95 ne
(_ |

Figure 30. The Waveform Editor window.
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B light. vwf*

FEX
Master Time Bar: 15.95 nz 1| ¥| Painter: 968 nz Interval: £.27 nz Start: 0ps End: 200.0 nz
0 pz 400 nz 80.0 nz 120.0 ns 160.0 nz 200.0 n4
Walue at i i i i
Name 15.95 nz 15.95 ne
|

3. Next, we want to include the input and output nodes of the circuit to be simulated. Click Edit > Insert >
Insert Node or Bus to open the window in Figure 32. It is possible to type the name of asignal (pin) into
the Name box, but it is easier to click on the button labeled Node Finder to open the window in Figure
33. The Node Finder utility has a filter used to indicate what type of nodes are to be found. Since we are
interested in input and output pins, set the filter to Pins: all. Click the List button to find the input and

Figure 31. The augmented Waveform Editor window.

output nodes as indicated on the | eft side of the figure.

Name: | ok ]
Type: [INPUT | Cancel
Valuetype: | FLevel > Mode Finder..
Fiadix s -]

Bus width: |1

Startindex: |0

[ Display gray code count as binary count

Figure 32. The Insert Node or Bus dialogue.

Node Finder rz|
Mamed: |i j Filter: |Pins: all j Custamize... | List Q QK |
Lock in: jJ V' Include subentities | Cancel |
Modes Found: Selected Nodes:

Mame Aszzignments | Tupe | Mame Aszsighments | Type

>
I f PIN_&E22 Output 9 [lightl1 PIN_N25 Input
| PIN_NZ5 Input [ B lightlx2 PIN_MZ2E Input
2 PIN_N26 Input L lightlf PIN_&E22 Output

<

<<
< > « < >

Figure 33. Selecting nodes to insert into the Waveform Editor.
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Click onthex1 signal inthe Nodes Found box in Figure 33, and then click the > sign to add it to the Selected
Nodes box on the right side of the figure. Do the same for x2 and f. Click OK to close the Node Finder
window, and then click OK in the window of Figure 32. This leaves a fully displayed Waveform Editor
window, as shown in Figure 34. If you did not select the nodes in the same order as displayed in Figure 34,
it is possible to rearrange them. To move awaveform up or down in the Waveform Editor window, click on
the node name (in the Name column) and release the mouse button. The waveform is now highlighted to
show the selection. Click again on the waveform and drag it up or down in the Waveform Editor.

B light.vwf =3
Master Time Bar: 15.95 nz 1| ¥| Painter: 10,08 nz Interval: 5.89ns Start: 0ps End: 200.0 nz
0 pz 400 nz 80.0 nz 120.0 ns 160.0 nz 200.0 n4
N Walue at i i i i
aME | 15,95 ns 15-933 ns
w0 «1 A0
1 %2 A0
£ 2 f A

Figure 34. The nodes needed for simulation.

4. We will now specify the logic values to be used for the input signals x1 and x2 during simulation. The logic
values at the output f will be generated automatically by the simulator. To make it easy to draw the desired
waveforms, the Waveform Editor displays (by default) vertical guidelines and provides a drawing feature
that snaps on these lines (which can otherwise beinvoked by choosing View > Snap to Grid). Observe also
asolid vertical line, which can be moved by pointing to its top and dragging it horizontally. This reference
line is used in analyzing the timing of a circuit; move it to the time = 0 position. The waveforms can be

drawn using the Selection Tool, which is activated by selecting the icon 3 in the toolbar, or the Waveform
Editing Tool, which is activated by theicon #2

To simulate the behavior of alarge circuit, it is necessary to apply a sufficient number of input valuations and
observe the expected values of the outputs. In a large circuit the number of possible input valuations may
be huge, so in practice we choose a relatively small (but representative) sample of these input valuations.
However, for our tiny circuit we can simulate all four input valuations given in Figure 11. We will use four
50-nstime intervalsto apply the four test vectors.

We can generate the desired input waveforms as follows. Click on the waveform name for the x1 node.
Once awaveform is selected, the editing commands in the Waveform Editor can be used to draw the desired
waveforms. Commands are available for setting a selected signal to 0, 1, unknown (X), high impedance (2),
don’t care (DC), inverting its existing value (INV), or defining a clock waveform. Each command can be
activated by using the Edit > Value command, or viathe toolbar for the Waveform Editor. The Edit menu
can also be opened by right-clicking on awaveform name.

Set x1 to 0 in thetimeinterval 0 to 100 ns, which is probably already set by default. Next, set x1 to 1in the
time interval 100 to 200 ns. Do this by pressing the mouse at the start of the interval and dragging it to its
end, which highlights the selected interval, and choosing the logic value 1 in the toolbar. Make x2 = 1 from
50 to 100 ns and also from 150 to 200 ns, which corresponds to the truth table in Figure 11. This should
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produce the image in Figure 35. Observe that the output f is displayed as having an unknown value at this
time, which isindicated by a hashed pattern; its value will be determined during simulation. Save thefile.

B light. vwf*
Master Time Bar: 0pz 4| v| Painter: 166.25 ng Interval: 166.25 ng Start: End:
0 pz 200 nz 400 nz B0.0 nz 80.0 nz 100.0 ns 120.0 ns 140.0 nz 160.0 ns 180.0 ns |
N Value at h h h h i i i i i
ame i 0ps
Ll
0 | A0 |
w1 %2 A0 |
£ 2 f AR
< >

Figure 35. Setting of test values.

6.1 Performingthe Simulation

A designed circuit can be simulated in two ways. The simplest way is to assume that logic elements and intercon-
nection wires in the FPGA are perfect, thus causing no delay in propagation of signals through the circuit. This
is called functional simulation. A more complex alternative is to take all propagation delays into account, which
leads to timing simulation. Typically, functional simulation is used to verify the functional correctness of acircuit
asitisbeing designed. This takes much less time, because the simulation can be performed simply by using the
logic expressions that define the circuit.

6.1.1 Functional Simulation

To perform the functional simulation, select Assignments > Settings to open the Settings window. On the left
side of this window click on Simulator Settings to display the window in Figure 36, choose Functional as the
simulation mode, and click OK. The Quartus || simulator takes the inputs and generates the outputs defined in the
light.wwf file. Before running the functional simulation it is necessary to create the required netlist, which is done
by selecting Processing > Generate Functional Simulation Netlist. A simulation run is started by Process-

ing > Start Simulation, or by using the icon E.. At the end of the simulation, Quartus Il software indicates its
successful completion and displays a Simulation Report illustrated in Figure 37. If your report window does not
show the entire simulation time range, click on the report window to select it and choose View > Fit in Window.
Observe that the output f isas specified in the truth table of Figure 11.
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Settings - light

Category:

|

Libraries A
Device |
=I- Operating Settings and Conditions
Yoltage
Temperature
Compilation Process Settings
Early Timing E stimate
Incremental Compilation
EDA Tool Settings
Design Entry/Synthesiz
Simulation
Timing Analysiz
Formal Verification
FPhysical Synthesiz
Board-Lewvel
Analyzis & Synthesiz Settings
WHOL Input
Werilog HOL Input
Default Parameters
Synthesiz Metlist Optimizations
Fitter Settings
Physical Synthesiz Optimizatio
=I- Timing Analyziz Settings
Timelluest Timing Analyzer
=I- Clazzic Timing Analyzer 5etting
Clazzic Timing Analyzer Re
Azzembler
Dresign Assistant
SignalT ap Il Logic Analyzer
Logic Analyzer Interface
Simulator Settings
PowerFlay Power Analyzer Setting 2

¥

| >

3

Select simulation options.

Simulation mode: |[FfETaE

Simulation input: |Iight.vwf

Add Multiple Files...

Simulation period
(* Run simulation until all vectar stimuli are used

" End simulation at:

Glitch filkering options: |Aut0

More Settings...

Drescription:

Specifies the type of simulation to perform for the curent Simulation focus.

Cancel

=]

Figure 36. Specifying the simulation mode.

Simulation Waveforms
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Figure 37. The result of functional simulation.

6.1.2 Timing Simulation

Having ascertained that the designed circuit is functionally correct, we should now perform the timing simulation
to see how it will behave when it is actually implemented in the chosen FPGA device. Select Assignments >
Settings > Simulator Settings to get to the window in Figure 36, choose Timing as the simulation mode, and
click OK. Run the simulator, which should produce the waveformsin Figure 38. Observe that there is a delay of
about 6 ns in producing a change in the signal f from the time when the input signals, z; and z», change their

values. Thisdelay is due to the propagation delays in the logic element and the wires in the FPGA device.
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Figure 38. The result of timing simulation.

7 Programming and Configuring the FPGA Device

The FPGA device must be programmed and configured to implement the designed circuit. The required configura-
tion fileis generated by the Quartus 11 Compiler’s Assembler module. Altera's DE2 board allows the configuration
to be done in two different ways, known as JTAG and AS modes. The configuration data is transferred from the
host computer (which runs the Quartus Il software) to the board by means of a cable that connects a USB port
on the host computer to the leftmost USB connector on the board. To use this connection, it is necessary to have
the USB-Blaster driver installed. If this driver is not already installed, consult the tutorial Getting Started with
Altera’s DE2 Board for information about installing the driver. Before using the board, make sure that the USB
cable is properly connected and turn on the power supply switch on the board.

In the JTAG mode, the configuration data is |loaded directly into the FPGA device. The acronym JTAG stands
for Joint Test Action Group. This group defined a simple way for testing digital circuits and loading data into
them, which became an |EEE standard. If the FPGA is configured in this manner, it will retain its configuration
as long as the power remains turned on. The configuration information is lost when the power is turned off. The
second possibility is to use the Active Serial (AS) mode. In this case, a configuration device that includes some
flash memory is used to store the configuration data. Quartus Il software places the configuration data into the
configuration device on the DE2 board. Then, this dataisloaded into the FPGA upon power-up or reconfiguration.
Thus, the FPGA need not be configured by the Quartus Il software if the power is turned off and on. The choice
between the two modes is made by the RUN/PROG switch on the DE2 board. The RUN position selectsthe JTAG
mode, while the PROG position selects the AS mode.

7.1 JTAG Programming

The programming and configuration task is performed as follows. Flip the RUN/PROG switch into the RUN
position. Select Tools > Programmer to reach the window in Figure 41. Here it is necessary to specify the
programming hardware and the mode that should be used. If not already chosen by default, select JTAG in the
Mode box. Also, if the USB-Blaster is not chosen by default, press the Hardware Setup... button and select the
USB-Blaster in the window that pops up, as shown in Figure 40.

U light.cdf

éaHardware Setup... USE-Blaster [USE-0] Mode: [ITAG | Progress:

I” Enable realtime ISP ta allow background prograrming [for MAk || devices)

Program/ Blank-
Configure Check

FFFFFFFF ] o O O

P Start |

mow |
*E'ﬂ Auto Detect
g
B Add File...

| < | >

File Uszercode Werify Examine

‘ Checksum

O02F5284

‘ Device

EP2C35FE72

light. zof

Figure 39. The Programmer window.
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Observe that the configuration file light.sof is listed in the window in Figure 39. If thefile is not already listed,
then click Add File and select it. Thisis a binary file produced by the Compiler's Assembler module, which
contains the data needed to configure the FPGA device. The extension .sof stands for SRAM Object File. Note
also that the device selected is EP2C35F672, which is the FPGA device used on the DE2 board. Click on the
Program/Configure check box, as shown in Figure 41.

Hardware Setup

X

Hardware Seftings IJTAG Settings]

Select a programming hardware getup to use when programming devices. This programming
hardware zetup applies only ta the current programmer window.
Currently selected hardware: USB-Blaster [USE-0]
Available hardware items:
Hardware Server | Fart | Add Hardware...
USE-Elaster Local Use-0

Figure 40. The Hardware Setup window.

U light.cdf*

&, Hardware Setup...| | USE-Blaster [USB-0] Mode: [JTAG +| Progress 0%

™ Enable realtime ISP ta allow background prograrring (for MAK || devices)

Wi Start i Checksum Usercode Prog_ram[;
__ light.s0 : i FFFFFFFF

*E'ﬂ Auto Detect

¥ Delete

s Add File...

li= Change File... | F

Figure 41. The updated Programmer window.

Now, press Start in the window in Figure 41. An LED on the board will light up when the configuration data

has been downloaded successfully. If you see an error reported by Quartus |1 software indicating that programming
failed, then check to ensure that the board is properly powered on.

7.2 Active Serial Mode Programming

In this case, the configuration data has to be loaded into the configuration device on the DE2 board, which is
identified by the name EPCS16. To specify the required configuration device select Assignments > Device,
which leads to the window in Figure 42. Click on the Device and Pin Options button to reach the window in
Figure 43. Now, click on the Configuration tab to obtain the window in Figure 44. In the Configuration device
box (which may be set to Auto) choose EPCS16 and click OK. Upon returning to the window in Figure 42, click
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OK. Recompile the designed circuit.
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Figure 42. The Device Settings window.
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Figure 43. The Options window.

26



Device and Pin Options PZ|

Fin Placement ] Error Detection CRC ] Capacitive Loading ] Board Trace Model ]
General  Configuration l Programming Files ] Unuzed F'ins] Dwal-Purpoze F'ins] Voltage]

Specify the device configuration scheme and the configuration device. Mote: For
HardCopy |1, these settings apply to the FPGA prototype device.

Configuration scheme: |Active Serial [can use Configuration Device] j
Configuration mode: | J

Configuration device
v Usze configuration device: Auto j

Auto
EPC51
EPCS4

v Generate compressed bitstreams |EPCSE4

Drescription:

Specifies the configuration device that you want to uge as the means of configuring
the target device.

Reset
(] 8 | Cancel |

Figure 44. Specifying the configuration device.

Therest of the procedure is similar to the one described above for the JTAG mode. Select Tools > Program-
mer to reach the window in Figure 39. In the Mode box select Active Serial Programming. If you are changing
the mode from the previously used JTAG mode, the pop-up box in Figure 45 will appear, asking if you want to
clear al devices. Click Yes. Now, the Programmer window shown in Figure 46 will appear. Make sure that the
Hardware Setup indicates the USB-Blaster. If the configuration file is not already listed in the window, press Add
File. The pop-up box in Figure 47 will appear. Select the file light.pof in the directory introtutorial and click
Open. Asaresult, the configuration file light.pof will be listed in the window. Thisis a binary file produced by
the Compiler’'s Assembler module, which contains the data to be loaded into the EPCS16 configuration device.
The extension .pof stands for Programmer Object File. Upon returning to the Programmer window, click on the
Program/Configure check box, as shown in Figure 48.

'E Some devices in current device list cannot be added to selected programming mode Active Serial Programming. Do you want ko clear all devices in
L

current device list and switch to selected mode?

Figure 45. Clear the previously selected devices.
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Figure 46. The Programmer window with Active Serial Programming selected.
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Figure 47. Choose the configuration file.
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Figure 48. The updated Programmer window.
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Flip the RUN/PROG switch on the DE2 board to the PROG position. Press Start in the window in Figure
48. An LED on the board will light up when the configuration data has been downloaded successfully. Also, the
Progress box in Figure 48 will indicate when the configuration and programming process is completed, as shown
in Figure 49.
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Figure 49. The Programmer window upon completion of programming.

8 Testingthe Designed Circuit

Having downloaded the configuration data into the FPGA device, you can now test the implemented circuit. Flip
the RUN/PROG switch to RUN position. Try all four valuations of the input variables x; and x5, by setting the
corresponding states of the switches SW; and SWy. Verify that the circuit implements the truth table in Figure
11.

If you want to make changes in the designed circuit, first close the Programmer window. Then make the
desired changesin the VHDL design file, compile the circuit, and program the board as explained above.
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