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Introduction
Dear Professors, Department Chairs, and Deans,

We have received many questions from undergraduate and graduate level mechanical 
engineering students in recent years, and probably the most common one is: 

Are there any Adams tutorials that I can use to help me learn the software? 

Adams is the leading multibody dynamics simulation software used extensively by engineers 
in product development within Automotive and other Industrial sectors worldwide to assess 
system performance using computer models before investing in physical prototypes.

Companies in the manufacturing industry tell us that multibody dynamics simulations within 
their engineering departments will increase by 3-5x over the next three years. These same 
companies tell us they have difficulty finding and hiring trained engineers coming out of 
universities today with Adams experience.  

This is a problem we would like to collaborate with you to solve.

The enclosed Adams tutorial package is designed as a supplemental curriculum kit 
for undergraduate Mechanical Engineering courses, including Design of Machinery, 
Dynamics, Vehicle Dynamics, and Mechanical Design. 

There are 44 examples in this Adams tutorial package, including some simple problems 
like “four-bar linkage”, “spring-damper system”, and also some real industrial examples like 

“Open differential” or “Gear Train System”, which are created based on a new powerful set of 
simulation modules in Adams called Adams/Machinery.

Several examples were developed from specific textbook problems, for example, the four 
problems in section III were developed in reference to the textbook Design of Machinery 
(Fifth Edition) by Robert L. Norton.  

We are asking you to use this Adams tutorial package as supplemental learning material 
for the aforementioned courses in your mechanical engineering program today, as a way to 
further develop the skills of your students in engineering simulation, and to prepare them for 
engineering careers in the future.

We are committed to continuing the development of this supplemental curriculum package. 
If you have any questions or requests for us, please contact Yijun.Fan@mscsoftware.com.

Enjoy, 
Adams team at MSC Software

mailto:Yijun.Fan%40mscsoftware.com?subject=
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This section introduces you the fundamentals of Adams/View 

with 14 examples. No previous Adams experience is needed to 

go through this section and detailed guidance is given for each 

example. You are encouraged to work through this section in 

sequential order. In this Beginner’s level, you will learn:

• How to create bodies

• How to connect bodies with joints

• How to create motions

• How to measure displacement, velocity or acceleration

• How to view results

Section I: Beginner’s Level
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Software Version
Adams 2013.2 

Problem Description
Find the displacement, velocity, and acceleration of a stone after 
one second, when the stone with zero initial velocity, falls under the 
influence of gravity. 

Example 1: Falling Stone

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 2. Build the Stone

a. From the Main Toolbox, right-click the Rigid Body tool 
stack, and then select the Sphere tool.

b. Put a check on Radius and set the radius to 5.0cm.

Step 3. Renaming the Stone.

To use the zoom Box shortcut:

a. First right click on the Stone then choose 
Part:PART_2 and click Rename.

b. For the New Name type in .Falling.Stone.

c. Choose Field Info and click Validate.

d. Click OK for Field validation was successful and click 
OK again.

Step 1. Create a New Adams database.

a. Click on Create a new model.
b. For the Model name change it to Falling_Stone.

c. For the Gravity choose Earth Normal (-Global Y).
d. For the Units, set it to MMKS - mm,kg,N,s,deg.

e. Then click OK.

Section I: Beginner’s Level  |  Example 1: Falling Stone
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Step 4. Set Mass to 1 kg

a. Right-click the sphere, point to Part:Stone, and then 
select Modify.

b. Choose User Input on the drop down selection for 
Define Mass by.

c. Type 1.0 for the Mass and click OK.

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 5. Calculate the 
Displacement of the Stone

a. Right-click on the Stone and choose Part:Stone and 
then click on Measure.

b. In the Measure Name text box, enter Displacement 
for the Characteristic, enter CM position for the 
Component, choose Y. Make sure that Create Strip 
Chart is Checked then click OK.

c. A measure stripchart appears. It is empty because you 
need to run a simulation before Adams/View has the 
necessary information for the stripchart.

d. For more Measurements follow the instructions above 
and set Measure Name to Velocity, Acceleration, 
and Characteristic to CM acceleration.

Step 6. Verify the Model.

a. In the right corner of the Status bar, right-click the 
Information tool stack, and then select the Verify tool.

b. In the Information window, check that the model has 
verified Successfully, then click Close.

Section I: Beginner’s Level  |  Example 1: Falling Stone
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Step 7. Set up and Run a Simulation

a. Select the Zoom tool, and then click and drag the 
mouse to the zoom out until the entire working grid is 
visible. Screen click the surface. Click Apply.

b. Select the Translate tool, and then drag the working 
grid to the top of the screen.

c. In the Main Toolbox, select the Simulation tool.
d. In the End Time text box, enter 1.0 and in the Steps 

text box, enter 50.

e. Select the Play tool and when the simulation ends, 
reset the model by selecting the Reset tool.

Step 8. Results

a. To find the Stone’s Displacement after 1 second, first 
right-click the blank area inside the stripchart, then 
choose Plot:scht1 then click on Transfer To Full 
Plot.

b. In Adams/Postprocessor, from the main toolbar, select 
the Plot Tracking tool.

c. Because you want to know the final conditions after 
1 second, move the cursor over the end point of the 
plot. In the area below the menu bar, the value of X is 
displayed as 1. Note the value of Y is -4903.

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Analytical Solution – Verify the results 
by calculating the analytical solution.

a. To find the distance, use y = - (1/2) gt2

b. Substitute: g = 9810 mm/s2 , t= 1 s, in the above 
equation.

c. Results: y = - 4905 

d. The results produced by Adams View is - 4903, this 
shows that the stone is traveling 4903 mm in the 
negative y direction. The hand calculated answer 
and the Adams/View generated answer has a 0.04% 
difference.

Section I: Beginner’s Level  |  Example 1: Falling Stone
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Software Version
Adams 2013.2 

Problem Description
Find the minimum inclination that will ensure that a crate slides off an 
inclined plane, the plane has dimensions of 50 in. by 8 in. by 2 in and 
the crate has dimensions of 12 in. by 8 in. by 4 in. and has a mass of 
100 lbs. The coefficient of static friction (μs) is 0.3 and the coefficient of 
dynamic friction (μd) is 0.25 and gravity is 32.2 ft/sec2. 

Example 2: Inclined Plane

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 2. Adjust the Working Grid.

a. From the Settings menu, select Working Grid.

b. Set Spacing to 1 in. in the x and y direction. 

c. Make sure that the working grid is oriented along the 
Global XY direction (default setting when you open 
Adams/View). The Set Orientation pull-down menu 
allows you to choose Global XY, YZ, XZ, or custom 
orientation. Click Apply and OK. 

Step 1. Create a New Adams database

a. Click on Create a new model. 

b. Under Working Directory, browse to the folder where 
you want to save your model. 

c. Type the name of the new Model name as inclined_
plane and click OK. 

d. Make sure that the Gravity is set to Earth Normal 
(-Global Y) and the Units is set to IPS - inch, lbm, lbf, s, 
deg.

Section I: Beginner’s Level  |  Example 2: Inclined Plane
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Step 3. Constructing the Geometries 
of the Plane and Crate.

a. To create the plane, right-click on the Rigid Body icon 
and select Rigid Body: Box. 

b. Make sure On Ground is selected and enter (50 in) for 
the Length, (3 in) for the Width, and (8 in) for the Depth. 

c. Make sure that the Length, Width, and Depth are all 
checked. Then click on the center of the coordinate 
plane and hit Enter to create the plane. 

d. To create the crate, right-click on the Rigid Body icon 
and select Rigid Body: Box. 

e. Make sure New Part is selected and enter (12 in) for 
the Length, (4 in) for the Width, and (8 in) for the Depth. 
Also make sure that the Length, Width, and Depth are 
all checked. Then position the crate near the end of the 
ramp as shown.

Step 4. Rename the Crate and Ramp 
Geometry and Assign Physical 
Properties to the Objects

a. Right-click on the large box (plane), point to Block: 
BOX_1, and then select Rename. 

b. Enter Ramp, under New Name, and click Apply and 
OK. 

c. Right-click on the smaller box (Crate), point to Block: 
BOX_2, and then select Rename.

d. Enter Crate, under New Name, and click Apply and OK. 

e. Enter the mass of the crate by right-clicking on crate 
and going to Part:Crate, and then selecting Modify. 

f. Set Define Mass By to User Input and in the Mass text 
box, enter 100 lbm. Click Apply and OK. 

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 5. Set the Model’s Inclination Angle.

a. On the file tree to the left, under Bodies>ground right 
click MARKER _1 and select modify. 

b. Under Orientation, input 15.0, 0.0, 0.0 click Apply and 
OK. 

c. Under the Move tool stack, select the Align & Rotate 
tool.

d. Under Angle, input 15 and press Enter. Then click on 
the crate to select it as the object that will be rotated. 

e. Now select the Z-axis of MARKER_1 (MARKER_1.Z) as 
the axis of rotation. It may be easier to rotate the view 
slightly to select the Z-axis. 

Section I: Beginner’s Level  |  Example 2: Inclined Plane
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Step 6. Adding Constraints on the Model.

a. To create a translational joint between the ramp and 
the crate, first go right-click on the Joint tool stack, and 
then select the Translational Joint tool. 

b. Then select 2 Bod-1 Loc and choose Pick Feature. 

c. Then proceed to select the bodies to be constrained by 
clicking on the crate, then the ramp. 

d. Then for location choose Crate.MARKER_2 and then 
MARKER_2.X with the vector point up the ramp. 

Step 7. Taking Measurements for the 
Crate’s Acceleration Along the Ramp

a. Right-click on the crate and go to Part:Crate and then 
Measure. 

b. Under Characteristic select CM acceleration, under 
Component select X. 

c. Under Represent coordinates in: right-click in the 
gray area and select Marker, then Guesses and then 
MARKER_1. Alternatively, you can select Pick and then 
select MARKER_1 in the geometry, which is the corner 
point at the bottom of the ramp. 

d. Click Apply and OK. 

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 8. Verify the Mechanism

a. To verify the mechanism, simulate the model by clicking 
on the “calculator” icon for 1 second and 50 steps. 

b. Find the value of the crate’s constant acceleration and 
verify it by checking without friction in the Closed-form 
solution and making sure the values match. 

Step 9.  Refine the model and 
Add Friction and Simulate

a. Display the joint’s modify dialog box by right-clicking 
on the translational joint and pointing to Joint:JOINT_1, 
and then select Modify. 

b. In the lower right corner of the Modify dialog box, 
select the Friction tool. 

c. Fill in the coefficients of friction (0.3 for the coefficient 
of static friction and 0.25 for the coefficient of dynamic 
friction) and leave the remaining friction parameters at 
their default values. 

d. In the Input Forces to Friction section, clear the 
selection of Bending Moment and Torsional Moment. 
Click OK on both windows. 

e. Simulate the model and note if the create slides off the 
ramp. 

f. Then right-click on the curve in the stripchart, and then 
select Save Curve. 

Section I: Beginner’s Level  |  Example 2: Inclined Plane
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Step 10. Refine the Model 
Again by Changing the Ramp’s 
Rotation Angle to 20°.

a. From the Build menu, select Group and New. 

b. Make a group, named rotated_objects, containing: the 
crate, the joint, and all of the geometry on the ramp 
(including the markers but not the ground), by right 
clicking in the Objects In Group text box and going to 
All and then Browse. 

c. This should bring up the Database Navigator, here 
select the Crate, MARKER_1, MARKER_4 and JOINT_1 
(hold CTRL to select multiple entities) and then click OK 
on both boxes. 

d. Now you can rotate the group, by going to the Main 
Toolbox, and from the Move tool stack, select the 
Precision Move tool . 

e. In the text box to the right of Relocate the, enter the 
group name, rotated_objects. Then click OK on the 
Database Navigator window. 

f. Set the menus in the second row to About the and 
marker. 

g. In the text box to the right of these menus, enter 
MARKER_1. The Precision Move tool rotates objects 
in increments about a specified axis of the marker you 
just selected. 

h. In the Plus/Minus text box, enter 5. 

i. Select the Z-axis box. Note that you can select the 
axis box (X, Y, or Z) to rotate a group to the desired 
orientation. Now, click Close. 

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 11. Find the Inclination Angles 
at which the Crate Starts to Slide.

a. Simulate the model and note if the crate slides off 
the ramp. For an end time of 0.5 seconds, verify that 
the create acceleration vs. time graph matches the 
adjoining figure. 

b. Through trial and error, find the approximate angle at 
which the crate starts to slide off the ramp. Save the 
curve in the graph plot and compare your results using 
Adams/PostProcessor.

Section I: Beginner’s Level  |  Example 2: Inclined Plane
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Analytical Solution

MD ADAMS Simulation Results:

At θ = 15°, a = 0 

At θ = 20°, a = -41.35 in/sec2. 

Max Angle for Crate to Slip (θmax) = 16.8°. a = -19.19 in/
sec2. 

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Software Version
Adams 2013.2 

Problem Description
Create the geometry of the Lift Mechanism and then set the 
constraints of the model and then simulate the model. 

Example 3: Lift Mechanism - Geometry

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 2.  Adjust the Working Grid.

a. From the Settings menu, select Working Grid. 

b. Set the Size in the X direction to 20 m and the Size 
in the Y direction to 20 m and the Spacing in the x 
and y direction to 0.5 m. Since the grid is in meters you 
will probably need to zoom out to see it. 

c. Make sure that the working grid is oriented along the 
global XY direction (default setting when you open 
Adams/View). The Set Orientation pull-down menu 
allows you to choose Global XY, YZ, XZ, or custom 
orientation. Click Apply and OK. 

Step 1. Create a New Adams database

a. To import a file.

b. Click on New model. 
c. Under Working Directory, browse to the folder where 

you want to save your model. 

d. Type the name of the new Model name as lift_mech 
and click OK. 

e. Make sure that the Gravity is set to Earth 
Normal (-Global Y) and the Units is set to MKS - 
m,kg,N,s,deg. 

Section I: Beginner’s Level  |  Example 3: Lift Mechanism - Geometry
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Step 3. Create the Geometry of the 
Lift Mechanism: Create the Base

a. Create the geometry of the lift mechanism based on 
the dimensions on the diagram. For a challenge try to 
recreate the Lift Mechanism yourself and only use this 
guide if you are stuck. We’re going to start with the 
Base first. Select the Rigid Body toolbox and select 
Box. 

b. Then, under Length, enter 12 m, under Height, 
enter 4 m, under Depth, enter 8 m. Make sure all the 
Length, Height, and Depth boxes are checked. 

c. Hit Enter and then right-click on the working grid to 
open the LocationEvent box, here enter 0,-4,0 and 
make sure Rel. To Origin is selected then click Apply. 

Step 4. Create the Geometry of the 
Lift Mechanism: Create the Mount.

a. Select the Rigid Body toolbox and select Box. 

b. Then, under Length, enter 3 m, under Height, enter 
3 m, under Depth, enter 3.5 m. Make sure all the 
Length, Height, and Depth boxes are checked. 

c. Hit Enter and then right-click on the working grid to 
open the LocationEvent box, here enter 9,0,2.25 and 
make sure Rel. To Origin is selected then click Apply. 

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 5. Create the Geometry of the Lift 
Mechanism: Create the Shoulder.

a. Select the Rigid Body toolbox and select Cylinder. 

b. Then, under Length, enter 10 m, under Radius, enter 
1 m. Make sure all the Length and Radius boxes are 
checked. 

c. Hit Enter and then right-click on the working grid to 
open the LocationEvent box, here enter 0.5,1.5,4 and 
make sure Rel. To Origin is selected then click Apply. 

d. Now click on the center of the Mount as shown to 
define the other endpoint of the cylinder. 

Step 6. Create the Geometry of the 
Lift Mechanism: Create the Boom.

a. Select the Rigid Body toolbox and select Cylinder. 
b. Then, under Length, enter 13 m, under Radius, enter 

0.5 m. Make sure all the Length and Radius boxes 
are checked. 

c. Hit Enter and then right-click on the working grid to 
open the LocationEvent box, here enter -4.5,1.5,4 
and make sure Rel. To Origin is selected then click 
Apply. 

d. Now click on the center of either the Shoulder or the 
Mount as shown to define the other endpoint of the 
cylinder. 

Section I: Beginner’s Level  |  Example 3: Lift Mechanism - Geometry
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Step 7. Create the Geometry of the 
Lift Mechanism: Create the Bucket.

a. Select the Rigid Body toolbox and select Box. 

b. Then, under Length, enter 4.5 m, under Height, 
enter 3 m, under Depth, enter 4 m. Make sure all the 
Length, Height, and Depth boxes are checked. 

c. Hit Enter and then right-click on the working grid to 
open the LocationEvent box, here enter -6.75,1.5,2 
and make sure Rel. To Origin is selected then click 
Apply.

Step 8. Apply Fillets on the 
Mount using the Fillet Tool.

a. From the Rigid Body toolbox select the Fillet tool. 

b. Under Radius, enter 1.5 m, and then check the box for 
End Radius and enter 1.5 m. 

c. Then select the edges of the Mount as shown and then 
right-click on it to create the fillets. You may want to 
rotate the view to make this task easier.

Step 9.  Modify the Bucket Using 
the Chamfer and Hollow Tools.

a. From the Rigid Body toolbox select the Chamfer tool. 

b. Under Width, enter 1.5 m. 

c. Then select the edges of the Bucket as shown and 
then right-click on it to chamfer it. You may want to 
rotate the view to make this task easier. 

d. Now under the Rigid Body toolbox, select the Hollow 
tool. 

e. Under Thickness, enter 0.25 m and make sure Inside 
is checked. 

f. Then select the top face of the bucket and then right-
click to hollow it out. You may want to rotate the view to 
make this task easier. 

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   29  MSC Software   |   29

Step 10. Final Model – 
Compare your Model

Section I: Beginner’s Level  |  Example 3: Lift Mechanism - Geometry
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Software Version
Adams 2013.2 

Problem Description
Continuing from the last example where you worked on the 
construction of the Lift Mechanism, add the proper constraints 
and joint motions to your model, as shown in the figure below, and 
successfully run a simulation of your model. 

Example 4: Lift Mechanism - Simulation

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Step 2. Constrain the Base to the Ground.

a. From the Joint toolbox, select Fixed. 

b. Under Construction, make sure 2 Bod-1 Loc, Normal 
to Grid are selected. 

c. Select the Base as the First Body and the Ground as 
the Second Body

d. Select the Midpoint of the Base as the Location. A 
Lock icon should appear indicating that you have done 
this process successful. It may be easier to change the 
view to Wireframe to complete this process. 

• Note: Because of the scale of the model you will 
need to zoom in to see the Lock icon, if you wish to 
make the scale of the Lock Icon larger, right-click on 
Joint:JOINT_1 and then go to Appearance and then 
increase the Icon Scale to 15 and click OK. 

Step 1. Open the File 
Containing your Model

a. Click on Open an existing database. 

b. Under File Name, browse to the folder where your 
model is located, and then click OK. 

c. Then locate the bin file that contains your model, lift_
mech, and click Open. 

Section I: Beginner’s Level  |  Example 4: Lift Mechanism - Simulation
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Step 3. Constrain the Mount to the Base.

a. From the Joint toolbox, select Revolute. 

b. Under Construction, make sure 2 Bod-1 Loc, Pick 
Feature are selected. 

c. Then select the Mount as the First Body and the 
Base as the Second Body, and then select the 
Midpoint of the Mount as the Location. Then select 
the Global Y-Direction as the axis of rotation. A 
Hinge icon should appear indicating that you have 
done this process successful. 

• Note: Because of the scale of the model you will 
need to zoom in to see the Hinge icon, if you wish to 
make the scale of the Hinge Icon larger, right-click on 
Joint:JOINT_2 and then go to Appearance and then 
increase the Icon Scale to 15 and click OK. 

Step 4. Constrain the 
Shoulder to the Mount.

a. From the Joint toolbox, select Revolute. 

b. Under Construction, make sure 2 Bod-1 Loc, Normal 
To Grid are selected. 

c. Then select the Shoulder as the First Body and the 
Mount as the Second Body, and then select the 
Anchor Marker of the Shoulder as the Location. A 
Hinge icon should appear indicating that you have 
done this process successful. 

• Note: Because of the scale of the model you will 
need to zoom in to see the Hinge icon, if you wish to 
make the scale of the Hinge Icon larger, right-click on 
Joint:JOINT_3 and then go to Appearance and then 
increase the Icon Scale to 15 and click OK. 
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Step 5. Constrain the Boom 
to the Shoulder

a. From the Joint toolbox, select Translational. 
b. Under Construction, make sure 2 Bod-1 Loc, Pick 

Feature are selected. 

c. Then select the Boom as the First Body and the 
Shoulder as the Second Body, and then select the 
Midpoint of the Boom as the Location. Then select 
the Global X-Direction as the axis of rotation. A 

“Translational” icon should appear indicating that you 
have done this process successful. 

• Note: Because of the scale of the model you will need 
to zoom in to see the Hinge icon, if you wish to make 
the scale of the “Translational” Icon larger, right-click 
on Joint:JOINT_4 and then go to Appearance and then 
increase the Icon Scale to 15 and click OK. 

Step 6. Constraint the Bucket to the Boom.

a. From the Joint toolbox, select Revolute. 

b. Under Construction, make sure 2 Bod-1 Loc, Normal 
To Grid are selected. 

c. Then select the Bucket as the First Body and the 
Boom as the Second Body, and then select the 
Midpoint of the Boom as the Location. A Hinge 
icon should appear indicating that you have done this 
process successful. 

d. Note: Because of the scale of the model you will need 
to zoom in to see the Hinge icon, if you wish to make 
the scale of the “Translational” Icon larger, right-click 
on Joint:JOINT_5 and then go to Appearance and then 
increase the Icon Scale to 15 and click OK. 

Section I: Beginner’s Level  |  Example 4: Lift Mechanism - Simulation
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Step 7.  Verify your Model.

a. Check model topology by constraints by going to the 
Status bar and then right-clicking on the Information 
tool stack. Then select the Model Topology by 
constraints tool and check to see if everything is 
constrainted properly. 

b. Perform a simulation to visually see if everything is 
constrained correctly. 

Step 8. Add Joint Motions.

a. First, add a motion to the Mount-to-Base joint by 
going to the Motion Driver tool stack and then select 
Rotational Joint Motion. 

b. Under Speed, enter 360d*time. 

c. Then select the Mount-to-Base revolulte joint 
(JOINT_2) to apply. 

d. Click revolute joint motion, then select the Shoulder-to-
Mount revolute joint (JOINT_3) to apply. Choose default 
speed.

e. Now right click this Shoulder-to-Mount joint 
motion in the model tree and click modify, then 
enter -STEP(time,0,0,0.10,30d) in the Speed Box 
(Function(time)). 

Now we will add a motion for the Boom-to-Shoulder joint. 
Under the Motion Driver tool stack, select Translational 
Joint Motion. 

f. Click translational joint, then select the Boom-to-
Shoulder translational joint (JOINT_4) to apply. Choose 
default speed. 

g. Now right click this Boom-to-Shoulder translational 
joint motion in the model tree and click modify, 
then enter -STEP(time,0.8,0,1,5) in the Speed Box 
(Function(time)).  

h. Lastly, we will add a motion to the Bucket-to-Boom 
joint. Once again under the Motion Driver tool stack, 
select Rotational Joint Motion. 

i. Click revolute joint motion, then select the Bucket-to-
Boom revolute joint (JOINT_5) to apply. Choose default 
speed 

j. Now right click this Bucket-to-Boom joint motion in 
the model tree and click modify, then enter 45d*(1-
cos(360d*time)). in the Speed Box (Function(time)).
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Step 9.  Verify the Joint Motions.

a. Check to see if the functions were properly entered 
for each joint by going to Modify and then Impose 
Motion and checking the Function. Also right near 
the joint and check the motion by going to right-
clicking on the Motion then Modify and checking the 
Function(time). If the function box does not have the 
correct function, enter it and click OK. 

b. For example, for the Mount-to-Base joint you can right-
click on Joint:JOINT_2 and then click on Modify

c. Then, click on Impose Motion. 

d. Then make sure that the Function textbox contains 
360d*time, then click OK. 

e. Now right-click on Motion: MOTION_1 and click on 
Modify. 

f. Make sure that the Function(time) textbox contains 
360d*time, and click OK. 

g. Repeat for all joints and motions. 

h. Once you have done that, check the model topology 
by constraints by going to the Status bar and then 
right-clicking on the Information tool stack. Then select 
the Model Topology by constraints tool and verify if the 
joint motions have been applied properly. 
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Step 10. Simulate the Model. 

a. Simulate the model for 5 seconds and 500 steps and 
observe the results.
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Software Version
Adams 2013.2 

Problem Description
Find the initial force supported by the pin at A for a bar that swings in 
a vertical plane, given the initial angular displacement and initial angular 
velocity. Also, find the pendulum frequency. 

Example 5: One-degree-of-freedom Pendulum
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Step 2. Construct the Pendulum Link.

a. From the Main Toolbox, right-click the Rigid Body tool 
stack and select the Link tool. 

b. Then select New Part and under Length, enter 450 mm, 
under Width, enter 20 mm, and under Depth, enter 
27.5 mm. Make sure the Length, Width, and Depth 
boxes are checked. 

c. Click on the origin on the working grid to place the 
pendulum at 0,0,0. 

d. Right-click anywhere on the working grid and a small 
window will appear in the bottom left corner of the 
window, this is called the Location Event window. In 
the Location Event window, enter 450,0,0 as the other 
endpoint and click Apply. 

Step 1. Create a new Adams Database

a. Click on Create a new model.

b. Under Start in, browse to the folder where you want to 
save your model. 

c. Type the name of the new Model name as pendulum 
and click OK. 

d. Make sure that the Gravity is set to Earth Normal 
(-Global Y) and the Units is set to MMKS - 
mm,kg,N,s,deg. 
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Step 3. Construct the Bob of the Pendulum

a. From the Main Toolbox, right-click on the Rigid Body 
tool stack, and then select the Sphere tool. 

b. Make sure Add To Part is selected and enter 25 mm for 
the Radius. 

c. Then select PART_2, the link, as the part you are going 
to add the sphere to. 

d. Then, in the Location Event window enter 450,0,0 as 
the center of the sphere and click Apply . 

Step 4. Rename the Pendulum.

a. Right-click on the link and point to Part:PART_2 and 
then select Rename. 

b. In the New Name text box, enter .pendulum.pendulum, 
and then click OK. 

Step 5. Assign Physical 
Properties to the Pendulum.

a. Right-click on the pendulum and go to Part: pendulum 
and then select Modify. 

b. Set Define Mass by to User Input and in the Mass text 
box, enter 2.0. In the Inertia text boxes (Ix, Iyy, Izz), 
enter 0. 

c. Then, right-click the Center of Mass Marker text box, 
and go to pendulum.pendulum.cm and then go to 
Modify. 

d. In the Location box, enter 450,0,0, then click OK and 
OK. If you get a warning message about the change in 
position of your center of mass marker, simply ignore it 
and click Close. 
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Step 6. Build the Pivot.

a. In the Main Toolbox, right-click the Joint tool stack, and 
then select the Revolute joint tool. 

b. In the container, select 2 Bod-1 Loc and Normal to 
Grid. 

c. Select the pendulum as the first body. 

d. The ground as the second body. 

e. Then select 0,0,0 as the location in the Location Event 
Window and click Apply. 

f. Right-click on the joint and go to Joint:JOINT_1 and 
then select Rename. 

g. In the New Name text box, enter .pendulum.pivot, and 
then click Apply and OK. 

Step 7.  Create Measures 
for the Pendulum.

a. Right-click on the pivot joint, and go to Joint:pivot, and 
then select Measure. 

b. In the box, where it says Measure Name, enter pivot_
force_x. Set Characteristic to Force, and select X as 
the Component. Make sure .pendulum.MARKER_4 
and Create Strip Chart are selected, and click Apply. 

c. Again in the box, where it says Measure Name, enter 
pivot_force_y. Set Characteristic to Force, and select Y 
as the Component. Make sure .pendulum.MARKER_4 
and Create Strip Chart are selected, and click Apply 
and Cancel. 
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Step 8.  Create a Reference Marker.

a. In the Main Toolbox, right-click on the Rigid Body tool 
stack, and select the Marker tool. 

b. Make sure Add to Ground and Global XY are selected. 
Right click in the window to invoke the Location Event 
and select 0,-450,0 as the marker location. The result 
would look like the first picture below. Notice the green 
marker beneath the pendulum. 

c. With the marker selected, go to Edit and select 
Rename. 

d. In the New Name text box, enter .pendulum.ground.
angle_ref, and then click Apply and OK.

Step 9.  Create an Angle Measure.

a. From the Design Exploration menu, go to Measure and 
then go to Angle and click Advanced. 

b. In the Measure Name text box, enter pend_angle. 

c. Then, right-click the First Marker text box, and go to 
Marker, and then go to Pick. 

d. Go to the working grid, and pick a marker that is on the 
pendulum, which is also located at its end, for example, 
select the cm marker. If multiple markers are coincident, 
right click at the location and a selection box will be 
invoked where you can choose among them. 

e. Right-click the Middle Marker text box, go to Marker, 
and then go to Pick. 

f. Then, pick a marker that is at the location of the pivot. 
(Marker_1). 

g. Right-click the Last Marker text box, go to Marker, and 
then go to Pick. 

h. Pick the marker that is on the ground and at the end of 
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the pendulum, the marker that you just created in the 
previous step, .pendulum.ground.angle_ref. Then click 
Apply and Cancel. 

Step 10. Add the Initial Conditions 
to the Pendulum Model.

a. Right-click on the pivot joint, and go to Joint:pivot, and 
then go to Modify. 

b. Go to Initial Conditions and in the Joint Initial 
Conditions dialog box, select Rot. Displ and enter -85 
in the text box. Then click OK and OK. This will make 
the pendulum to oscillate with a small displacement of 
5 degrees. 
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Step 11. Simulate the Model.

a. Verify the model.Refer to Example 1, Step 6 if 
necessary. 

b. Simulate your model for 2 seconds with 100 steps 
using the Simulation tool. 

Step 12. Using ADAMS/PostProcessor, 
Determine the Global Components 
and the Frequency of the Pendulum.

a. Right-click the blank area inside the pend_angle graph, 
and go to Plot: scht1 and then go to Transfer to Full 
Plot. 

b. You should now be in the Adams/PostProcessor. Now, 
select the Plot Tracking tool. 

c. To determine the Global Components, move the cursor 
over the plot to where t=0 and make note of the value 
of Y. 

d. In the dashboard, go to Clear Plot. 

e. Set the source to Measures, and from the Measure 
list, select pivot_force_x and select Surf. 

f. Move the cursor over the plot where t=0, and make 
note of the value of Y. 

g. From the Measure list, select pivot_force_y. 

h. Move the cursor over the plot where t=0, and make 
note of the value of Y. 

i. To determine the frequency, from the Measure list, 
select pend_angle. 

j. Estimate the period of the curve, then find the 
reciprocal of the period to determine the frequency. 
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Analytical Solution – Verify the Results 
by Calculating the Analytical Solution.

• The period of a simple pendulum is T= 2π(L/g)^0.5. 
Plug in L=0.45m and g=9.8m/s2, we get T=1.346s 
which matches the result of Adams simulation (Check 
the figure above).

• The verification of the forces is left to the student as a 
practice.
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Software Version
Adams 2013.2 

Problem Description
A stone is projected from the ground with initial velocity of 6m/s and 60 
degree above the ground.

Example 6: Projectile Motion
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Step 2. Adjust the Working Grid.

a. From the Settings menu, select Working Grid. 

b. Set the Size in the X direction to 4000 mm and the 
Size in the Y direction to 3000 mm and the Spacing in 
the x and y direction to 50 mm.

c. Make sure that the working grid is oriented along the 
global XY direction (default setting when you open 
Adams/View). The Set Orientation pull-down menu 
allows you to choose Global XY, YZ, XZ, or custom 
orientation. Click Apply and OK.

Step 1. Create a new Adams Database

a. Click on Create a new model.

b. Under Working Directory, browse to the folder where 
you want to save your model. 

c. Type the name of the new Model name as projectile_
motion and click OK. 

d. Make sure that the Gravity is set to Earth Normal 
(-Global Y) and the Units is set to MMKS - 
mm,kg,N,s,deg. 
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Step 3. Constructing the Geometries 
of the Plane and the Stone.

a. To create the plane, right-click on the Rigid Body icon 
and select Rigid Body: Box. 

b. Make sure On Ground is selected and enter (3500 
mm) for the Length, (100 mm) for the Height, and 
(100 mm) for the Depth. Also make sure that the 
Length, Width, and Depth are all checked. 

c. Then, right-click on the working grid and then enter in 
the coordinates for the corner of the plane: 0,-150,0 
and then click Apply. 

d. To create the spherical stone, right-click on the Rigid 
Body icon and select Rigid Body: Sphere. 

e. Make sure New Part is selected and enter (50 mm) for 
the Radius. Also make sure that Radius is checked. 
Then on the working grid select the origin (0,0,0) as the 
center of the sphere. 

Step 4. Rename the Stone and Plane 
Geometry and Assign Physical 
Properties to the Objects.

a. Right-click on the box (plane), point to Block: BOX_1, 
and then select Rename. 

b. Enter Plane, under New Name, and click Apply and 
OK. 

c. Right-click on the sphere (stone), point to 
Part:PART_2, and then select Rename. 

d. Enter Stone, under New Name, and click Apply and 
OK. 

e. Enter the mass of the stone by right-clicking on sphere 
and going to Part:Stone, and then selecting Modify. 

f. Set Define Mass By to User Input and in the Mass 
text box, enter 1.0 kg. Click Apply and OK. 
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Step 5. Set Initial Conditions.

a. Right-click on the stone and go to Part:Stone and 
then select Modify. 

b. Under Category select Velocity Initial Conditions. 

c. Check X Axis and then enter (6*cos(60d)(m/sec)), 
and then check Y Axis and enter (6*sin(60d)(m/sec)). 
Click Apply and OK. 

Step 6. Create Measures for 
the Projectile Motion.

a. Right-click on the stone and select Part:Stone and 
then select Measure. 

b. In the Measure Name text box, enter R_
displacement. Set Characteristic to CM Position 
and Component to X. 

c. Make sure Create Strip Chart is checked and select 
OK. 

Step 7. Simulate the Model.

a. From the Main Toolbox, select the Simulation tool. 

b. In the End Time text box, enter 1.5 and in the Step 
Size text box enter 0.02. Then click on the Play button. 

c. After the end of the simulation, click on the Reset tool.
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Step 8. Use Animation Tools to 
Determine the Time at which the Stone 
Makes Contact with the Plane.

a. From the Main Toolbox, select the Animation tool. 

b. Select the Play tool and click on Stop when the stone 
makes contact with the plane. Use the Step Forward 
and Step Backward tools, if needed, to facilitate this 
step. Make note of the time at which the stone makes 
contact with the plane on the graph. 

c. Click on the ellipses above the Icons button and then 
change No Trace to Trace Marker. 

d. In the box, below Trace Marker, right-click and go to 
Marker and select Browse. 

e. In the Database Navigator, under Stone, select cm and 
then click OK. 
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Step 9. Using ADAMS/Post Processor, 
determine the range, R.

a. To find the Stone’s Displacement after 1 second, first 
right-click the blank area inside the stripchart, then 
choose Plot:scht1 then click on Transfer To Full Plot.

b. In Adams/Postprocessor, from the main toolbar, select 
the Plot Tracking tool.

c. Because you want to know the final conditions after 
1 second, move the cursor over the end point of the 
plot. In the area below the menu bar, the value of X is 
displayed as 1. Note the value of Y is 3000.

Analytical Solution – Verify the Results 
by Calculating the Analytical Solution.
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Software Version
Adams 2013.2 

Problem Description
Find the force in spring damper at static equilibrium. 

Example 7: Spring Damper - Part 1
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Step 2.  Build the Rigid Body.

a. From the Main Toolbox, right-click the Rigid Body tool 
stack, and then select the Rigid Body: Box tool. 

b. Create a Rigid Body:Box by clicking on the grid. The 
dimension of the box is not important, so just create 
any type of box. 

c. Right-Click on the Box and choose Part:PART_2 : 
Modify. Input the Mass as 187.224. 

d. After inputing the Mass, click OK. 

Step 1. Create a new Adams Database

a. Click on New model. 
b. For the Model name change it to spring_mass. 

c. For the Gravity choose Earth Normal (-Global Y). 
d. For the Units, set it to MMKS - mm,kg,N,s,deg. 

e. Then click OK. 
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Step 3. Constrain the Block to 
Move Only in the yg Direction.

a. First right-click on the screen and choose Rotate XY 
then rotate the model until it is similar to the view below. 
It is best to check the translational joint that will be 
created by rotating the model to make sure that it is fix 
in the yg direction. 

b. Now click on Joint: Translational. 
c. Choose the Rigid Body : Box, when it says “Select 

the first body” on the bottom of the screen. 

d. Choose the Ground, when it says “Select the 
second body” on the bottom of the screen. 

e. Choose the PART_2.cm, when it says “Select the 
location” on the bottom of the screen. 

f. Choose the cm.X, when it says “Select the direction 
vector” on the bottom of the screen. 

g. To verify the expected behavior, simulate the model by 
clicking on the Interactive Simulation Controls. 

h. Click on the Play icon to run the simulation and click 
on the Reset icon.
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Step 4. Move the Working Grid.

a. To ensure that the spring damper is aligned with the Yg 
direction, move the working grid to the cm of the Box. 
First click on Settings: Working Grid.... 

b. Change Set Location to Pick. 

c. Pick on the cm of the Box. 

d. Click OK. Now the working grid is in the center of the 
box. 
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Step 5.  Add the Pre-Defined 
Spring Damper

a. Click on the Translational spring damper. 
b. Input the K value of 5 and the C value of 0.05. 

c. Choose the PART_2.cm, when it says “Select the 
first point” on the bottom of the screen. 

d. Right-click anywhere on the ground to display the 
Location Event. Enter 0, 400, 0, and change Rel. to 
Origin to Rel. to Grid. 

e. Click Apply. 

Step 6. Verify the Distance 
of the Spring Damper.

a. Click on Tools and choose Measure Distance.... 

b. Click on First Position and choose cm, because this 
is the position where one of the spring end is located. 

c. Click on Second Position and choose MARKER_5, 
because this is the position where the other spring end 
is located. Then click OK. 

d. Verify the value of Y. 
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Step 7. Finding the Force in Spring 
Damper at Static Equilibrium

a. Select Interactive Simulation Controls on the Main 
Toolbox. 

b. Select the Static Equilibrium tool. 

c. Select Force Graphics... under Settings on the Main 
Menu. 

d. Put a check on Display Numeric Values on the 
Force Graphics Settings. 

e. Click OK. Zoom out until you can see the force value. 
As shown the force in the spring damper at static 
equilibrium is 1836.04 N.

Analytical Solution – Verify the Results 
by Calculating the Analytical Solution.

• The block’s mass is 187.224 kg. 

• Therefore, to balance the force of gravity, the spring 
damper must generate: 

• 187.224 kg * 9806.65 mm/s2 = 1836.04 N

• The results produced by Adams View are the same as 
the hand calculated answer. 
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Software Version
Adams 2013.2 

Problem Description
Replace the Spring Damper with a Single-Component Force. Create 
a Length vs Force Plot. Find the Static Equilibrium using the Single-
Component Force.  

Example 8: Spring Damper - Part 2
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Step 1. Replace the Spring Damper

a. Right Click on the Spring, choose Spring: SPRING_1, 
and click on choose Delete. 

b. Click on the Forces Tab and go to Applied Force: 
Force (Single-Component). 

c. Change the Run-time Direction to Two Bodies, for 
the Characteristic choose K and C and input K=5.0, 
C=0.05. 

d. Then click on PART_2 for the action body. 

e. Then click on ground for the reaction body. 

f. Then click on PART_2.cm for the action point. 

g. Then click on any point on the global y-axis for the 
reaction point. The user can right click in the window to 
invoke LocationEvent or simply snap on a point using 
the working grid.
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Step 2.  Simulate the Model.

a. Right-click on the Force: SFORCE_1 and select 
Measure. 

b. Change the Measure Name to spring_force. 

c. Change the Characteristic to Force. 

d. Change the Component to mag then click OK. 

e. Follow similar procedures to create a displacement 
measure of SFORCE. Change the characteristic to 
displacement. Change the Measure Name to spring_
length.

f. Go to the Simulation Tab and click on Run a 
Scripted Simulation (Calculator Icon). 

g. Click on Interactive. 

h. Change the End Time to 2. 

i. Change the Steps to 50. 

j. Then click on Start or continue simulation. 

Step 3. Creating Length 
(mm) vs. Force (N) Plot.

a. First right-click Plot, choose Plot: scht1 then click on 
Transfer To Full Plot. 

b. Click on Clear Plot. 
c. Click on Data. 

d. In the Independent Axis Browser, click on Spring_
length in the Results Set and Q in the Component. 

e. Click OK. 

f. Click Add Curves. 
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Step 4. Finding the Static Equilibrium 
of the Single-Component, 
Action-Reaction Force.

a. Finding the Static Equilibrium of the Single-
Component, Action-Reaction Force

b. To view the force at static equilibrium click on the Static 
Equilibrium tool. As you can see the value of the 
Force generated is the same as the Force generated 
by the Spring Damper. 
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Analytical Solution – Verify the Results 
by Calculating the Analytical Solution.

• The block’s mass is 187.224 kg. 

• Therefore, to balance the force of gravity, the spring 
damper must generate: 

• 187.224 kg * 9806.65 mm/s2 = 1836.04 N

• The results produced by Adams View is the same as 
the hand calculated answer. 
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Software Version
Adams 2013.2 

Files Needed
• suspension_parts_starts.cmd
• Located in the directory 

exercise_dir/Example 9

Problem Description
Inspect the toe angle that the wheel exhibits throughout its vertical 
travel of 80 mm in jounce and rebound. The given model is a 
geometric representation of a short-long arm (SLA) suspension 
subsystem. 

Example 9: Suspension System 1
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Step 2.  Import the Model.

a. To import the model, first click on File and then choose 
Import. 

b. Now click on the File To Read. 

c. For the file choose and Open suspension_parts_starts.
cmd. 

d. Then click OK. 

Step 1. Creating a New Database.

a. Click on Create a new model.  
b. First, change the Model name to Suspension. 

c. For the Gravity choose Earth Normal (-Global Y). 
d. Change the units to MMKS-mm,kg,N,s,deg. 

e. Choose the directory where you want to save the 
model and then click OK. 
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Step 3. Create a Spherical Joint.

a. First, right-click on the screen, choose Shaded. 

b. Click on Joint and choose Joint:Spherical. 
c. For the Construction pick 2 Bod-1 Loc and choose 

Normal To Grid for the First Body choose Pick 
Body and the Second Body choose Pick Body. 

d. Choose the Spindle_Wheel for the first body. 

e. Pick the Tie_Rod for the second body. 

f. For the location choose ground.HP8. 
g. If you are not sure where ground.HP8 is, go to the 

model tree, expand the ground folder and highlight 
HP8. The hard point will be hilighted in the view 
window. The proceed to step e. when you are prompt 
to select the marker, right click at the area where HP8 
is and select it from the select list window that pops 
out.

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   65  MSC Software   |   65

Step 4. Create a Hooke Joint.

a. Click on Joint and choose Joint:Hooke. 

b. For Construction choose 2 Bod-1 Loc and choose 
Pick Feature. For the First Body and Second Body 
choose Pick Body.  

c. Click on the Tie_Rod when selecting the first body. 

d. Click on the steering_rack when selecting the second 
body. 

e. Click on the ground.HP7 when selecting the location. 

f. Click on HP8 when selecting the first direction vector. 

g. Click on HP13 when selecting the second direction 
vector. 
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Step 5. Create a Point Motion.

a. First, click on Motion ribbon and choose Point 
Motion. 

b. Under Construction, choose 1 Location, Bodies 
implied

c. Choose the Spindle_Wheel.Center when selecting 
the location. 

d. Choose the Center.Y when selecting direction vector. 
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Step 6. Modify the Motion 
to a Specific Function.

a. Right-click on the Wheel.Center choose 
Motion:MOTION_1 and then click on Modify. 

b. Click on the Function (time). 
c. Modify the “Define a runtime function” to 

80*SIN(360d*time). Click on SIN under the Math 
Functions when inputting a SIN function. Then click 
OK. 
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Step 7. Modify the Translational 
Joint to be a Fixed Joint.

a. Right-click on the Joint: rck_body_joint then click on 
Modify. 

b. Change the Type to Fixed.  

c. Click OK. 

Step 8. Verify and Simulate the Model.

a. First, click on the Interactive Simulation Control. 
b. Change the End Time to 10 and change the Steps to 

500.  

c. Then click on Start Simulation. Now you have 
completed creating a Spherical Joint, Hooke Joint 
and Point Motion on this suspension subsystem.
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Software Version
Adams 2013.2 

Files Needed
• wheel.slp
• Knuckle.slp
• Located in the directory 

exercise_dir/Example 10

Problem Description
Use the model you built in the previous workshop (Suspension System 
I) to inspect the toe angle that the wheel exhibits throughout its vertical 
travel of 80 mm in jounce and rebound. Note: you can either use your 
own model created in Example 9 or use the start file in the directory.

Example 10: Suspension System 2
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c. Now change the Measure Name to .suspension.
Wheel_Height. 

d. Change the “To Point” to Center. This can be typed 
in or double click on it to choose it from the Database 
Navigator. As for the “From Point” double click, 
choose WH_ref from the Database Navigator and 
click OK. 

e. Then choose Y for the Component. 
f. Choose Cartesian. 

g. Click OK. 

h. Click on the Interactive Simulation Controls. 

i. Change the End Time to 1.0 and the Steps to 50. 

j. Click on Start Simulation. As you can see a plot of 
Time vs Displacement in the Yg direction has been 

created. 

Step 1. Open an Existing Database.

a. First, choose Existing Model. 
b. Under File Name, locate the suspension_start.cmd 

file. 

c. Then click OK. 

Step 2. Create Point-to-Point Measure.

a. To find the relative wheel displacement in the Yg 
direction, click on the Design Exploration tab, then 
choose Measure, pick Point-to-Point and click on 
New.... 

b. Click on Advanced. 
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Step 3. Use a Function Measure 
to Create a Toe Angle.

a. Using an Adams/Solver function measure, create 
a toe angle measure using the markers Spindle_
Wheel.Center and Spindle_Wheel.TA_ref. First 
click on Build, choose Measure, click on Design 
Exploration and then click on Create a New 
Function Measure.

b. Input ATAN(DZ(Center,TA_ref)/DX(Center,TA_ref) 
for Create or Modify a Function Measure, choose 

ATAN under the Math Functions. 
c. Change the Measure Name to .suspension.Toe_

Angle and change the Units to angle. 

d. Click on Verify then click OK when the Function 
syntax is correct. 

e. Click OK. 

f. Click on the Start Simulation. 

g. Click on Close to close the plots. 
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Step 4. Plot Toe Angle 
versus Wheel Height.

a. Click on Results and go to Opens Adams/
PostProcessor. 

b. For the Dependent Axis under Measure choose Toe_
Angle and then click on Data for the Independent Axis. 

c. Choose Last_Run for Simulation and choose Wheel_
Height for Measure. 

d. Click OK then click on Add Curves.

e. Close the plotting window.
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Step 5. Importing the Knuckle and Wheel.

a. Now, you’ll import more realistic, CAD-based spindle/
wheel geometry. First click on File and choose Import. 

b. Choose Render(*.slp) for File Type. 

c. Choose the appropriate location by clicking on File to 
Read. Choose the file wheel.slp then click Open. 

d. Change the Part Name to Spindle_Wheel you can 
screen pick this by right-clicking and choose Part and 
click on Guess. Then click Apply. 

e. Change File to Read by right-clicking and choose 
Browse.... 

f. Choose knuckle.slp then click Open. 

Step 6. Turn off Spindle Geometry.

a. Turn off the appearance of Adams/View spindle 
geometry so that only the CAD geometry is visible. First 
click on Appearance... under the Edit menu. 

b. Hold on the Shift key and choose CYLINDER_1, 
CYLINDER_1_2, SPHERE_1, FRUSTUM_1, 
FRUSTUM_2, FRUSTUM_3, FRUSTUM_4, REV and 
click OK. 

c. Click on Off for Visibility, then click OK. 

d. To rotate the model, click on R on the keyboard or 
right-click on the screen and choose Rotate. 
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Step 7. Simulate the Model.

a. First, click on the Interactive Simulation Control. 
b. Change the End Time to 5.0 and the Steps to 500. 

c. To simulate the model click on Start Simulation. 
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Problem Description
Use Adam/View to
• Create a marker
• Change angle units
• Add motion

Use Adams/PostProcessor to
• Create center of mass angular velocity measurements

Software Version
Adams 2013.2 

Problem Description
In the four-bar linkage shown, control link OA has a counterclockwise 
angular velocity omega = 10 rad/s during a short interval of motion. 
When the link CB passes the vertical position shown, point A has 
coordinates x = -60 mm and y = 80 mm. By means of vector algebra, 
determine the angular velocity of AB and BC. 

This problem asks for the rotational velocity of segment BC when it is 
in the pictured position given a constant and known rotational velocity 
for segment OA. We will use ADAMS to create a model with the given 
conditions and collect the data needed. 

Example 11: Four Bar Velocity

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   77  MSC Software   |   77

Step 2. Create a Marker

a. Press F4 to Open Coordinate Window

b. From Bodies ribbon, select Construction 
Geometry: Marker 

c. Create a marker at each of the following 
coordinates: O (0, 0, 0); A (-60, 80, 0); B (180, 180, 
0); C (180, 0, 0) 

Step 1. Creating the Model

a. Start Adams/View. 
b. Create a new model. (Model Name = Fourbar, Units 

= mmks, Gravity = none) 
c. Modify the spacing of the Working Grid (X = 10mm, 

Y= 10mm) 
d. Click Units from Settings menu

e. Select Radian from Angle pull down menu

f. Click OK
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Step 3. Create Links and Joints

a. From Bodies ribbon, double click RigidBody: 
Link

b. Create links OA, AB, and BC, using the markers 
as end points. 

c. From Connectors ribbon, double click Create a 
Revolute joint

d. Make revolute joints between two links at points 
A and B, and between link and ground at O and C. 

Step 4. Add Motion

a. From Motions ribbon, select Rotational  
Joint Motion

b. Enter (1rad) in Rot.Speed text field 

c. Select joint at point O
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Step 5. Testing the Model

a. From Simulation ribbon, select Run an 
Interactive Simulation

b. Set End Time to 10 and Step Size to 0.1
c. Click Start, 
d. Click Plotting
e. Create a CM position plot for link OA in X component

f. Create a CM angular velocity plot for LinkAB and 
LinkBC in mag component

g. Use the Plot tracking tool
h. Follow the plot curve. Find the angular velocity at X = 

0.0 

Results

Theoretical Solution

Adams solution
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Workshop Objectives
Use Adams/view to

• Create different shapes using the open and closed splines
• Add constraints (joints): revolute joint, translational joint and a 2D 

curve-curve constraint
• Create a rigid body: box
• Measure

Software Version
Adams 2013.2

Example 12: Cam-Follower
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Step 3. Closed Body Spline

a. Under the Bodies ribbon, click on Spline
b. Select New Part from Spline pull down menu

c. Turn on checkbox next to Closed. 

d. Click on the 13 points in the table below.

e. Right click to create a closed spline

• *Note that the first point and the last point have the 
same coordinates to create a closed spline.

f. An alert box will appear warning you that the part has 
no mass. Close the box.

• *If your part’s geometry does not match the illustration, 
it can be fixed by clicking and dragging any of the “hot 
points” (rectangular boxes) to its proper location 

Step 1. Getting Started:

a. Start Adams/View
b. Select New model button.

c. Enter cam_follower as Model Name
d. Choose a Location to save your files

e. Verify the Gravity text field is set to Earth Normal 
(-Global Y). 

f. Verify that the Units text field is set to MMKS - 
mm,kg,N,s,deg. 

g. Select OK. 

Step 2. Settings Grid Size:

a. Click Settings menu, then Working Grid…

b. The Working Grid Settings window will appear

c. Change the Spacing text fields in X and Y to (10mm)
d. Click OK.
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Step 4. Create Revolute Joint

a. Under the Connector ribbon, select Revolute 
Joint 

b. Verify that the Construction text fields read 2 Bod-1 
Loc. 

c. Left-click on any blank area in the working window 
(ground)

d. Left click on your cam 

e. Click on the position (0,-130,0) 

Step 5. Open Body Spline

a. Select the Spline tool   

b. Turn on checkbox next to Closed. 

c. Click on the 27 points in the table below.

d. Right click to create a closed spline

• *Note that the first point and the last point have the 
same coordinates to create a closed spline.
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Step 6. Create Box

a. Select the Box. 

b. Select Add to Part from Box menu

c. Click on the Open Body Spline in the working area to 
select the part to add to. 

d. Click on the left end of the open spline (-250,50,0). 
e. Click on (250,180,0).

Step 7. Create Cylindrical Joint

a. Select the Joint:Cylindrical tool.   

b. Set that the Construction text fields to  
1 Location 

c. Click on PART_3.cm
d. Move the cursor in the positive Global Y axis until an 

arrow pointing straight up appears. Click once. 

e. Make sure the arrow is parallel to the Y axis. This arrow 
determines the direction of the translational joint.
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Step 8. Create Curve-on-Curve Contact

a. Select the Cam 2D Curve-Curve Constraint tool

b. Click on the cam part

c. Click on the follower

Step 9. Add Rotational Joint Motion

a. Select the Rotational Joint Motion   
b. In the Speed text field, enter (360d) to set the 

motion displacement to be 360 degrees/second. 

c. Left-click on the revolute joint.

Step 10. Verify

a. Right-Click on the Information Icon in the bottom 
right corner of the Working Window  

b. Left-click on the Verification Icon 

c. After seeing that the model has verified successfully, 
click on the cose button.

Step 11. Measure

a. Right click the follower part and choose measure. 

b. The Part Measure dialog box appears. 

c. Select CM Position from Characteristic pull down 
menu and select Y for the Component entry to 
measure the displacement in the Y direction. 

d. Click Apply. 

e. A graph window appears. This is where data will be 
displayed. 

f. Repeat, step b & c, except use CM Velocity for 
Characteristic. 

g. Repeat, step b & c, except use CM Acceleration for 
Characteristic. A new graph window will appear for 
each new measure. 

h. After the three graph windows are created, click Cancel 
to close the dialog box
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Step 12. Simulation

a. Click on the Simulation tool in the Toolbox. 

b. Enter 1 in End Time text field

c. Change Steps to Step Size, enter .01 in the text 
field

d. Click on the Play icon. 

e. You should see the cam rotate about the pivot and the 
follower slide along its translational joint.

f. When the simulation ends, click on the Rewind 
icon

Step 13. Plotting

a. To get a closer look at a plot, click on a blank area 
inside the small plot window with the right mouse 
button and follow the pull right menu. Select Transfer 
to Full Plot.

b. The ADAMS Plot Window will open, replacing the 
modeling window. To return to the modeling window, 
go to the File pull-down menu and select Close Plot 
Window or press F8 or click on the Return to modeling 
environment button

Step 14. Viewing Plots

a. Select Objects for the source text field

b. Choose a Filter (Body, Force. Constraint)
c. Choose an Object
d. Choose a Characteristic
e. Choose a Component
f. Select Surf if you would like to replace the curve in 

the Plot Window, or select Add Curves to add more 
curves to the window

Step 15.Saving

a. Return to ADAMS modeling window

b. Under the File pull-down menu, select Save Database 
As…

c. In the text field next to File Name, enter the name you 
wish to give this model, for example, cam. 

d. Select OK.

e. A binary file (.bin) has been created in the folder you 
choose when opening ADAMS
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Workshop Objectives
Use Adams/View to

• Create a revolution
• Create a Point-to-Point measure
• Create a measure about an axis
• Create an angular velocity measure about an axis
• Create an angular acceleration measure about an axis

Software Version
Adams 2013.2 

Example 13: Crank Slider
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Step 1. Creating the Model

a. Start Adams/View 
b. Create a new model. (Model Name = slider_crank, 

Units = mmks, Gravity = -y earth) 
c. Resize the working grid, Size = X – 375mm, Y – 

250mm, Spacing X – 5mm, Y – 5mm
d. Open Coordinate Window
e. Create crank part from point (60, 0, 0) to (150, 0, 0)
f. Rename .slider_crank.crank 

Problem Description

Pin A moves in a circle of 90-mm radius as 
crank AC revolves at a constant rate beta-
dot = 60 rad/s. The slotted link rotates about 
point O as the rod attached to A moves in 
and out of the slot. For the position beta=30 
degrees, determine r-dot, r-double dot, theta-
dot, theta-double dot. 

This problem asks for the translational speed 
and acceleration of the slider rod and the 
angular speed and acceleration of the 
slider assembly at a given crank angle of 30 
degrees and crank angular velocity of 60 
radians per second. To solve this, we will 
build an ADAMS model of the crank and 
slider assembly based on the information 
given and measure the data we want using 
an ADAMS simulation of the model.

Problem 2/163 from J. L. Meriam and L. G. Kraige, Engineering 
Mechanics: Volume 2, Dynamics 3rd edition. John Wiley & Sons, 
Inc.

Copyright © 1992, by John Wiley & Sons, Inc. 

This material is used by permission of John Wiley & Sons, Inc
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Step 2. Creating Revolution

a. Select Rigid Body:Revolution
b. Click points: (55 0 0), (-150 0 0), (55 -5 0), (55 

-10 0), (-150 -10 0), (-150 -5 0), (55 -5 0)
c. Right-click to close

d. Rename .slider_crank.cylinder

Step 3. Creating Joints

a. Select Rigidbody:Cylinder 
b. Create piston part. (cylinder, length = 200 mm, 

radius = 5 mm, from (60, 0, 0) to (-140, 0, 0)), 
c. Rename .slider_crank.piston
d. Create revolute joints between crank and 

ground

e. Create spherical joint between cylinder and 
ground

f. Create translational joint between piston and 
cylinder. 

g. Create Hooke joint between crank and piston
h. Add Rotational joint motion to revolute joint with 

function = -30deg - 60 * time.
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Step 4. Create Point-to-Point Measure

a. From Design Exploration ribbon, select Point-
to-Point Measure

b. Select Displacement as Characteristic
c. Select GloabalZ as Component.
d. Select the Marker at the left end of cylinder and the 

Marker at the left end of crank
e. Rename it as MEA_PT2PT_R

Step 5. Create Point Measure

a. Under the piston tree in the Model Browser, right-
click cm and select Measure

b. Select Translational Velocity and select Z 
Component.

c. Enter cylinder.cm as Represent coordinates
d. Select any Marker belongs to the ground as DO time 

derivatives in.
e. Repeat the above steps to create a translational 

acceleration.

Step 6. Create Angle about Axis Measure

a. In the Bodies tree, right-click the spherical joint 
between cylinder and the ground

b. Select info and remember the name of I Marker and J 
Marker.

c. Close the info window.

d. Select Function Measure
e. Select Angle about Z under Displacement and enter 

the marker name in Step b.

f. Select angle as units
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Step 7. Testing the Model

a. From Simulation ribbon, select Run an Interactive 
Simulation

b. Set End Time to 0.01 and Step Size to 0.001, and 
then click Start 

c. Click Plotting
d. Use the Plot tracking tool
e. Follow the plot curve. Find the size measurement at X 

= 0.0

Results

Theoretical Solution

 

ADAMS solution

r = 2.266m 

r-dot = 3.58 m/s, 

r-double dot = 316 m/s^2, 

Theta = 11.46deg 

theta-dot = 17.86 rad/s, 

theta-double dot = -1510 rad/s^2 
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Workshop Objectives
Use Controls Toolkit in Adams/View

• Create an input-signal block
• Create a summing-junction block
• Create a gain block
• Modify torque function

Software Version
Adams 2013.2 

Files Required
• Lift_Mechanism_start.cmd
• Located in the directory 

exercise_dir/Example 14

Example 14: Controls Toolkit in ADAMS/View
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Step 1. Importing a command file (.cmd)

a. Start with New Model
b. Select File, and then select Import.
c. Right-click File To Read text field, select Browse
d. Locate saved file Lift_Mechanism_start.cmd
e. Click Open
f. Click OK

Problem Description
This example provides a simple introduction 
to the Controls Toolkit that is integrated into 
ADAMS/View. This example closely follows 
the process outlined in the ‘Using the Control 
Toolkit’ section of the ADAMS/View guide. 
Model consists of two moving parts, one 
imposed motion, and one single-component 
torque.

Boom - is constrained to the ground with a 
Revolute Joint and a Joint Motion that makes 
it oscillate. 

Bucket - is constrained to the Boom with 
a Revolute Joint. There is also a TORQUE 
between the Bucket and the Boom that has 
a magnitude of 0 right now. This is where 
we will be giving the output of our controls 
blocks. 

Notice as you run a simulation the Boom 
rotates according to the function on the 
joint motion, while the Bucket just randomly 
oscillates. We are going to use the Controls 
Toolkit to keep the bucket at a horizontal 
orientation with respect to the ground. 

Our Controls Block Diagram will look like this: 
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Step 2. Creating Input-Signal Block

a. From Element ribbon, click Controls Toolkit
b. Click input-signal block tool

c. Enter .Lift_Mechanism.theta_desired in 
Name text field

d. Enter 0.0 in Function text field, and then click Apply
e. Click input-signal block tool again

f. Enter .Lift_Mechanism.theta_actual in Name 
text field

g. Click Function Builder button

h. Select Displacement from pull down arrow

i. Click Angle about Z, and then click Assist
j. Right-click in To Marker text field click Marker → 

Browse 

k. Click Torq_I_mar, and 
then click OK

l. Right-click in From 
Marker text field click 
Marker → Browse

m. Click ref_mar, and then 
click OK

n. Make sure the Define a 
runtime function text 
field reads AZ(Torq_I_mar, 
ref_mar)

o. Click OK

Step 3. Create a Summing-Junction Block

a. Click summing-junction block tool

b. Enter .Lift_Mechanism.theta_sum
c. Right-click in Input 1 text field, select  

controls_input → Guesses → theta_desired
d. Right-click in Input 2 text field, select  

controls_input → Guesses → theta_actual
e. Click OK

Step 4. Create a Gain Block

a. Click gain block tool 

b. Enter .Lift_Mechanism.theta_gain
c. Right-click in Input text field, select controls_sum → 

Guesses → theta_sum
d. Enter 1e9 in the Gain text field

e. Click OK
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Step 5. Modify Torque Function

a. Right click on torque icon, select Torque: 
TORQUE → Modify

b. Click Function Builder button next to Function 
text field

c. Select Measure from Getting Object Data pull down 
arrow

d. Right click in text field, select Runtime_Measure → 
Guesses → theta_gain

e. Click Insert Object Name
f. The name of the measure should appear in the editor 

above

g. Click OK

Step 6. Verify and run Simulation

a. Click Simulation tool

b. Click verify
c. Make sure there are no redundant constraints 

and only 1 Degree of Freedom

d. Click Close
e. Select Duration from pull down menu, and enter 2
f. Select Steps from pull down menu, and enter 

100
g. Click Play button
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In this section, you’ll work on four more complex Adams 

examples compared to the first section. 

The purpose of this section is to reinforce what you have 

learned in Section I. If you are an experienced Adams user, you 

can start from this section to get familiar with the new interface 

and to learn some more advanced skills in Adams/View, for 

instance:

• How to create contacts

• How to use function measurement

• Optimization analysis

Section II: Intermediate Level

Control

Parcels

Stamp

Inking Pad

Conveyor
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Workshop Objectives
Use Adams/View to manipulate, inspect, simulate, and animate the 
valvetrain mechanism. 

Software Version
Adams 2013.2

Software Version
• valve.cmd
• Located in the directory exercise_dir/Example 15

Example 15: Valvetrain Mechanism
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Step 1. Import File

To import a file.

a. Start Adams/View. 

b. From the Welcome dialog box, select Existing Model.
c. Click the file folder icon, and the Select Directory 

dialog box appears.

d. Find and select the directory Exercise_dir/mod_2_
aview_interface.

e. Click OK.

f. Click on the file folder icon of the File Name, select the 
file valve.cmd  and click Open.

g. Click OK on the Open Existing Model dialog box.

Step 2.  View the List of 
Keyboard Shortcuts

To view the list of keyboard shortcuts:

a. Move the cursor away from the model and then right-
click in the Adam/View window. A menu appears listing 
the keyboard shortcuts.  

b. To close the menu, left-click away from the menu. 

c. In the space below, write the shortcut keys for 
performing the following view operations.

a. Rotate: 

b. Translate: 

c. Zoom with a box: 

d. Zoom into a specific Area: 

e. Fit: 

f. Front View: 

Problem Description
• The model represents a valvetrain 

mechanism.
• The cam is being rotated at a given velocity.
• The rod (follower) moves translationally 

based on its constraint to the cam.
• The rocker pivots about a pin attached to 

the engine block.
• The spring is always in compression to try 

and keep the rod in contact with the cam.
• The valve moves vertically as the rocker 

rotates.
• When the valve moves, it lets small 

amounts of air into the chamber below it 
(not modeled here).
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Step 3. Use the Zoom Box Shortcut

a. To use the zoom Box shortcut:

b. Zoom into the cam area by using the shortcut <w>.

c. Notice the instructions in the status bar instruct you to 
select the area.

d. Click the left mouse button in the place where you want 
the top left corner of your zoomed in rectangle to be. 

e. Now the status bar instructs you to: drag to select size 
of view.

f. Draw a rectangular box around the cam. 

g. You should now be zoomed into the cam area.

h. Use the fit shortcut <f> to return to the original view. 

Step 4. View the Model 
from Different Angles

To view the model from the top:

a. Use the Top shortcut <T> and the view changes to a 
top view.

To view the model from the right:

b. Use the Right shortcut <R> and the view changes to 
the right view. 

To view the model in an isometric view:

c. Use the Iso shortcut <I> and the view changes to an 
isometric one. 

If you wish you may continue to try the other shortcut keys.
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Step 5.  Rename the Parts

As you go through these instructions notice that right-
clicking always give you a list of choices while left clicking 
selects an object.

To rename the parts to match the ones given in the 
diagram to the right:

a. From Model Browser, select the part displayed 
under the Bodies tree. Same part will be selected and 
highlighted.

b. Right click and select Rename from the displayed 
menu. 

c. In the Rename dialog box, change the name 
according to the given diagram.

d. Click OK to change the part name. 

e. Repeat the above steps a through e for the Rod, Cam, 
Guide, and Valve.
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Step 6. Inspect the Model

To inspect the model to determine the number and type of 
constraints:

a. Right-click the small arrow on the Information tool 
stack on the right side of the Status Bar at the bottom 
of the screen.

b. Select the Model topology by constraints tool.

c. From the Information window that appears, note 
the number and type of constraints and use them 
to answer Question 1 in the Workshop 2, Review 
section, page WS2-19

d. Close the Information window.

To inspect the mode to check if the model verified 
successfully:

e. Right-click the small arrow at the bottom of the 
information tool stack.

f. Select the verify tool. 

g. From the Information window that appears, notice that 
the model verified successfully.

h. Close the Information window.
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Step 7.  Simulate the Model

To run a simulation:

a. Select the ribbon Simulation.

b. From the options available select “Run an Interactive 
Simulation.”

c. In the Simulation Control dialog box select End 
Time.

d. In the text box adjacent to End Time, enter 2.

e. In the text box adjacent to Steps enter 100.

f. Click on the Play tool.

g. When the simulation is complete, click the Reset tool.

Step 8. Save the Simulation

To save the simulation:

a. To save the last simulation results to the database 
under a new name, select the Save simulation tool. 
The Save Run Results dialog then appears

b. In the Name text box, enter a name for the simulation 
results, such as first_results.

c. Click OK.

d. Close the Simulation Control dialog box.
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Step 9. Animate the Results

To animate the results in the default mode with icons off:

a. Switch to Animation Controls from Simulation 
Control.

b. To see the animation, click the Play button.

c. When the animation is complete, click the Reset tool.

d. To see the animation in incremental steps click either 
the +Inc to move forward or the -Inc to rewind the 
animation.

e. The step number will be listed in the center between 
these two buttons. 

f. When finished, click the Reset tool. 

To animate the model with icons turned on:

g. At the bottom of the Animation Controls dialog box, 
check icons.

h. Repeat the step from b. to f.

i. Close the Animation Controls dialog box. 

Step 10. Save Your Work

To save your work so that the saved file contains only the 
model information:

a. From the File menu, select Export.
b. Set File Type to Adams/View Command File.

c. In the File Name Text box, enter valve1.

d. In the Model Name text box, enter valve.

e. Click OK.

Since this is the last step for the workshop, you may 
manipulate the model and experiment with it as time 
permits.
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Workshop Questions

How many constraints are there in this system? What type of constraints are they?  
  
  
  
  
 

Is it possible to have more than one model in a database? 
  
  
  
  
  
 

Is geometry a direct child of a model? If not, what is  
geometry a child of?  
  
  
  
  
 

If you are in the middle of an operation and you are not sure what input Adams/View wants 
next, where should you look?  
  
  
  
  
 

If you are working with our technical support staff and you want them to look at one of your 
files, what file format would you send them, a .cmd or .bin? Why?  
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Software Version
Adams 2013.2 

Files Required
• valve_train_start.cmd
• Located in 

exercise_dir/Example 16

Workshop Objectives
Design a cam profile based on desired valve displacement, and ensure 
that there is no follower liftoff when the cam is rotated at 3000 rpm.

Example 16: Cam-rocker-valve
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Step 1. Import File

To import a file.

a. Open Adams/View from the directory exercise_dir/
Example 16.

b. From the directory exercise_dir/Example 16, import 
the model command file valve_train_start.cmd.

c. The file contains a model named valve_train.

Problem Description
• The model represents a valvetrain 

mechanism.
• The cam is being rotated at a velocity of 1 

rotation per second.
• The rocker pivots about a pin attached to 

the engine block (ground).
• The valve displaces up and down as the 

rocker moves.
• When the valve moves, it lets small 

amounts of air in the chamber below it (not 
modeled here).
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Step 2.  Apply a Motion

a. From the ribbon Motion select Translation Motion 
tool to add a motion to the joint, Valve_Ground_Jt.

b. Use the STEP function below to define the 
displacement. Add the two STEP functions together 
such that the final function looks as follows:

a. STEP(time, .4, 0,.6,13) + STEP(time,.6,0,.8,-13).
b. Enter this function in the Function(time) textbox, 

on the Joint Motion dialog. 

c. From ribbon simulation, select Interactive Controls.
d. From the simulation control Run a 1-second, 100-

step simulation to verify that the valve displaces as a 
result of the joint motion.

Step 3. Create a Cam Profile

Use a point trace to create a cam profile:

a. To use a point trace: From the ribbon Results, select         
Create Trace Spline.

b. Select the circle on the rod, rod.CIRCLE_1 and then 
the part named cam.

c. Verify that you now have a spline representing  
the cam profile.

d. Run a simulation to verify that the Rod appears to 
move along the surface of the Cam.
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Step 4. Constrain the Rod to the Cam

To constrain the rod:

a. Delete the joint motion on the joint, Valve_Ground_Jt.
b. From the ribbon Connectors, select  Curve-Curve 

Constraint tool to create a curve-on-curve constraint 
between the circle on the Rod (CIRCLE_1)  and the 
cam profile on the Cam. (GCURVE_232) Note that the 
number may vary.

c. Run an interactive simulation to verify that the new 
constraint works.

Step 5. Measure the Force

Measure the force in the curve-on-curve constraint. To 
measure the force:

a. Create a force measure for the curve-on-curve 
constraint.  Right-click the constraint and then select 
Measure. 

b. Measure the force along the z-axis of ref_marker, 
which belongs to the rod:

• Characteristic: Force
• Component: Z
• Represent coordinates in: ref_marker
c. A strip chart for the measure will be displayed.

(Note: The curve-on-curve constraint applies a negative 
force that keeps the rod follower on the cam, avoiding any 
liftoff.)
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Step 6. Replace the Curve-
On-Curve Constraint

Make the cam-to-rod contact more realistic by replacing 
the curve-on-curve constraint with a Point-to-curve 
contact force. To replace the curve-on-curve constraint:

a. Deactivate the curve-on-curve constraint you created 
in Step 4 on page WS21- 9.

b. From the ribbon Force, select create a contact.
c. Use the following contact parameters:

• Contact Name:cam_
contact

• Contact Type: Point to 
Curve

• Marker: ref_marker

• Curve: GCURVE_201

• Normal Force: Impact

• Stiffness (K): 1e6 (N/
mm)

• Force Exponent (e): 1.5

• Damping (C): 10 (N-sec/
mm)

• Penetration Depth (d): 
1e-3 mm

• Friction Force: Coulomb

• Coulomb Friction: On

d. Use the following contact parameters continued:

• Static Coefficient (μs): 0.08

• Dynamic Coefficient (μd): 0.05

• Stiction Transition Vel. (vs): 1 (mm/sec)

• Friction Transition Vel. (vt): 2 (mm/sec)

e. Use the Change Direction tool next to the Directions 
textbox, to make sure that the normal arrow points 
outward from the curve (GCURVE_232) as shown to 
the right.

f. Run an Interactive simulation to check if liftoff 
occurs. 
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Step 7. Create a Spring

Since lift off still occurs, to prevent it create a spring 
damper:

a. To add a marker on the valve at the location, Valve_
Point: 
From ribbon Bodies, select Construction  
Geometry: Marker

• Add to Part

• From the screen, select valve and the location Valve_
Point.

b. From the ribbon Forces, select create Translational 
Spring-Damper. Add a spring damper between the 
marker you just created and the point, Ground_Point 
(which is a point on ground, at the top of the guide), 
using the following parameters:

• Stiffness (K): 20 (N/mm)

• Damping (C): 0.002 (N-sec/mm)

c. To add a preload to the spring you must modify the 
spring, use a pre-load of 100 N.

Step 8. Find Static Equilibrium

To find the static equilibrium of the model:

a. From the ribbon simulation, select Interactive 
Simulation. Click Find Static Equilibrium. Do not 
reset the model before going on to the next step. 

b. Run a dynamic simulation to view the effects of the 
spring starting from static equilibrium.

c. Modify the rotational motion on the cam. 

d. The speed should be 3000 rpm, so enter the 
displacement function as -50*360d*time.

e. To view only one rotation of the cam, run a static 
equilibrium followed by a dynamic simulation for 
end=1/50 seconds, steps=100.  Note: an easy way 
to run this simulation sequence is to create a simulation 
script. 
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Step 9. Create a Measure 
on the Contact Force

To create a measure on the contact force:

a. From the ribbon Design Exploration, select Create 
new Function Measure

b. Change the units to force. 

c. Use the category Force in Object, select Contact 
force and click on Assist tab.

d. Fill out the contact Force dialog as shown below.

e. Your function should look like the one shown below in 
the Function Builder.

f. Remember to Verify the function before clicking OK.

g. Rerun the simulation to populate the new measure strip 
chart.

Step 10. Modify the Spring 
Damper to Prevent Liftoff

a. Modify the spring-damper characteristics (stiffness, 
damping, and preload) to prevent liftoff based on the 
new rotational speed of the cam. Note: Experiment 
with different values until the no-lift criteria is met.

b. Save the model.
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Step 11. Create and Swap the 
Flexible Part using ViewFlex

You will use the ViewFlex utility to convert the rigid valve 
part to a flexible valve part and transfer the constraints 
acting on the rigid body to the flexible body. 

To create and swap the flexible part:

a. From the ribbon Bodies, select Rigid to Flex.
b. From the Make Flexible select Create New
c. Right-click in the Part to be meshed field and select 

the Valve part.

d. Check Advanced Settings to open more settings

e. Select Size option in the Element Specification
f. Set the element size =2 and minimum size = 0.5
g. Click OK.

h. The Rigid valve is now replaced by Flexible valve as 
shown below
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i. From the Tools menu, select Database Navigator.
j. Change Browse to Graphical Topology.

k. Highlight Valve_flex part.

l. Notice that the joints and spring are now attached to 
the flexible valve part.

Step 12.  Run a Simulation and Save

a. To view only one rotation of the cam, run a static 
equilibrium followed by a dynamic simulation for 
end=1/50 seconds, steps=100.

b. Use Adams/PostProcessor to investigate how the 
flexible body affects the model.

a. Does lift off occur in the model now?  
 

c. Save the model

d. dIf you want to further explore the model, as suggested 
in the next section, leave the model open.  Otherwise, 
Exit Adams/View.
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Workshop Questions

How many DOF are removed by adding a curve-on-curve constraint?  
  
  
 

How many DOF are removed by a curve-to-curve force?  
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Workshop Objectives
To understand the virtual prototyping process by improving the design 
of the stamping mechanism.

Software Version
Adams 2013.2 

Files Required
• aview.cmd
• Located in the directory 

exercise_dir/ Example 17

Problem Description
• This model represents a mechanism for stamping parcels that are 

moving along a conveyor belt.
• During the work cycle, the stamp does not contact the parcels that 

it is supposed to label.
• To fix this design flaw, modify the length of the control link.

Example 17: Stamping Mechanism
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Step 3. Simulate the Model

a. To simulate the model:

b. From the Stamper menu, select Simulate. The 
Stamper_Simulate dialog box appears.

c. To simulate the current design variation, ensure that 
Single is selected.

d. Note: The default setting for Model Update is set to 
Never. If you were to change Model Update from 
Never to At Every Output Step the model would 
update on the screen but would not solve faster.

e. To solve the equations of motion for the current design, 
select Apply. 

f. When a single simulation is completed, Adams/
View tells you what the penetration was during the 
simulation.  A positive number indicates penetration. To 
continue, click OK. 

g. Leave the Stamper_Simulate dialog box open, and 
continue with the next step.

Step 1. Import File

To import a file.

a. Start Adams/View. 

b. From the Welcome dialog box, select Existing Model.
c. Click the file folder icon, and the Select Directory 

dialog box appears.

d. Find and select the directory Exercise_dir/
Example17.

e. Click OK.

f. Click on the file folder icon of the File Name, select the 
file aview.cmd and click Open. 

g. Click OK on the Open Existing Model dialog box.

Step 2. Change the Length 
of the Control Link

To change the length of the control link:

a. From the Stamper menu, select Setting Up Model. 
The Stamper_Setup dialog box appears.

b. Use the left and right arrow buttons to modify the 
length of the control _link.

a. The buttons shift the location of the top of the 
control_link upward and downward 3 mm at a time.

b. The parts connected to the control link are 
parameterized in such a way as to move the 
appropriate amount automatically whenever you 
adjust the length of the control link.

c. Watch the model change as you press these buttons.

d. To reset your model to the original configuration, select 
Reset. Leave the Stamper_Setup dialog box open, 
and continue with the next step.
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Step 4. Investigate the Results

To investigate the results:

a. From the Stamper menu, select Investigate Results. 
The Stamper_Investigate dialog appears.

b. To see the motion resulting from the last simulation, 
select Animate Results. 

c. If necessary, use the stop sign in the lower right corner 
of the window to stop an animation before it has 
completed. 

d. To plot the vertical travel of the stamper with respect 
to the parcel tops versus time, as calculated from your 
last simulation, select Measure Stamp Height above 
Parcels.  

e. A stripchart appears, which shows a plot of the height 

of the stamp above the parcels. Note, your stripchart 
may look different depending on the value you used in 
the Stamper_Setup dialog.  In this example that value  
was 254 (see WS1-8).

f. To save an existing curve so that the next simulation 
will not overwrite the exiting curve but will be 
superimposed on the saved curve, select Save Curve.
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Step 5. Manually Find the Correct Height

To manually find the correct Height:

Repeat the steps on the previous pages using 3 mm 
increments until you can identify the control_link length at 
which the stamp makes contact with the parcels. Use this 
value to answer Question 1.

Helpful hint:

• If the stamp_height > 0, the stamper does not make 
contact with the parcels

• If the stamp_height < 0, the stamper makes contact 
with parcels. 

Step 6. Perform a Design Study

The design study automatically analyzes the model using 
the specified upper and lower limits for control_link length 
and the specified number of runs. To perform a design 
study:

a. On the Stamper_Simulate dialog box, select Design 
Study.

b. Default values for the upper and lower limit are given, 
but you can modify these if you wish. 

c. In this case, leave the number of Runs at 5. 

d. To speed up the simulation, set the Model Update to 
Never.

e. Click Apply to submit the design study.

f. The design study automatically analyzes the model. 
Click Close on the Information Dialog that informs you 
that the design study was successful. 

g. After the study is complete a stripchart and information 
window appear.

h. From the information window, identify the range of 
the control_link length values within which the stamp 
makes contact with the parcels.  Use this range to 
answer Question 2.

i. Close the information window.
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Step 7. Perform an Optimization Study

During an optimization study, Adams/View systematically 
varies the control_link length and runs a number of 
simulations until the specified penetration is achieved to 
within a set tolerance. To perform an optimization study:

a. On the Stamper_Simulate dialog box, select 
Optimization.

b. Set the Desired Penetration to 4 mm. You do not 
have to enter the units, Adams/View will automatically 
use the default units set for the model.

c. Set Model Update to Never.
d. Click Apply to submit the optimization study.  

e. The information window appears displaying the control_
link length for maximum penetration of 4mm. 

f. Use this displayed value of the control link length to 
answer Question 3.

g. Click OK to close the information window.
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Workshop Questions

Using 3 mm increments, at what control link length do you first notice penetration?  
  
  
  
  
 

From the design study, what control link length results in penetration?  How does this 
compare with your previous results?  
  
  
  
  
 

If you specify a maximum desired penetration of 4 mm, what is the optimal length of 
the control link? How close is the maximum actual penetration to the maximum desired 
penetration?  
  
  
  
  
 

How many moveable parts does the model consist of?  
  
  
  
  
 

How many joints does the model consist of?  
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Workshop Objectives
• Construct a robot arm in Adams
• Manipulate the working grid for use with multi-planar part layouts
• Create a gear constraint between revolute joints
• Use a SFORCE to apply griping torque to a robot manipulator
• Define 3D object contact and friction
• Synchronize joint motions and motor toques to perform a  

complex task

Software Version
Adams 2013.2 

Example 18: Robot Arm
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Step 2. Change the Working Grid

a. Go to Settings >> Working Grid
b. Set Orientation to Global YZ plane and spacing to 

10mm x 10mm. 
c. Select OK.

d. Press Shift + R to change to right view.

• The XY working grid was ideal for creating the lower 
links and base, but the YZ is much more convenient 
for building the manipulator. Not only does this cause 
the cursor to snap to points in the appropriate plane, 
but also allows the use the use to the default Create 
Normal to Grid option on Joints and other entities.

Step 1. Build the Lower Links

a. Start Adams/View. 

b. Create a new model. (Model Name = robot_arm, 
Units = mmks, Gravity = -y earth)

c. Create a Link from (0, 0, 0) to (0, 150, 0) and rename 
it lower_link. 

• Note that the working grid, by default, snaps to 50mm 
spaced grid points, which make it easy to select the 
specified points.

d. Build another from (0, 150, 0) to (0, 250, 0). Rename it 
middle_link.

e. Modify the link geometries of lower_link to have a 
width and depth of 40. For middle_link, set its link 
geometry to a width and depth of 30.

f. Build a Cylinder with a start point at (0, 0, 0) and an 
end point at (0, -50, 0). Rename it base.

g. Modify the cylinder radius to be 30.

h. Select the Revolute Joint follow the instruction in the 
status bar to create the following joints. 

• The order of the body selections is important because 
it determines which direction is positive for applied 
motion. After all of the joints are created, the model 
will be tested to make sure motions act in the correct 
direction. If not, this can easily be changed. 
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Step 3. Build the Manipulator I

a.  Decrease the size of the icons to make working near 
them easier:

• Go to Settings >> Icons… and type 10 in the New 
Size box

b. Build and resize links for the manipulator as shown 
below.

c. Referring to the image below, (your colors may differ) 
rename the MAGENTA link manipulator_base, the 
RED link gripper_right and the GREEN link gripper_
left.

d. Save your work.

Step 4. Build the Manipulator II

For this simulation, the robot will be grasping 40mm 
square cubes. Use precision move to correctly space the 
grippers.

a. Select gripper_left.
b. Select the Position:Move icon in the Main Toolbar.

c. Type 5mm in the distance box.

d. Select Vector and select any vector in the global z 
direction

e.  Repeat for gripper_right, moving it left 5mm instead.

Finish building the geometry for the manipulator base part

f. Select the Rigidbody:Link icon. 

g. Change from New Part to Add to Part in the drop-
down menu

h. Select the check boxes Width and Depth, and enter 
20 into each field

i. Select the manipulator_base part, then select the 
lower markers of each gripper part to define the new 
link geometry

Note that this is a new geometry added to the manipulator_
base part, not a new part.

j. Build revolute joints between each of the grippers 
and manipulator_base as shown, selecting the 
grippers at the first bodies
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manipulator_base (0, 300, 0) (0, 
250, 0)

20mm 20mm

gripper_right (0, 350, -30) (0, 
300, -30)

10mm 10mm

gripper left (0, 350, 30) (0, 
300, 30)

10mm 10mm
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Step 5. Define the Remaining Joints

a. Switch the working grid orientation to the Global XY.

b. Build a revolute joint between manipulator_base and 
middle_link at (0, 250, 0)

c. Switch the working grid orientation to Global XZ.
d. Build a revolute joint between ground and base at the 

bases .cm marker, which is at (0, -25, 0).

Step 6. Add Motions to Test the Model

a. Click the Rotational Joint Motion tool from the Main 
Toolbar. Use the default speed of 30.0. 

b. Select the joint between lower_link and base.

c. Rename the newly created motion motor_1.
d. Modify (Right Click >> motor_1 >> Modify…) the 

newly created motion. Add a negative sign to the 
function line to reverse its direction

e.  Add motions to the other 5 revolute joints, using the 
default speed of 30 for each motion. It is not necessary 
to change the direction of sign/direction of these 
motions.

f. Rename each of the motions as shown.

g. Simulate for the default of 5 seconds and 50 steps.
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Step 7. Test the Model

a. Click on the animation icon. 

b. Use the slider bar to navigate to frame 26. 
c. Shown is the iso (Shift+I) shaded (Shift+S) view of 

the model at frame 26 (time 2.5000). Manipulator_base 
has been made transparent for visualization.

a. If your model does not behave as shown, attempt to 
make the necessary changes.

b. Likely, the issued can be fixed by reviewing the 
slides (5-8 for position related issues, and 12-13 
for joint related issues). If this does not resolve the 
issue, load robot_arm_shortcut1.bin and continue 
from there.

Step 8. Build Objects to Grasp I

a.  Switch working grid to Global XZ and spacing to 20 x 
20. Switch to top view.

b. Use the Rigid Body: Box to build boxes as shown 
below by selecting the appropriate corner locations. 

c. Modify the block geometry of each part, changing the 
Z component of Diagonal Corner Coords to -5 for 
the large ‘platforms’ and 40 for each of the cubes.

d. Rename the geometries of the newly created bodies as 
shown below.

e.  Change the mass of each cube to 20g. Modify >> 
Define Mass By: User Input
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Step 9. Build Objects to Grasp II

Now we will fix the platforms to ground, and create contact 
between the boxes and platforms so they do not fall into 
space.

a. Select Contact icon

b. Make sure Solid to Solid is selected in the Contact 
Type drop down menu

c. Right click in the I Solids and J Solids dialog box 
and use the Pick to select the geometries in the Main 
Window.

d. Repeat for the other three cubes. 

e.  Create fixed joints between each platform and 
ground.

Step 10. Couple the Motion of the Grippers

Now we will fix the platforms to ground, and create contact 
between the boxes and platforms so they do not fall into 
space.

a. Set the Working Grid back to Global YZ and switch to 
Right View.

b. Delete the motions acting on the gripper revolute joints.

c. Select the Joint Coupler. 
d. Choose the gripper_right revolute joint, then 

the left, to define a motion coupler.

e.  Modify the coupler as shown. This constrains the 
motion of the joints to be equal in magnitude but 
opposite in direction.
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Step 12. Test the Gripper Forces

a. Set the other motions in the model to be 0 and verify 
the operation of the manipulator.

b. Set all 4 of the joint motion (motor_1, motor_2, etc.) 
function definitions to be 0.

c. Modify grip_torque’s function to be 20.
d. Simulate for 3 seconds, 30 steps, the grippers should 

now settle in a slightly closed position, as shown.

e. Change grip_torque’s function to be 0.
f. If the grippers do not behave as shown, refer to the 

Modify dialog boxes and images for the torsion spring 
and grip_torque on the previous slide to check their 
definitions

Step 11. Add Forces to the Gripper

a.  Select Create a Rotational Spring-damper.
b. Select gripper_right then manipulator_base for 

the bodies to define the spring, then the center of the 
revolute joint for location.

c. Modify the torsion spring to have a Stiffness of 10, 
Damping of 5 and a Preload of 10. The causes the 
grippers to spring slightly open by default. 

d. Select Create a Torque.
• Note: Although the torque should act between 

gripper_right and manipulator_base, use the 
default Space Fixed option (which reacts on ground) 
to take advantage of the default Normal to Grid for 
direction. The SFORCE will later be modified to react 
on manipulator_base.

e. Select manipulator_left for the body to define the 
SFORCE and the center of the gripper_right revolute 
joint for location.

f. Change the appearance of the SFORCE to have a color 
of blue and a size of 11 for visibility. 

g. Rename the torque SFORCE_grip_torque.

h. Modify the SFORCE as shown.
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Step 13. The Step Function Introduction

A step function will be used to define the motion of the 
robot. The step function dependent variable has an initial 
valve h0, before the independent variable, x, reaches x0, a 
final value h1 after the x reaches x1, and a smooth step in 
between. “Smooth” mean the first derivative is continuous 
(i.e. no instantaneous change in acceleration). Position, 
Velocity, and Acceleration of a step defined motion are 
show below.

Step Function:  -90d*step(time,1,0,2,1)

As you can see, detailed information on Adams functions 
can be found in the Adams help documentation
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Step 15. Grip the Cube

Next create a contact and friction force between the 
grippers and the cube.

a. Create a solid to solid contact between gripper_left 
and cube_1.  

b. Change the Static and Dynamic Coefficients as 
shown.

c. Repeat for gripper_right and cube_1. 
d. Rename each gripper_contact_[left/right].
Use a step function to set torque equal to 0 from 0-1sec, 
allowing the spring the keep the grippers in the slightly 
open position, then apply 8000 N*m when in position.

e. Modify grip_torque’s function to be 
-step(time,1,0,1.1,-8000)

f. Simulate for 1.1 seconds, 55 steps. Confirm that the 
gripper makes contact with cube_1 as shown.

Step 14. “Stepping” the Robot

Now, motions will be defined with step functions to bring 
into position to grip cube_1.

a. Define the following step functions. Be sure delete what 
is already in the function box and select apply in the 
motion modify window. 

b. Run a simulation for 1 second, 20 steps.
c. At the end of the simulation, the gripped should be 

positioned to grip the cube, as shown. 

Motions Function

Motor_1 step(time,0,0,1,-40d)

Motor_2 step(time,0,0,1,-110d)

Motor_3 step(time,0,0,1,60d)

Motor_4 0
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Step 16. Adding Steps

a. Add the following steps to the specified motion 
functions:

b. Simulate for 2 seconds, 40 steps.
c. Verify that your simulation matches with the image.

Step 17. Finalize Definition of 
Motions and Torques

The chart below describes the necessary step values 
required to complete the entire operation. Try to figure 
out the missing values on your own. Recall that x values 
are the independent value (time) and the h values are 
the dependent variables (position/torque) and the 
format for the step function (with time defined as X) is 
step(time,x0,h0,x1,h1)

Motions Step to Add

Motor_1 step(time,1.1,0,2,20d)

Motor_2 step(time,1.1,0,2,40d)

Motor_3 step(time,1.1,0,2,-60d)

Add to motion definitions one step at a time and simulating 
to verify the model behaves as expected.

Note that all h0 values are zero and h1 always describes 
motion relative to the current position.

The necessary motion to place the cube on the platform 
and release it is essentially the reverse of picking it up. In 
other words, steps 3, 5, and 7 are very similar. 

For example, the final function definition of motor_2 is:                                                                             
step(time,0,0,1,-110d) + step(time,1.1,0,2,40d) + 
step(time,2,0,3,-40d) + step(time,4.1,0,5,40d)

Step 4 is simple a rotation of the base to bring the cube 
over platform_2. Note that its x values overlap steps 2 & 5.

Try to simulate the whole operation (0-4 seconds) with your 
values. If you are having trouble, continue to the next step. 
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Step 19. Optional Tasks

Torque Demand

a. Switch to PostProcessor and examine the results of 
the simulation.  

b. Look at torque demands (Source:Objects >> motor 
_x>> Element Torque >> Mag), and gripper contact 
forces(Source:Objects >> gripper_contact_[left/
right]>> Element Torque >> Mag). 

c. Note the sporadic spikes in torque required to maintain 
the smooth step motion. 

d. Switch back to View and increase the contact 
damping to 100 and re-simulate.

e. How do the torque demands and contact forces look 
now?

Move the Remaining Cubes

For simplicity, the robot sits the block down in the same 
position on platform 2 as it was on platform 1.  

a. Use sketch paper to derive the necessary angles to sit 
the block near the far edge of platform 2 , where cube 
3 is on platform 1. 

b. Try to create the additional steps necessary to move 
the remaining blocks. Derive the necessary angles by 
hand or use trial and error to determine the correct 
values. 

Step 18. Finalize Definition 
of Motions and Torques

Final list of motion/torque functions:
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Motions Function

Motor_1 step(time,0,0,1,-40d) + 
step(time,1.1,0,2,20d) + step(time,2,0,3,-
20d) + step(time,3.1,0,4,20d)

Motor_2 step(time,0,0,1,-110d) + 
step(time,1.1,0,2,40d) + step(time,2,0,3,-
40d) + step(time,3.1,0,4,40d)

Motor_3 step(time,0,0,1,60d) + step(time,1.1,0,2,-
60d) + step(time,2,0,3,60d) + 
step(time,3.1,0,4,-60d)

Motor_4 step(time,1.5,0,2.5,90d)

gripper_torque step(time,1,0,1.1,8000) + 
step(time,3,0,3.1,-8000)
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Software Version
Adams 2013.2 

Problem Description
Shooting a basketball accurately is no easy task without proper 
practice. The thousands of iterations that basketball players make is 
the process of optimizing the move to find the best combination of 
initial vertical and horizontal velocity. In this example, this process is 
simulated in Adams/View to find the optimal velocity combination to 
score a three-point.

Example 19: Adams Optimization
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g. Press F to fit the view and show the ball.

h. Right click on PART_2 and select Rename. Rename 
PART_2 to Ball.

Step 3. Change the Working Grid.

a. Go to Settings->Working Grid.

b. Set Orientation to Global XZ Plane. This is because 
in the next step, when we create the hoop using Torus, 
the torus is created in the plane of Working Grid.

Step 4. Create the Hoop.

a. From Bodies ribbon, select RigidBody: Torus.

b. Check both Minor Radius and Major Radius and 
set them to 1cm and 24cm respectively. Major radius 
is the radius of the center line of the hoop while minor 
radius is the radius of the ring itself.

c. Right click in the background to invoke Location Event 
and set the coordinate to 0, 3.05, 0.

d. Rename PART_3 to Hoop.

e. Press F to fit the view.

Step 1. Start Adams/View.

a. Start Adams/View 2013.2.

b. Select New Model.
c. Name the model to Basketball and change the Unit 

to MKS. We use MKS here because we are going to 
model half of the basketball court.

d. Click OK.

Step 2. Create the Ball.

a. From Bodies ribbon, select RigidBody: Sphere.

b. Select New Part and check Radius.

c. Set the Radius to 12cm. The dimensions of the ball, 
the hoop and their positions are all set according to the 
standard of NBA.

d. Right click in the window to invoke Location Event.

e. Set the location of the ball at (-7, 2.1, 0).
f. Click Apply.
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Step 5. Create Fixed Joint.

a. From Connectors ribbon, select Joint: Fixed.

b. Set Construction methods to 2 Bodies-1 Loc and 
Normal to Grid.

c. Pick Hoop and then ground.

d. Pick Hoop.MARKER_2 as location. Now we fixed the 
hoop to the ground.

Step 6. Create Contact.

a. Now we create a contact between the ball and the 
hoop.

b. From Forces ribbon, select Special Forces: Create 
a Contact.

c. Right click in the I Solid(s) field and select Contact 
Solid->Pick and pick the ball.

d. Similarly, pick the hoop as J Solid.

e. We will leave the rest of the settings as default in this 
tutorial. Feel free to change these parameters later to 
see how these affect the simulation.

Step 7. Create Design Variables.

a. From Design Exploration ribbon, select Design 
Variable: Create a Design Variable. 

b. Name the variable x_vel.
c. Set the Units to velocity.

d. Set Standard Value to 5.

e. Select Value Range by: Absolute Min and Max 
Values.

f. Set Min. Value and Max. Value to 5 and 10 
respectively.

g. Click Apply and create another variable y_vel using the 
same settings.

Step 8. Impose Initial Velocities to the Ball.

a. From the model tree, right click on part Ball and select 
Modify.
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b. Under Category popup menu, pick Velocity Initial 
Conditions.

c. Check X axis and Y axis.

d. Right click in the field and select Parameterize-
>Reference Design Variable.

e. Select x_vel and y_vel respectively. Now the initial 
velocity of the ball will change during each iteration 
as the design variable x_vel and y_vel follows different 
combinations.

f. Click OK.

Step 9. Create a Measurement.

a. From Design Exploration ribbon, select Measures: 
Create a New Point to Point Measure. 

b. Pick Ball.MARKER_1 and Hoop.MARKER_2. This 
measures the distance between the center of the ball 

and the center of the ball. When the distance is zero 
(within tolerance), we assume that the ball is on target.

Step 10. Run a Simulation.

a. Run a simulation with 1 second and 50 steps.

b. The simulation script with default run will automatically 
be used in later iterations by the design evaluation tools.

Step 11. Set Up Design Evaluation Tools.

a. From Design Exploration ribbon, select Design 
Evaluation: Design Evaluation Tools.

b. Pick Study a Minimum of.
c. Select the measurement we created in the field.

d. Select Optimization.

e. Right click in the field of Design Variables and select 
x_vel and y_vel.

f. Pick the Goal as Minimize Des. Meas.

g. Click Start.

Step 12. Review Optimization Results.

a. Click Create tabular report of results.
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b. Then click OK.

c. In the message window, we find that the best 
combination is a x_vel of 7.1404 m/s and a y_vel of 
5.7773 m/s. The distance between two centers is 

about 0.0024m.
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Software Version
Adams 2013.2 

Problem Description
In this example, we will be studying the dynamics of an airplane control 
surface. The topics covered in this example include importing .mnf files, 
using .cmd file to generate features and the benefit of including flexible 
bodies in simulation.

Example 20: Airplane Control Surface
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times throughout our tutorial kit. In this example, we will 
use .cmd files to create joints.

b. From the menu bar, go to File->Import.
c. Select Adams/View Command File for File Type.

d. Right click in the field next to File To Read and browse 
for Create_Joints.cmd.

e. Click OK. Then you will find that several joints have 
been created under Connectors. What is included in 
.cmd file is called Adams/View Command Language. 
Actually, you can right click on the .cmd file and use 
any text editor to view its content. For more information 
on Adams/View Command Language, please refer to 
Adams Online Help.

Step 4. Compare Between 
Rigid and Flexible Body

a. From Simulation ribbon, select either mode of 
simulation and verify the model.  

b. The result says that we have 80 degrees of freedom 
with no redundant contraint equations.

c. Close the information window and make the control 

Step 1. Import Start File

a. Start Adams/View 2013.2.

b. Select Existing Model and browse to file Control_
Surface_start.cmd.

c. Click OK. If you can’t see the model immediately, press 
F to fit the model to the view window.

Step 2. Import .mnf File

a. At this stage the control surface is not included in the 
model. There are two ways to include it in the model. 
The first one is to import the parasolid geometry and 
then make it a flexible body. The second one is to 
generate the .mnf file first and then import it into the 
model. In our example, we use the second method. 
This is the case when .mnf has been prepared by CAE 
engineer and then provided to Adams Engineer.

b. From Bodies ribbon, select Flexible Bodies: Adams/
Flex: create flexible body via MNF import.

c. Right click in the file next to file type and browse for 
FlapModes.mnf.

d. Make sure that you don’t change the flexible body 
name. Otherwise you won’t be able to create joints 
later by importing the .cmd file we provide to you. 
Leave the rest of the fields as default and click OK.

Step 3. Import .cmd File to Create Joints

a. We have been exporting and importing .cmd files many 
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surface rigid.

d. Right click on control surface and select Make Rigid.

e. Verify the model again. Now the result tells us that 
there two redundant constraints. Sometimes, Adams 
will still run even with the presence of redundant 
constraints because Adams will remove redundant 
constraints during simulation as long as they are 
consistent. However, as the simulation runs, chances 
are that the redundant constraints will become 
inconsistent, which will cause the simulation to fail. 
Hence, including a flexible body in the model when 
necessary will help us to circumvent this situation.

f. Close the information window and make the body 

flexible again. Pick partial inertia modeling.

Step 5. Add Loads to the Control Surface

a. To facilitate selection process, press Shift+S to change 
the render mode to Shaded. Notice that you can 
now find some nodes with maize coordinate system 
markers.

b. From Forces ribbon, select Applied Forces: Create 
a Single Component Force.

c. Select Space Fixed for Run time Direction.

d. Select Pick Feature for Construction.

e. Pick Flex_Body_1 as the body.

f. Pick Node 6363 as the point of application. You can 
right click on the area around its location and pick 
Node 6363 from the selection list.

g. Pick Node 6363.Z as direction. Again, if you are 
having trouble pick the feature, right click on the region 
and select from the selection list.
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h. Use the same method to create a force at Node 6364 
with the same direction.

i. Right click on SFORCE_1 and select Modify.

j. Enter step(time, 0,0,1,-1500) in the function field.

k. Modify SFORCE_2 to have the same function. These 
forces are not aerodynamically accurate. But they are 
sufficient for illustrative purposes. With data available, 
you can easily exert forces on flexible bodies in the 
same manner.

Step 6. Run a Scripted Simulation

a. From Simulation ribbon, select Simulate: Run a 
Scripted Simulation.

b. Right click in the field and select SIM_SCRIPT_1.

c. Click Start Simulation.

Step 7. Review Simulation result

a. From the simulation control panel, save the 
simulation result as flex.
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b. Make the body rigid and run the same scripted 
simulation again. Save the simulation result as rigid.

c. Press F8 to bring the postprocessing window.

d. Now you can explore the simulation results.

e. You may find that the difference of two modeling 
methods is distinct in terms of forces at some of the 
joints. Please explore the result sets and compare the 
results of two different modeling techinques.
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Software Version
Adams 2013.2 

Problem Description
In our previous example of a pendulum, we studied the dynamics 
of a simple pendulum. In this example, we will further investigate 
the pendulum but with more complicated models. We will focus on 
comparing results of pendulums with different set ups. The parameters 
of the double pendulum referenced in this example is provided by 
Mechanical Engineering Control Systems Lab at California Polytechnic 
State University.

Example 21: More on Pendulum
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c. Click Save Run Results.

d. This will store the simulation result automatically 
so that we can plot the last run with previous runs 
together. Name the runs as pendulum and check 
Auto-Increment Name. This will add a number after the 
name for each run to distinguish them from each other.

e. Click plotting to enter postprocessing window.

Step 1. Start Adams/View

a. Start Adams/View 2013.2.

b. Select Existing Model and browse for Pendulum.
cmd in this example’s start folder.

c. Click OK.

Step 2. Run a Baseline Simulation

a. The configuration of the pendulum at default is 
explained now. The center of mass of the rod is defined 
at the end of the rod. And the rod has no inertia at 
all. This makes the default configuration a simple 
pendulum. Beneath the pendulum is a simple mass-
spring system. It has the same natural frequency as the 
pendulum.

b. Run an interactive simulation with 3 seconds and 150 
steps.
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f. In plotting page, make sure that Objects is selected as 
the source.

g. Then, hold Ctrl key and highlight both bob.cm and 
Mass_block.cm.

h. Then select Translational_Displacement and X 
component. Click Add Curves.

i. It can be found that these two systems have exactly 
the same amplitude and natural frequency. They 
act like each other despite the distinct geometric 
difference.

Step 3. Move the Pendulum to the Moon

a. What if the pendulum is swinging on the moon? We 
can simply change the value of the gravity and check 
the results.

b. From the menu, go to Settings->Gravity.

c. Change the value to -1622 (MMKS unit system). Click 
OK.

d. Run the simulation with the same settings (3 seconds, 
150 steps) again and save the run results as well.

e. Now, switch to postprocessing window again and plot 
the X component of Translational_Displacement 
of bob.cm. The plot shows that the period of the 
pendulum is longer as it is inversely proportional to the 
square root of the gravity.
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f. Go to Settings->Gravity again and click on –Y to 
change the gravity back to default value.

Step 4. Change the Initial 
Position to a Larger Angle

a. In this step, the initial angle of the pendulum is 
increased from 5 degrees to 60 degrees. The aim is to 
show that small angle approximation will fail at relatively 
large deflection.

b. From the model tree, double click Design Variable 
initial_angle. Then change the value from 5 to 60. 
Click OK.

c. You should notice that the mass block as well as 
the spring has extended to a new initial position 
corresponding to the pendulum. No graphical update 
occurs to the pendulum because the modification will 
only show up when the simulation starts. The model is 
parameterized so that once we change the initial_angle 
variable, the other parameters change accordingly.

Step 5. Run the Simulation Again

a. Again, run a 3 seconds-150 steps simulation and save 
the result.

b. Return to postprocessing window and plot the 
translational displacement of bob.cm and mass_block.
cm. Notice that the period has changed from 2 
seconds to 2.16 seconds. 

c. The change in period may not be that significant. 
However, if we check the force on the revolute joint at 
the end of the rod, we can find a huge difference.

d. Change Source from Objects to Result Sets and 
select the first and the last simulation, select rev_rod_
ground and pick FX component and then click Add 
Curves.

Section II: Intermediate Level | Example  21: More on Pendulum



150   |   MSC Software

e. The curve in magenta is the curve of the large 
deflection. It is not even a sinusoidal curve. This 
reminds us that the equation

     applies only to pendulums with small angle deflection. 

Step 6. Add a Revolute Joint 
between Rod and Bob

a. In this, step, we will investigate the effect of the inertia 
of the bob on the oscillation of the pendulum.

b. Double click CYLINDER_2 from the model tree and 
change the radius to 15in. Click OK.

c. Run the simulation and plot the x component 
translational displacement of bob.cm as we have done 
in previous steps.

d. From the animation you can already find that as the 
radius of the bob increases, the period also increases. 
Simple pendulum neglects the effect of the inertia of 
the bob.

e. Now, deactivate joint fixed_rod-bob and activate 
joint rev_rod_bob.

f. Run the simulation again. In postprocessing window, 
in the same plot, add the curve of x component of 
translational displacement of bob.cm.

g. We find that the pendulums gradually oscillate out of 
phase. The one with the revolute joint (blue dashed 
curve) oscillates faster.

h. The reason is that as the bob is set free, it is not 
rotating about its center of mass. That portion of 
energy is converted to the translational motion of the 
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pendulum thus making the pendulum to finish one 
swing quicker. 

Step 7. Double Pendulum

a. In this step, a double pendulum connected by a spring 
is modeled This is a system with two DOFs. We will run 
simulations with different initial conditions to find out 
the two normal modes of the system.

b. Go to File->New Database. Select Existing Model 
and pick Double_Pendulum.cmd from the exercise 

start directory.

c. Double click on each of the revolute joints and then 
click Initial Conditions to view the I.C. at each Joint.

d. From Simulation Ribbon, run an interactive 
simulation with 5 seconds and 100 steps.

e. Then press F8 to enter postprocecssing window. 
Hold Ctrl key and highlight both pendulum1.
MARKER_3 and pendulum2_MARKER_3. Under 
Characteristic, select Translational Displacement. 
Under Component, select Mag. Then click Add 
Curves. It can be found that the period of the system 
is 1.5 seconds. The two pendulums have the same 
magnitude of oscillation but in the opposite direction of 
motion.

f. Double click on one of the revolute joints and click 
Initial Condition. Change the initial rotational 
displacement to the opposite sign so that initially, 
the pendulums will start with the same amount of 
deflection in the same direction.

g. Run the simulation again and press F8 to enter 
postprocessing window.

h. Plot Translational Displacement of pendulum2.
MARKER_3 on the same page with the previous 
curves. This time, it can be found that the period of the 
system now is 1.6 seconds. The two pendulums still 
have the same magnitude of oscillation but they have 
the same phase angle.

i. Another interesting simulation would be setting the 
initial displacement of pendulum1 to zero and maintain 
the initial angle of pendulum2. You may change the 
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Initial Conditions like instructed in Step 7f. Then, run a 
simulation with 45 seconds and 900 steps.

j. Now, plot the magnitude of Translational_Displacement 
of MARKER_3 of both pendulums again. The curves 
are not simply sinusoidal anymore. But we can still find 
out a periodic oscillation. 
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Software Version
Adams 2013.2 

Problem Description
A gyroscope is a device for measuring or maintaining orientation. A 
gyroscope usually comprises an outer cage (frame), an inner cage 
(gimbal) and an inertia wheel (rotor). The rotor is spinning at high speed 
so that external disturbances cannot change its orientation too much 
due to its large angular momentum. In this example, we will show you 
how to build a gyroscope model in Adams/View and properly measure 
the angle as well as export the data. Outer cage, inner cage and 
inertia wheel are connected to each other via revolute joints while the 
assembly is connected to the ground via a spherical joint to assume 
any orientation.

Example 22: Gyroscope

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   155  MSC Software   |   155

Step 3. Create the Inner Cage

a. From Bodies ribbon, select RigidBody: Torus.

b. Select New Part and check Minor radius and Major 
radius. Set them to 1cm and 30cm respectively.

c. Click on the Origin and the inner cage will be created.

d. From Bodies ribbon, select RigidBody: Cylinder.
e. Select Add to Part and leave length unchecked. 

Check radius and set it to 1cm.

f. Select the torus just created and right click at the 
background to invoke the Location Event.

g. Enter 300, 0, 0, and click apply then enter 350, 0, 0. 

h. Rename PART_3 to InnerCage.

Step 4. Create the Inertia Wheel

a. From Bodies ribbon, select RigidBody: Cylinder.
b. Select New Part and leave length unchecked. Check 

radius and set it to 1cm.

c. Right click in the background and enter 0, 300, 0 in the 
Location Event. Click apply and enter 0, -300, 0.

d. From Bodies ribbon, select RigidBody: Cylinder.

Step 1. Create a New Database

a. Open Adams/View 2013.2.

b. Select New Model.
c. Name the new model Gyro.

d. Select the directory of your choice.

Step 2. Create the Outer Cage

a. From Bodies ribbon, select RigidBody: Torus.

b. Select New Part and check Minor radius and Major 
radius. Set them to 1cm and 35cm respectively.

c. Click on the Origin and the outer cage will be created.

d. From Bodies ribbon, select RigidBody: Cylinder.
e. Select Add to Part and leave length unchecked. 

Check radius and set it to 1cm.

f. Select the torus just created and right click at the 
background to invoke the Location Event.

g. Enter 0, 350, 0, and click apply then enter 0, 450, 0. 
These steps will create a cylinder under PART_2 and it 
starts at 0, 350, 0 and ends at 0, 450, 0.

h. Rename the part to OuterCage.
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e. Select Add to Part and leave length unchecked. 
Check radius and set it to 25cm.

f. Select the cylinder just created (PART_4) right click 
in the background and enter 0, -10, 0 in the Location 
Event. Click apply and enter 0, 10, 0.

g. Rename PART_4 to InertiaWheel.

Step 5. Create Spherical Joint

a. From Connectors ribbon, select Joint: Spherical.
b. Select 2 Bodies-1 Loc and Normal to Grid.

c. Pick OuterCage first and then ground.

d. Select OuterCage.CYLINDER_6.E1 (center) as the 
location. Note that the actual name of the point may 
vary but the idea is to create a spherical joint at the 
end of the cylinder on outer cage. If the point is not 
automatically snapped on, right click around it and 
select it from the selection list.

Step 6. Create Revolute Joints

a. Change the working grid orientation to Global YZ 
Plane.

b. From the Connectors ribbon, select Joint: Revolute. 

c. Select 2 Bodies-1 Loc and Normal to Grid.

d. Pick OuterCage first and then InnerCage.

e. Select the end of the cylinder of Innercage.

f. Change the orientation of the working grid to Global 
XZ Plane.

g. Create a revolute joint between InnerCage and 
InertiaWheel at the connecting cylinder.

Step 7. Verify the Model

a. From Simulation ribbon, run a simulation with 1 
second and 50 steps. Check Start at equilibrium. The 
gyro should sit still.

Step 8. Create a Disturbance

a. From Forces ribbon, select Applied Forces: Single 
Component Force.

b. Select Body Moving for Run-time Direction.

c. Select Pick Feature under Construction.
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d. Select InertiaWheel, then right click on the center of 
InertiaWheel and pick InertiaWheel.cm from the list.

e. Select cm.X for the directon. You may need to switch 
to Iso view (shift+I) to help you make the selections.

f. When the force has been created, double click it under 
the model tree.

g. Under Function, enter step(time, 0.1,0,0.15,100)*st
ep(time,0.15,100,0.2,0). This function simulates an 
impulse disturbance applied upon inertia wheel that 
has a width of 0.1 second and an amplitude of 100 N. 

Step 9. Run a Baseline Simulation

a. Run an interactive simulation of 1 seconds and 500 
steps.

b. Check Start at Equilibrium.

c. It can be found that the gyro, without the inertia wheel 
spinning, moves rather drastically, especially towards 
the end of simulation.

Step 9. Add Initial Condition 
to Inertia Wheel

a. From the model tree, double click on JOINT_3.

b. Click on Initial Conditions.

Section #: Section Title  |  Example Title
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c. Check Rot.Velo. and enter 36000.

d. Click OK.

Step 10. Run Simulation Again

a. Run a simulation of 10 seconds and 500 steps.

b. Check Start at Equilibrium.

c. This time, although the cages were still moving due to 
the disturbance, the inertia wheel didn’t behave as in 
the previous case. Due to the inertia of the spinning 
wheel, the gyro barely rotates.

Step 11. Check Simulation Results

a. Press F8 to enter postprocessing window.

b. Under Simulation list, select Last Run. 

c. Under Source, pick Result Sets.

d. Under Result Set list, hightlight InertiaWheel_
XFORM.

e. Highlight THETA under Component.
f. Click Add Curves.

g. The plot of theta, angular data of the inertia wheel 
rotating around y axis is rapidly changing and 
discontinuous. In real-world application, this will cause 
difficulties for control algorithms.

Step 12. Build an Angle Measurement

a. To avoid the problem mentioned above, we create a 
new measurement using function AY and check the 
results again.

b. From Design Exploration ribbon, select Measures: 
Create a new Function Meaure.

c. In the function builder, enter AY(InertiaWheel.
cm)*rtod. Here, function AY measures the angle of 
center of mass of inertia wheel against global Y axis. 
Function rtod converts the result from radian to degree.

Step 13. Run Simulation Again

a. Run the simulation again and check the results.

b. The result is now a continuous line.

c. To export the numerical data, in post processing 
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window, go to File->Export->Spreadsheet.
d. Enter file name ay.

e. Right click in Result Set Name and browse for 
FUNCTION_MEA_1. The click OK.

f. Now, in your working directory, there should be a new 
file ay.tab. Open it with any type of text editor, and you 
can postprocessing the data for your own application.
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Workshop Objectives
Use Adams/View to 

• Simulate the power hacksaw mechanism
• Create translational joint and revolution joints
• Apply motion to a revolution joint
• Define a contact between a solid and a solid
Use Adams/PostProcessor to

• Plot the horizontal stroke of the saw blade as a function of the angle 
of link 2.

Software Version
Adams 2013.2

Example 23: Power Hacksaw Mechanism
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Files Required
• hackSaw.x_t
• Located in the directory exercise_dir/

Example 23

Problem Description
• The model represents the power hacksaw, 

which is an offset crank slider mechanism.
• Link 2 is being rotated at a given velocity.
• Link 5 pivots at O5 and its weight forces 

the saw blade against the work piece while 
the linkage moves Link 4 back and forth on 
Link 5 to cut the work piece. 

Adapted from Robert L. Norton (2012). Design of 
Machinery (Fifth Editon)
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Step 1. Start Adams/View 
and Create a Database

a. Start Adams/View.

b. From the Welcome dialog box, select New Model.
c. Replace the contents of the Model Name text box 

with Power_Hacksaw
d. Select OK.

Step 2. Set Up Work Environment

a. From the Setting menu, select Working Grid.

b. Set the grid size along X to 400 mm and along Y to 150 
mm, and the grid spacing for X and Y to 5mm.

c. Select OK.

d. Press F4 on the keyboard to display the coordinates.
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Step 3. Import Part

a. From the Main Menu, select File, then click Import…
b. Replace the contents of File Type with Parasolid
c. Right-click the blank beside File to Red and select 

Browse.

d. Locate saved file hackSaw.x_t and click OK.

e. Select the default Model Name and type Power 
Hacksaw into the blank.

f. Click OK.

Step 4. Move the Import Parts

a. From the Main Toolbox, select the ribbon Bodies.

b. Select Geometry: Point.
c. Click the origin point (0.0, 0.0, 0.0) in the working 

space.

d. Rename the new point as POINT_ORIGIN
e. Select all the parts under the Bodies tree.

f. From the Main Toolbox, right-click Position: 
Reposition objects. 

g. Select Position-Move.

h. In the Position:Move dialog, check Selected 
and select From To method.

i. Select the point Base.cm, and then select POINT_
ORIGIN.
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Step 5. Change Mass of Link5

a. From the Model Brower, right-click Link5 below the 
Bodies tree.

b. Select Modify.

c. Set Density to 1.0.

d. Click OK.

Step 6. Create Work Piece

a. From the Main Toolbox, select Bodies, and then 
select RigidBody:Box.

b. Use the default construction method New Part.
c. Check Length, Height and Depth, and then enter 

50.0 mm
d. Right -click at location (-265, -55, 0) in the working 

area.

e. Right-click the part and point to Part: PART, and then 
select Rename.

f. Enter .Power Hacksaw.Work_Piece in the New 
Name content.

Step 7. Color the Parts

a. From Model Browser, left-click the plus sign beside 
Base displayed under the Bodies tree

b. Right-click SOLID1, and then select Appearance. 

c. In the Edit Appearance dialog, enter Gray beside 
Color.

d. Click OK.

e. Repeat the above steps to change the color of the 
other parts.

Step 8. Connect the Parts 
Using Revolute Joints

a. From the Main Toolbox, select Connectors, and then 
select Create a revolute joint.

b. To select the parts to attach, click the part Base and 
Link 2

c. Click the point in the table to set the joint’s location.

d. Repeat the above steps to create three more revolute 
joints.
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Part Name Color Name

Link2 Red

Link3 Maize

Link4 Magenta

Link5 Green

Saw Gray

Work Piece Yellow

Base Gray

1st Body 2nd Body Joint Location

Link 2 Link 3 Link2.SOLID4.E16(center)

Link 3 Link 4 Link4.SOLID3.E56(center)

Base Link 2 base.SOLID1.E28(center)

Base Link 5 base.SOLID1.E28(center)
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Step 9. Create Fixed Joints

a. From the Main Toolbox, select Connectors, and 
then select Create a fixed joint.

b. Click the part Saw, the part Link 4 and the CG of Saw.

c. Repeat the above steps to create fixed joints between 
Base, Work Piece and ground.

Step 10. Connect Link 4 and Link 
5 Using a Translational Joint

a. From the Main Toolbox, select Connectors, and 
then select Create a Translational joint. 

b. Click the part Link 4, the part Link 5 and the CG of 
Link 4.

c. Right-click the CG of Link 4 and select Link4.cm.X
d. Select any vector in X-direction

e. 

Step 11. Create Contact between 
Saw and Work Piece

a. From the Main Toolbox, select the ribbon Forces, and 
then select Create a Contact.

b. Right-click the text box of I Solid(s), point to Contact_
Solid, and then select Pick. Select the part Saw.

c. Select Work_Piece as J Solid(s).
d. Change the Normal Force to Restitution.

e. Set Penalty to 1.0E+010. Set Restitution 
Coefficient to 0.5.

f. Select Coulomb as Friction Force.
g. Click OK.
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Step 12. Create an Angle Measure 

a. Under the Connectors tree in the Model Browser, 
right-click the revolute joint between Link2 and Base.

b. Select Info to see the names of I Marker and J 
Marker.

c. Close the Information dialog.

d. From the Main Toolbox, select the Design 
Exploration.

e. Select Create a new Function Measure.
f. In the Function Builder dialog, enter Angle_

Link2toBase as Measure Name.

g. Select angle as Units.

h. Select Displacement, select Angle about Z, and 
then click Assist…

i. In the Angle about Z dialog, right-click the contents of 
To Marker and From Marker, point to Marker, and 
then select Browse…

j. In the Database Navigator, select the markers in 
Step b.

k. Click OK.

Step 13. Create a Horizontal 
Distance Measure

a. Select Point to Point Measure
b. Select Displacement as Characteristic and 

Global X as Component
c. Select the left hole center of the saw and then select 

Base.POINT1
d. Rename the measurement as stroke.

Step 14. Create Motion on 
a Revolution Joint

a. From the Main Toolbox, select the ribbon 
Motions, and then select Rotational Joint 
Motion. 

b. Enter 30 in Rot. Speed
c. Select the revolution joint between the Link2 and the 

ground.

d. From the model browser, expand Motions.

e. Right-click MOTION_1 and select Modify.

f. In Function (time), enter 55d + 30d*time. (55d is the 
initial angel to keep Link2 horizontal at the beginning of 
the simulation.)

g. Click OK. 
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Step 15. Simulate the 
Motion of Your Model

a. Click the ribbon Simulation, and then select the 
Run an Interactive Simulation tool. 

b. Set up a simulation with an End Time of 15 seconds 
and Step Size of 0.1.

c. Select the Simulation Start tool.

d. To return to the initial model configuration, select 
the Reset tool.

Step 16. Use Adams/PostProcessor

a. In the Simulation Control panel, click Plotting. 

b. In the Adams/PostProcessor windows, select 
Data as Independent Axis.

c. Select Angle_Link2toBase in the Independent Axis 
Browser, and then click OK.

d. Select Measure as Source, and then select stroke
e. Click Add Curve.
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Step 17. Compare Results

Theoretical Solution

Adams Solution

The Adams solution is exactly the same as the theoretical 
solution.
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In this section, you’ll learn how to solve some of the textbook 

problems using Adams. All these problems are created in 

reference to the textbook Design of Machinery (Fifth Edition) by 

Robert L. Norton (2012). All the mechanisms that we chose have 

been widely used in automotive and manufacturing industry. We 

hope you can solve the other similar textbook problems using 

Adams after you finish this section.  

Section III: Textbook Problems
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Workshop Objectives
Use Adams/view to

• Simulate the walking beam indexer with a pick-and-place 
mechanism

• Import existing .x_t file
• Create a gear pair
• Duplicate part
• Create an angle measurement
 
Use Adams/Postprocessor to 

• Calculate the horizontal stroke of the walking beam and the angular 
displacement of the placing arm.

Example 24: Walking Beam Indexer 
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Step 1. Start Adams/View 
and Create a Database

a. Start Adams/View.
b. From the Welcome dialog box, select New Model.
c. Replace the contents of the Model Name text box 

with Walking_Beam _Indexer.
d. Select OK.

Step 2. Set Up Work Environment

a. From the Setting menu, select Working Grid.

b. Set the grid size along X and Y to 250 mm, and the 
grid spacing for X and Y to 5mm.

c. Select OK.

Software Version
• Adams 2013.2 
• Adams/Machinery Plugin with gear module 

is required

Files Required
• crank.x_t
• walkingBeam.x_t
• placeArm.x_t
• link.x_t
• Located in the directory 

exercise_dir/Example 24

Problem Description  
• The model represents the walking beam 

indexer with a pick-and-place mechanism.
• The crank is being rotated at a given 

velocity.
• For one revolution of the crank, the walking 

beam pushes products forward one step.
• The articles are caught by the place arm.
 
Adapted from Robert L. Norton (2012). Design of 
Machinery (Fifth Editon)
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Step 3. Create Design Points

a. From the Main Toolbox, select the ribbon Bodies, 
and then select the Construction Geometry: 
Point. 

b. Use the default setting for points, which are Add to 
Ground and Don’t Attach.

c. Place the design point at X = 55 and Y = 80.
d. Right-click the design point, Point to Point: POINT_1, 

and then select Rename.  

e.  Replace POINT_1 with ground.O2.

f. Right-click the design point, Point to Point: O2, and 
then select Modify.

g. Change X coordinate to 57 and Y coordinate to 82.

h. Select OK.

i. Repeat the above steps to create the following design 
points in the following table.

X Location Y Location Z Location

O2 57 82 -10

O4 -51 82 0

O6 -128 0 -10

B 10.517 7.641 0

F -100 136 10

D -62.695 120.252 0

C -164.089 89.871 0

Step 4. Import Parts

a. From the Main Menu, select File, then click Import…
b. Replace the contents of File Type with Parasolid
c. Right-click the blank beside File to Red and select 

Browse.

d. Locate the save file crank.x_t.
e. Click OK.

f. Replace Model Name with Part Name and type 
Crank into the blank beside the Part Name.

g. Right-click the blank beside Location and select Pick 
Location.

h. Select the point ground.O2 in the working area.

i. Replace the contents of Orientation with 0.0, 0.0, 
73.0.

j. Click OK.

k. Repeat the above steps to import the other three parts 
in. 

Step 5. Create Gears

a. From the Main Toolbox, select ribbon Machinery, and 
then select Create gear pair. 

b. Choose Spur in Gear Type, and then click Next.
c. Choose Detailed in Method, and then click Next.
d. Set the parameters in the Geometry dialog 
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according to the following figure.

e. Click Next with the default setting of Material 
and Connection

f. Click Finish.

Step 6. Create Platen

a. From the Main Toolbox, select ribbon Bodies, 
and then select RigidBody:Box 

b. Use the default construction method New Parts.

c. In the Geometry: Box dialog, check Length and enter 

250.0 mm. Check Height and enter 10.0 mm. Check 
Depth and enter 30.0 mm.

d. Click the point ground.F.
e. Right-click the part and point to Part: PART_10, and 

then select Rename.

f. Enter .Walking Beam Indexer.Platen_Left in the 
New Name content.

g. From the Main Toolbox, right-click Position: 
Reposition objects 

h. Select Position –Move.
i. In the Position: Move dialog, check Selected and 

Copy. Choose Vector and enter -40.0 mm below 
Distance

j. Select the part Platen_Left.
k. Right-click the CG of the part Platen_Left. 
l. Select Platen_Left.cm.Y and click OK. 

m. Click Unparamerized.

n. Rename the new part as Platen_Right.

Step 7. Create Eccentric Cam

a. From the Main Toolbox, select ribbon Bodies, and 
then select Construction Geometry: Arc/Circle. 

b. In the Geometry: Circle dialog, check Radius and 

enter 25 mm, then check Circle.

c. Left-click ground.B in the working area.

d. From the Main Toolbox, select ribbon Bodies, and 
then select Rigidbody: Extrusion.

e. Select the items in Geometry: Extrusion as shown in 
Figure 7.

f. Click the gear Driver_1 in the working area, and then 
select PART_9.CIRCLE_18.

g. From the Model Browser, left-click the plus beside 
PART_9.

h. Right-click CIRCLE_18, and then select Hide.
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Step 8. Color the Parts

a. From Model Browser, left-click the plus beside 
Platen_Right displayed under the Bodies tree

b. Right-click SOLID1 under the Crank and select 
Appearance. 

c. In the Edit Appearance dialog, enter Cyan beside 
Color.

d. Click OK.

e.  Repeat the above steps to change the color of the 
other parts.

Step 9. Connect the Parts 
Using Revolute Joints

a. From the Main Toolbox, select ribbon 
Connectors, and then select Create a revolute 
joint.

b. To select the parts to attach, click the part Place_Arm 
and ground (the background)

c. Click the point ground.O6 to set the joint’s location.

d. Repeat the above steps to create three more revolute 
joints.

Step 10. Fix the Platen to the Ground

a. From the Main Toolbox, select ribbon 
Connectors, and then select Create a fixed 
joint. 

b. Click the part Platen_Left, ground and the CG of 
Platen.

c. Repeat the above steps to create a fixed joint between 
Platen_Right and ground.
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Step 11. Create Motion on 
a Revolution Joint

a. From the Main Toolbox, select the ribbon 
Motions, and then select Rotational Joint 
Motion. 

b. Select the revolution joint between the Crank and the 
ground.

Step 12. Create an Angle Measure 

a. Under the Connectors tree in the Model Browser, 
right-click the revolute joint between Place_Arm and 
the ground.

b. Select Info to see the names of I Marker and J 
Marker.

c. Close the Information dialog.

d. From the Main Toolbox, select the Design 
Exploration.

e. Select Create a new Function Measure.

f. In the Function Builder dialog, enter Angle_
PlaceArmtoGround as Measure Name.

g. Select angle as Units.

h. Select Displacement, select Angle about Z, and 
then click Assist…

i. In the Angle about Z dialog, right-click the contents of 
To Marker and From Marker, point to Marker, and 
then select Browse…

j. In the Database Navigator, select the markers in 
Step b.

k. Click OK.

Step 13. Create a Function Measure

a. Select Construction Geometry: Marker
b. Create a MARKER_42 at (-100.0, 146.0, 0.0)
c. From the Main Toolbox, select the Design 

Exploration.
d. Select Create a new Function Measure.
e. In the Function Builder dialog, enter Stroke_

Walking_Beam as Measure Name.
f. Select length as Units.

g. Enter the following into the Create or Modify a 
Function Measure 
(DY(MARKER_41, MARKER_42, MARKER_42)/
ABS(DY(MARKER_41, MARKER_42, MARKER_42)) 
+ 1) / 2 * DX(MARKER_41, MARKER_42, 
MARKER_42)

h. Click OK.

Note: you can design another better way to measure the 
horizontal stroke of the walking beam for the portion of 
their motion where its tips are above the top of the platen. 
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Step 14. Simulate the 
Motion of Your Model

a. Click the ribbon Simulation, and then select the 
Run an Interactive Simulation tool.

b. Set up a simulation with an End Time of 20 and Step 
Size of 0.2.

c. Select the Simulation Start tool.

d. To return to the initial model configuration, select 
the Reset tool.

Step 15. Use Adams/PostProcessor

a. In the Simulation Control panel, click Plotting. 

b. Select Objects as Measure.

c. Select Angle_PlaceArmtoGround or Stroke_
Walking_Beam.

d. Click Add Curve.
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Adams Solution

Stroke = 254.9749 -177.1884 = 77.78 mm

The 1mm difference between the Adams solution and 
exact solution is caused by the thickness of the platen.

Step 16. Compare Results

Theoretical Result

The portion of one revolution of Link 2 is
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Workshop Objectives
Use Adams/view to

• Simulate the Watt’s linkage in a steam Engine.
• Import .x_t file
• Create revolute joints and a translational joint
• Create a gear pair
 
Software Version
• Adams 2013.2 
• Adams/Machinery Plugin with gear module is required 

Files Required
• wheel.x_t
• Located in the directory exercise_dir/Example 25

Example 25: Watt’s Linkage in a Steam Engine 
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Middle_Link

Lower_Link

Piston_Link
Drive_Link

Upper_Link

Piston

Cylinder
Wheel
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Step 1. Start Adams/View 
and Create a Database

a. Start Adams/View.

b. From the Welcome dialog box, select New Model.
c. Replace the contents of the Model Name text box 

with Watts_Linkage.
d. Select OK.

Step 2. Set Up Work Environment

a. From the Setting menu, select Working Grid.

b. Set the grid size along X and Y to 500 mm, and the 
grid spacing for X and Y to 10mm.

c. Select OK.

Problem Description  
• The model represents the Watt’s linkage 

used in a steam engine.
• The piston is being constrained to move 

along a straight line.
• The piston pushes three-bar linkage 

system to rotate the wheel.
 
Adapted from Robert L. Norton (2012). Design of 
Machinery (Fifth Edition)
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Step 3. Create Design Points

a. From the Main Toolbox, select the ribbon Bodies, 
and then select the Construction Geometry: 
Point. 

b. Use the default setting for points, which are Add to 
Ground and Don’t Attach. Place the design point at X 
= 0 and Y = 350.

c. Right-click the design point, Point to Point: POINT_1, 
and then select Rename. Replace POINT_1 with 
ground.A.

d. Repeat the above steps to create the design points.

Step 4. Import Part

a. From the Main Menu, select File, then click Import…
b. Replace the contents of File Type with Parasolid.

c. Right-click the blank beside File to Read and select 
Browse.

d. Located the saved file wheel.x_t
e. Click OK.

f. Replace Model Name with Part Name and type 
Wheel into the blank beside the Part Name.

g. Right-click the blank beside Location and select Pick 
Location.

h. Select the point ground.O8 in the working area.

i. Replace the contents of Orientation with (0.0, 0.0, 
18.43).

j. Click OK.

Step 5. Create Cylinder

a. From the Main Toolbox, select ribbon Bodies, 
and then select RigidBody:Cylinder.

b. Use the default construction method New Parts.

c. In the Geometry: Cylinder dialog, check Length and 
enter 250.0 mm. Check Radius and enter 60.0 mm. 

d. Click the point (0, 0, 0), move upwards and click.

e. Rename the new part as Cylinder.
f. Select RigidBody:Box.

g. Select Add to Part as method in Geometry: 
Box dialog.

h. Check Length and enter 120 mm. Check Height and 
enter 250 mm. Check Depth and enter 60mm.

i. Left-click the part Cylinder in the working area, and 
then left-click (-60, 0, 0).

j. Select Booleans: Cut out a solid with another.
k. Select Cylinder, and then select Box.

l. Repeat the above procedure to cut Cylinder use a 
smaller cylinder with the radius of 50mm.
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Step 6. Create a Piston

a. From the Main Toolbox, select ribbon Bodies, 
and then select RigidBody:Cylinder.

b. Use the default construction method New Parts.
c. In the Geometry: Cylinder dialog, check Length and 

enter 20.0 mm. Check Radius and enter 50.0 mm. 

d. Click the point D in the working area, move downwards 
and click

e. Right-click the part and point to Part: PART_4, and 
then select Rename.

f. Enter Piston in the New Name content.

g. Right-click Piston in the model browser and select 
Modify.

h. Enter (7.801E+004(kg/meter**3)) for Density.

Step 7. Create Ground Supports

a. Select RigidBody:Box. 
b. Select New Part as method in Geometry: Box 

dialog.

c. Check Length and enter 40mm. Check Height and 
enter 40 mm. Check Depth and enter 40mm.

d. Left-click (-220, 330, 0).
e. From the Main Toolbox, right-click Position: 

Reposition objects 
f. Select Add a boss. 
g. Enter 2mm to Radius and 5mm to Height, and 

then select the center of the Box in the working area.

h. Rename the new part as Ground_Support1
i. Repeat the above steps to create Ground_Support2 

at (180, 430, 0).

Step 8. Create Linkages

a. Select RigidBody:Link.
b. Use the default construction method New Parts.
c. Check Width and enter 20mm. Check Depth and 

enter 5mm.

d. DO NOT check Length.

e. Left-click the point D and point P.
f. Rename the link as Piston_Link.
g. Repeat the above steps to create five more 

linkages.

h. Select Add a hole or Add a boss to add a hole 
of boss at the end of these linkages.

Remarks: Use set the view to isometric to choose 
point (290,100,0).

Step 9. Move Parts into Difference Layers

a. From the Main Toolbox, right-click Position: 
Reposition objects. 

b. Select Position-Move.
c. In the Position:Move dialog, check Selected 

and select Vector method.

d. Select the part, and then select any vector into or out 
of the working area.

e. Choose Unparameterize in the warning message.

Step 10. Create Gears

a. From the Main Toolbox, select ribbon Machinery, 
and then select Create gear pair. 

b. Choose Spur in Gear Type, and then click Next.
c. Choose 3D Contact in Method, and then click Next.
d. Set the parameters in the Geometry dialog according 

to Figure.

e. Click Next with the default setting of Material.
f. Create Gear Connection according to Figure

g. Click Next, and then Click Finish.

Section III: Textbook Problems  |  Example 25: Watt’s Linkage in a Steam Engine
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Step 11. Color the Parts

a. From Model Browser, right-click Ground_Support1 
displayed under the Bodies tree. Select Appearance. 

b. In the Edit Appearance dialog, enter Gray beside 
Color

c. Repeat the above steps to change the color of the 
other parts.

Step 12. Connect the Parts 
Using Revolute Joints

a. From the Main Toolbox, select ribbon Connectors, 
and then select Create a revolute joint.

b. To select the parts to attach, click the part Lower_Link 
and ground (the background)

c. Click the point ground.O2 to set the joint’s location.

d. Repeat the above steps to create three more revolute 
joints. 

1st Body 2nd Body Joint Location

Lower_Link ground O2

Middle_Link Lower_Link A

Middle_Link Piston_Link P

Middle_Link Upper_Link B

Piston_Link Piston D

Upper_Link ground O4

Drive_Link Upper_Link C

Gear_Link Ground O8

Gear_Link Driver_1 E

Step 13. Fix the Ground_
Support1 to the Ground

a. From the Main Toolbox, select ribbon 
Connectors, and then select Create a fixed 
joint. 

b. Click the part Ground_Support1, ground and the CG 
of Ground_Support1.

c. Repeat the above steps to create two fixed joint 
between: Ground_support2 and the ground, Cylinder 
and the ground, Driven_1 and Wheel.
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Step 14. Create a Translational Joint

a. From the Main Toolbox, select Connectors, and 
then select Create a Translational joint. 

b. Click the part Pistion, the part Cylinder and the 
CG of Piston.

c. Right-click the CG of Link 4 and select Piston.cm.X
d. Select any vector in X-direction

e. Right-click the translational joint in the model browser, 
and then select Modify

f. Click Initial Conditions, and enter 86 for Trans. 
Displ.

Step 15. Review All the Constraints

1 Fixed joint Ground_
Support1 
and ground

O2

2 Fixed joint Ground_
Support2 
and ground

O4

3 Fixed joint Cylinder and 
ground

Cylinder.cm

4 Fixed joint Wheel and 
driven_1.
gear_part

O8

5 Revolute 
joint

Lower link 
and ground

O2

6 Revolute 
joint

Lower link 
and middle 
link

A

7 Revolute 
joint

Piston link 
and middle 
link

P

8 Revolute 
joint

Upper link 
and middle 
link

B

9 Revolute 
joint

Upper link 
and drive 
link

C

10 Revolute 
joint

Upper link 
and Ground_
support2

O4

11 Revolute 
joint

Piston link 
and Piston

D

12 Revolute 
joint

Gear Link 
and ground

O8

13 Revolute 
joint

Gear Link 
and driver_1.
gear_part

E

14 Translational 
joint

Piston and 
cylinder 
with initial 
Conditions, 
86 for Trans. 
Displ.

Along the 
vertical DIR.

Section III: Textbook Problems  |  Example 25: Watt’s Linkage in a Steam Engine
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Step 16. Create a Force

a. From the Main Toolbox, select the ribbon Forces, 
and then select Create a Force. 

b. Select Piston, and then select point D.

c. Move upwards and create a force in y direction.

d. Expand the Forces tree in the Model Browser.
e. Right-click SFORCE_1, and then select Modify.

f. Enter  
120*(STEP(time, 0.25, 0.0, 0.26, 1) + STEP(time, 
0.27, 0.0, 0.28, -1) +STEP(time, 0.55, 0.0, 0.56, 1) 
+ STEP(time, 0.57, 0.0, 0.58, -1) +STEP(time, 0.81, 
0.0, 0.82, 1) + STEP(time, 0.83, 0.0, 0.84, -1)) 
into Function(time).

g. Click OK.

Step 17. Simulate the 
Motion of Your Model

a. Click the ribbon Simulation, and then select the 
Run an Interactive Simulation tool.

b. Set up a simulation with an End Time of 1 and Step 
Size of 0.01.

c. Select the Simulation Start tool.

d. To return to the initial model configuration, select 
the Reset tool.

e. Click Plotting to start PostProcessor.

f. Select Objects as Source.

g. Plot the y component of CM_Position of Piston, CM_
Velocity of Piston and SPFORCE in the graph.
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In this section, you will learn how to use a powerful simulation 

tool, Adams/Machinery, to help you solve real world problems 

more easily, especially for those models with Gears, Bearings, 

Belts, Chains, Cables or Electric Motors in their drive systems. 

Section IV. Adams/Machinery 
Applications
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Workshop Objectives
Use Adams/view to

• Simulate open differential when a vehicle makes moves straightly 
and then turns.

• Create Gear Pairs with existing gears and non-existing gears.
• Apply force and motion to the revolute joint.
• Learn the function of Booleans. 

Use Adams/Postprocessor to

• Calculate the torque ration between the pinion shaft and the axle 
shafts

 

Example 26: Open Differential 
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Ring Gear

Upper Piston Gear

Left Axle Shaft

Left Side Gear

Lower Piston Gear
Lower  

Housing

Input Piston

Right Axle 
Shaft

Right Side Gear

Upper Housing

Piston Shaft
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Software Version
• Adams 2013.2 
• Adams/Machinery Plugin with gear module 

is required 

Problem Description
• The model represents how a differential 

works.
• The left and right side gears have teeth on 

their side and they are attached directly to 
the end of the left and right axel shafts.

• The left and right axel shafts can turn freely 
on bearing in the ends

• The ring gear is attached to the input 
pinion which takes power from the pinion 
shaft which comes from the transmission.

• When the pion shaft turns and the ring rear 
and housings turns. 

Section III: Textbook Problems  |  Example 26: Open Differential

Step 1. Start Adams/View 
and Create a Database

a. Start Adams/View.

b. From the Welcome dialog box, select New Model.
c. Replace the contents of the Model Name text box 

with Open_Differential.
d. Select OK.

Step 2. Set Up Work Environment

a. From the Setting menu, select Working Grid.

b. Set the grid size along X and Y to 150 mm, and the 
grid spacing for X and Y to 5mm.

c. Select OK.



190   |   MSC Software

Step 3. Create Design Points

a. From the Main Toolbox, select the ribbon Bodies, 
and then select the Construction Geometry: 
Point. 

b. Use the default setting for points, which are Add to 
Ground and Don’t Attach.

c. Place the design point at X = -45 and Y = 0.
d. Right-click the design point, Point to Point: POINT_1, 

and then select Rename.  

e. Replace POINT_1 with ground.A.
f. Select OK.

g. Repeat the above steps to create the following design 
points.

Step 4. Create Five Pairs of Gears

a. From the Main Toolbox, select ribbon Machinery, 
and then select Create gear pair. 

b. Choose Bevel in Gear Type, and then click Next.
c. Choose 3D Contact in Method, and then click Next.
d. Set the parameters in the Geometry dialog according 

to the following figures. Note that some gears are 
created using Existing option.

e. Click Next with the default setting of Material 
f. In the Connection page, select none in Type. 

Only select Rotational Joint and ground for Ring_
Gear.

g. Click Finish.
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Step 5. Create Axle Shafts

a. From the Main Toolbox, select ribbon Bodies, 
and then select RigidBody:Cylinder.

b. Use the construction method Add to Part.
c. In the Geometry: Cylinder dialog, check Length and 

enter 100.0 mm. Check Radius and enter 20.0 mm. 
d. Select Left_Side_Gear. Click the point A, move left 

and click.

e. Repeat the above steps to create the shaft for Right_
Side_Gear.

Section III: Textbook Problems  |  Example 26: Open Differential
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Step 6. Create Shafts for Pinion Gears

a. From the Main Toolbox, select ribbon Bodies, 
and then select RigidBody:Cylinder.

b. Use the construction method Add to Part.
c. In the Geometry: Cylinder dialog, check Length and 

enter 50.0 mm. Check Radius and enter 10.0 mm.
d. Click Upper_Pinion_Gears.
e. Click the point C, move upwards and click.

f. Repeat the above steps to create the shaft for Lower_
Pinion_Gear.

Step 7. Create Housings

a. Select RigidBody:Box.
b. Select Add to Part as method in Geometry: 

Box dialog.
c. Check Length and enter 70 mm. Check Height and 

enter 20 mm. Check Depth and enter 40mm. 
Click the point F.

d. Rename the new part as Upper_Housing.

e. From the Main Toolbox, right-click Position: 
Reposition objects. 

f. Select Position-Move.

g. In the Position:Move dialog, check Selected 
and select Vector method. Enter 20mm in Distance.

h. Select Upper_Housing, and then select any vector 
pointing into the working area.

i. From the Main Toolbox, select ribbon Bodies, and 
then select RigidBody:Cylinder.

j. Select Add to Part as method in Geometry: Box 
dialog.

k. In the Geometry: Cylinder dialog, check Length and 
enter 20.0 mm. Check Radius and enter 20.0 mm.

l. Select Upper_Housing. Click the point F, move 
upwards and click.

m. Select Booleans: Cut out a solid with another.
n. Select Upper_Housing.BOX27, and then select 

Upper_Housing.Cylinder28.
o. From the Main Toolbox, select ribbon Bodies, 

and then select RigidBody:Cylinder.
p. Select Add to Part as method in Geometry: Box 

dialog.
q. In the Geometry: Cylinder dialog, check Length and 

enter 20.0 mm. Check Radius and enter 10.0 mm.

r. Select Upper_Housing. Click the point C, move 
upwards and click.

s. Select Booleans: Cut out a solid with another.
t. Select Upper_Housing.CGS29, and then select 

Upper_Housing.Cylinder30.
u. Select Position-Move.

v. In the Position:Move dialog, check Selected 
and check Copy.

w. Select Vector method and enter 120mm in Distance.

x. Select Upper_Housing, and then select any vector 
which is vertical downwards.

y. Rename the new part as Lower_Housing

Step 8. Create Pinion Shaft

a. Select Setting -> Working Grid…
b. Select Global YZ in Set Orientation
c. Click OK.

d. From the Main Toolbox, select ribbon Bodies, 
and then select RigidBody:Cylinder.

e. Use the construction method Add to Part.
f. In the Geometry: Cylinder dialog, DO NOT check 

Length. Check Radius and enter 10.0 mm. 

g. Click Input_Pinion_Gear.
h. Click the point E, and then click point H.
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Step 9. Color the Parts

a. From Model Browser, left-click the plus beside 
Platen_Right displayed under the Bodies tree

b. Right-click Right_Axle_Shaft and select 
Appearance. 

c. In the Edit Appearance dialog, enter Aquamarine 
beside Color.

d. Click OK.

e.  Repeat the above steps to change the color of the 
other parts.

Step 10. Create Revolute Joints

a. From the Main Toolbox, select ribbon 
Connectors, and then select Create a revolute 
joint.

b. Click the part Left_Pinoin_Gear and the ground.

c. Click the center point at the end of the shaft of Left_
Pinion_Gear.

d. Repeat the above steps to create the revolute joint 
between Right_Pinoin_Gear and the ground.

e. Change the grid orientation to Global XZ.
f. Create revolute joints between

a. Lower_Housing and Lower_Pinion_Gear  

at point F
b. Upper_Housing and Upper_Pinion_Gear  

at point G
g. Change the grid orientation to Global XY
h. Create revolute joints between

a. Input_Pinion _Gear and the ground at point H

Step 11. Create Fixed Joints

a. From the Main Toolbox, select ribbon 
Connectors, and then select Create a fixed 
joint. 

b. Click the part Upper_Housing, Ring_Gear and point 
Upper_Housing.cm.

c. Repeat the above steps to create another fixed joint 
between Lower_Housing and Ring_Gear.

Section III: Textbook Problems  |  Example 26: Open Differential
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Step 12. Create Motion on 
Revolution Joints

a. From the Main Toolbox, select the ribbon Motion, and 
then select Rotational Joint Motion. 

b. Select the revolution joint between the Right_Shaft 
and the ground.

c. Rename it as Motion_Right.
d. Right-click Motion_Right in the model browser, and 

select Modify.

e. Enter 10 + STEP(time, 1, 0, 2, 5.0) into Function
f. Repeat the above steps to create Motion_Left. 
g. Enter 10 - STEP(time, 1.0, 0.0, 2.0, 5.0) into 

Function for Motion_Left.

Step 13. Simulate the 
Motion of Your Model

a. Click the ribbon Simulation, and then select the 
Run an Interactive Simulation tool.

b. Set up a simulation with an End Time of 5 
seconds and Step Size of 0.01.

c. Select the Simulation Start tool.

d. To return to the initial model configuration, select 
the Reset tool.

Remarks: It may take several minutes to run the 
simulation.

Step 14. Use Adams/PostProcessor

a. In the Simulation Control panel, click Plotting. 

b. Select Source as Objects.

c. Select body as Filter.
d. Select CM_Angular_Velocity of Left_Side_Gear, 

Right_Side_Gear and Input_Pinion_Gear..
e. Click Add Curve.
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Section III: Textbook Problems  |  Example 22: Open Differential
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Workshop Objectives
• Modify the current planetary model and compare results in post-

processor
• Get familiar with wizard interface

Software Version
Adams 2013.2

Files Required
• Planetary_start.cmd
• Located in the directory exercise_dir/Example 27

Example 27: Planetary Gear Sets Modification

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum
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Section IV: Adams/Machinery Applications  |  Example 27: Planetary Gear Sets Modification

Step 1. Launch Adams and Import start 
file

To get started: import the initial model:

a. Launch Adams/View
b. Select Existing Model
c. Browse for Planetary_start.cmd and hit OK

Step 2. Create the Planetary Gear

a. Click Planetary Gear under “Machinery” Tab.

b. Click Next.

c. Choose “Simplified”, then Next. 

d. On Geometry page, choose the default setting, click 
Next.

e. On Material page, choose the default setting, click 
Next.

f. On Connection page, fix the Sun gear to the existing 
“PART_2”. 

g. Click Next. Then click Finish.
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Step 3. Run the simulation

a. Click on the run icon from the Simulation tab 

b. Set “End Time” and “Steps” as shown.

c. Hit the Run button to run the simulation.  

d. Click on Save the results to save the last simulation 
as P1
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Step 3. Change the number 
of planet gears

a.  Right click Planet_set_1 in Gear systems in 
model browser, and choose Modify.

b. Click Next until you get to the Geometry 
setup window. 

c. Change the number of planet gears from 3 
to 4, and then continue to click Next until the 
Finish button appears. Then click Finish to 
complete the wizard.

Step 4. Change the number of teeth

Next, change the number of teeth for Planetary 
gear set 1. To do this: 

a. Modify Planet_set_1 again and run through 
the wizard, but change the Number of Teeth 
on the Geometry step. 

b. Follow the rule: 
Sum(Sun-teeth + 2*planet-teeth) should 
equal Ring-teeth 
and 
Sum(Sun-teeth + Ring-teeth) should be 
EVENLY divisible by number of planets

c. For example: 
Sun Gear: 25; Ring Gear: 71; Planet Gear: 
23
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Section IV: Adams/Machinery Applications  |  Example 27: Planetary Gear Sets Modification

Step 5. Run the simulation again

a. Click on the Rewind button

b. Run another simulation with 2 seconds and 200 
steps

c. Save simulation results as P2

Step 6. Open postprocessor

a. Go to the post processor 
b. Change Source to Result Sets 

Step 7. Compare results

a. Choose P2 in Simulation 

b. Click the result REQ_SIMPLIFIED_Planet_1_to_ring 
and Total Force (which means the contact force 
between Ring gear and one of the planet gears in Gear 
set 1).

c. Click Add curve
d. Choose P1 in Simulation 

e. Click the result REQ_SIMPLIFIED_Planet_1_to_ring 
and Total Force 

f. Click Add curve
In P1, there are 3 planetary gears; In P2, there are 4 
planetary gears. That’s why the contact force on each 
planetary gear is decreased from P1 to P2.
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Workshop Objectives
• Investigate the system dynamics with Ideal Joint and with Bearing. 
• Compare the effect of Ideal Joint and Bearing on system dynamics. 

Software Version
Adams 2013.2

Files Required
• CamBearings_start.cmd
• Located in the directory exercise_dir/Example 28

Example 28: Bearing System Workshop
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Section IV: Adams/Machinery Applications  |  Example 28: Bearing System Workshop

Step 1. Import Start File

To get started: import the starting model:

a. Open Adams/View from the directory 
exercise_dir/Example 24

b. Import the file CamBearings_start.cmd.

Step 2. Simulate Baseline System

Run a simulation to get familiar with the system operation. 
To do this: 

a. Run a simulation for (1/50)s, 100 output steps. 

b. Animate the system a few times and inspect the 
behavior.

c. Save the results as With_Revolute.
d. In Adams/Post processor plot the result of FX and 

FY for Revolute Joint.

Step 3. Create First Bearing

Next, create the first Bearing in the model. Currently there 
is a revolute joint and motion between the camshaft and 
ground. We will replace this system with bearing system. 
To do this: 

a. Deactivate Revolute_motion, Revolute_joint. 
b. Select the Create Bearing icon. 
c. In the Bearing Method select Detailed
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d. Advance to the Type tab. Select the Type as Needle 
Roller Bearing with/without internal ring.

e. Advance to the Geometry tab and input all the 
parameters, as shown:

a. Select Bearing location as MARKER_71.

b. Select Create Bearing From Database.

c. Enter Bearing Diameter as 30 mm.
d. Select Bearing Type Koyo NA4906.

f. Advance to the Connection tab and input all the 
parameters as shown:

a. Select Shaft as Main_Shaft and Housing as 
ground. 

b. Select Impose Motion On. 

c. Input rotation about z-axis as: disp(time) = 
50*360d*time

d. Translation about z-axis is fixed

e. Leave rest as default

g. Advance to the Completion tab and Finish the 

operation to build the first Bearing. 

Step 4. Create Second Bearing

Next, create the second Bearing in the model. To do 
this: 

a. Select the Create Bearing icon.

b. Select Method and Type as same as first Bearing.

c. Advance to the Geometry tab and input all the 
parameters as shown:

a. Select Bearing location as MARKER_1.

b. Enter Bearing Diameter as 20 mm.

c. Select Bearing Type Koyo NA4904.

d. Advance to the Connection tab and Select Shaft as 
Main_Shaft and Housing as ground. Leave rest as 
default.

e. Advance to the Completion tab and Finish the 
operation to build the Second Bearing. 
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Step 6. Create Bearing REQUESTs

Adams/Machinery provides common bearing properties in 
the form of REQUEST elements. To create a REQUEST for 
the bearing characteristics: 

a. From the main toolbar select the Machinery tab 
and then the Bearing Output button. 

b. Select the first bearing: Bearing_1.
c. Select all of the output characteristics. Select 

lubrication properties as shown in figure. 

d. Hit OK to create the REQUEST. 

e. Repeat the process for the second Bearing in the 
model. 

Step 5. Check Completed Model

The model with both the Bearings should look like as 
follows:

Section IV: Adams/Machinery Applications  |  Example 28: Bearing System Workshop
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Step 7. Simulate and Investigate

Run a simulation for the bearing system:

a. Run a dynamic simulation for (1/50)s, 100 output 
steps. 

b. Save this analysis to the database as With_Bearing. 

c. Switch to Adams/PostProcessor and compare 
the result of FX and FY of Revolute joint with that 
of Bearing Forces Radial_X and Radial_Y of first 
bearing.

d. Plot Service life for both the bearings.

Step 8. Further Investigation

Investigate the system performance in other ways.

a. Check the Displacement along x and y axis. 

b. Change Bearing 2 to bearing type Koyo NA4904R 
and compare the results (Koyo NA4904R has 9 rollers 
as compared to Koyo NA4904 which has 12 rollers).

c. Change the damping factors and check its effect on 
the results.

d. Try changing lubricant properties from bearing output 
and compare the results.

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   205  MSC Software   |   205

Section IV: Adams/Machinery Applications  |  Example 28: Bearing System Workshop
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Software Version
Adams 2013.2 

Problem Description
Build a simple belt system with two pulleys and one tensioner. The 
pulleys are rotating about axes parallel to global z axis. The center 
distance is 400mm. The pulley is actuated to rotate at constant speed. 
A box is hanging above the belt system and is dropped at simulation 
time=0.5s. Adams/View Command Language is used to create 
multiple contacts and Simulation Script is used to deactivate the fixed 
joint between the box and the ground.

Example 29: Simple Belt Example
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e. Select Method: 2D Links. This method is only used 
for the cases where the axis of rotation of pulleys are 
parallel to the global axes. Since this is exactly what we 
are modeling, we can use this method instead of more 
complicated ones. Browse through each method to 
learn the differences among each other.

f. Click Next.

g. Name the first pulley P1. Enter (-200, 0, 0) for Center 
Location.

h. Click on Tab 2 and name the second pulley P2 and 
enter (200, 0, 0) for Center Location. Here we are 
making the center distance of the pulleys to be 400 
mm. This is not a large distance. The reason we use 
such a small distance is that in this way, with less 

Step 1. Open Adams/View 
and Create a New Model

a. Open Adams/View 2013.2 and select New Model.
b. Name the model Belt and select a Working Directory.

c. Click OK.

Step 2. Build the Pulleys

a. To build a belt system, we would create the pulleys and 
tensioners first.

b. From Machinery ribbon, select Belt: Create Pulley.

c. Change the Pulley Set Type to Smooth. This 
configuration creates a simple flat belt system. By the 
end of this example, feel free to choose other types of 
pulley sets.

d. Click Next.  

Section IV: Adams/Machinery Applicaitons  |  Example 29: Simple Belt Example
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elements modelled, it is faster to run the simulation. 
This is sufficient for illustrative purposes.

i. Click Next.
j. Leave the material properties of pulleys as default. 

Click Next.
k. Leave the connection page as default and click Next. 

In this tutorial, we are actuating the pulley using the 
built in module of Adams/Machinery. We can also use 
other bodies to actuate the pulley. For example, we can 
choose Type: Fixed to fix the pulley to an existing shaft. 
Later, we can impose a motion/torque on the shaft to 
actuate the pulley. Here, by selecting Type: Rotational, 
Adams/Machinery will automatically create a revolute 
joint between the pulley and the body specified.

l. Now we are asked to select the output of the pulley. 
Check all the parameters and click Next.

m. Now we have completed the specification of the 
pulleys. In the next step, we will navigate to the pages 
where tensioners are specified.

Step 3. Build the Tensioner

a. Under Geometry-Tensioners page, change the 
Number of Tensioner with Deviation Pulley to 1.

b. Pick Rotational Type and Name the Tensioner to T1.

c. Enter (0, -200, 0) for Pivot Center. This will locate the 
tensioner beneath the belt system.

d. Enter 140, 30, 30 for Length, Width and Depth 
respectively. Set the Installation Angle to 90. This 
means that the deviation pulley is installed 90 degrees 
counter-clock wise about z axis, which is desired in 
this case.

e. Name the Deviation Pulley D1 and enter 30 for Pulley 
Radius.

f. Under In/Out, pick Out. This is important because this 
determines which side the belt will wrap around the 
deviation pulley. Click Next. 

g. Leave the material properties as default and click Next.
h. Under Connection page, we connect the tensioner to 

ground.

i. Enter 300, 0.1, 50 for Stiffness, Damping and Preload. 
These values are for illustrative purposes. Click Next 
and then Finish.

Step 4. Build the Belt

a. From Machinery ribbon, select Belt: Create Belt.
b. Right click in the name field and go to pulley_set-

>Guesses->beltsys_1.pulleyset_1.

c. Click Next.
d. Select 2D Links Method, or make sure the method 

is consistent with your pulley modeling method. Click 
Next.
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e. There are a number of parameters we can set to 
determine the geometry of the belt. Press F1 to check 
what each of the parameters does. Change the 
Segment Length to 7.5 and then click Next.

f. This page is to specify the contact and mass property 
of belts. This is beyond the scope of this tutorial. If you 
want to learn more about this, press F1 to view the 
Help documents. Click Next.

g. Now we have to specify the Wrapping Order. Right 
click in the field and go to UDE_Instance->Guesses-
>Pulleyset_1.pulleyset_1_P1. Choose P2 and 
D1. Make sure the wrapping is in the order of P1, P2 
and D1. The wrapping order is clockwise about the 
positive axis of rotation. Click Next. 

h. A message will tell you the number of segments and 
the tension. Write the number of segments down 
because it will later be used when we are creating the 
contacts. It is 138 in this example. Click Yes. You might 
see a warning. This is merely telling us that we should 
choose C++ solver. We will set this when we are about 
to run the simulation. 

i. Check Span Request and Segment Request. Right 
click in the field to select any of the segments. What 
is important is to get to know that we can get useful 
outputs from Adams/Machinery. Click Next and then 
Finish.  

Step 5. Create Actuator

a. From Machinery ribbon, select Belt: Belt Actuation 
Input.

b. Right click in the Name field and select the pulley set 
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we have created. 

c. For the actuator pulley, select P1. Click Next. 

d. Pick Motion for Type. Click Next.
e. Select Function: User Defined and enter step(time, 

0,0,0.25,40). This defines a step function in Adams. 
Step function in Adams has been explained in Example 
18. Click Next.

f. Check all the requests. Click Next and then Finish.

Step 6. Set Solver Settings

a. From the menu bar, select Settings->Solver-
>Executable.

b. Under Solver, select C++. 

c. Change category from Executable to Dynamics and 
select Integrator: HHT.

Step 7. Run a Simulation

a. Run a simulation with 1 second and 100 steps. Set 
Sim. Type to Dynamic. Make sure that the model 
works well.

b. The simulation make take time depending on the 
configuration of your machine.  

Step 8. Create a Box

a. From Bodies ribbon, select RigidBody: Box.

b. Pick New Part and check all three dimensions. Enter 
30 in all the fields. This will create a cube that is equal 
in depth as the belt.

c. Right click in the background and invoke the Location 
Event.

d. Enter 0, 60,-15 as the corner of the cube.  
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Step 9. Create a Fixed Joint

a. Now a fixed joint will be created between the box and 
the ground. This joint will later be deactivated during 
simulation using script.

b. From Connectors ribbon, select Joint: Fixed.

c. Pick the box first and then the ground. Pick PART_#.cm 
as the location. You can right click around the cube to 
invoke the select list. # is the number of the part in your 
model. 

Step 10. Create Contacts using 
Adams/View Command Language

a. In order to model the interaction between the dropping 
box and the belt, contacts should be added between 
the box and the belt. Since the belt is composed of 
138 segments, we have to add 138 contact pairs. This 
is tedious to accomplish if we create them separately. 
However, Adams/View Command Language enables 
us to include this process in a for loop.

b. Right click on contact.cmd located in the start file 
folder and edit it with any text editor of your choice.

c. When the file opens, you should see the following lines. 

d. Make several changes to the template.

e. In line 1, replace the nubmer after “end_value =”with 
the number of segments you write down in step 4h.

f. In line 3, replace Belt with your model name in case 
you name your model in your own way.

g. In line 6, replace BOX_3264 with BOX_# where # is 
the number of the box. You can browse your model 
tree to determine this number. 

h. Save the changes to contact.cmd. For more 
information about Adams/View Command Language, 
please refer to Adams Online Help Document.

Step 11. Import the .cmd

a. From the menu bar, select File->Import.
b. Under File Type, select Adams/View Command File 

(*.cmd).
c. Right click in the File to Read field and browse to 

contact.cmd. Click OK. 

d. Expand the Forces in model tree and you will find that 
138 contacts has been added. 
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e. Now the view window is messy because of the 
contacts added.  

f. Press V to hide the icons.

Step 12. Create a New Simulation Script

a. From Simulation ribbon, select Setup: Create a new 
Simulation Script.

b. Choose Script Type as Adams/Solver Commands. 

c. Under the menu of Append ACF Command, choose 
Dynamic Simulation. 

d. Enter 50 and 0.5 for Number of Steps and End Time. 
Click OK.

e. Now a new line has been appended to the script. 

f. From the drop down menu, select Deactivate.

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   213  MSC Software   |   213

g. Right click and browse for the fixed joint in the Joint 
Name field. Click OK. Note that the ID number of the 
joint may vary.

h. Now another line has been added.

i. Add another line of dynamic simulation which ends at 
t=1.4s with 90 steps.

j. The final Adams/Solver Commands would look like 
this. The simulation will start with a dynamic simulation 
at t=0. At t=0.5s, the fixed joint is deactivated and the 
cube drops. A dynamic simulation continues and ends 
at t=1.4s. Click OK. 

Step 13. Run a Scripted Simulation

a. From Simulation ribbon, select Simulate: Run a 
Scripted Simulation.

b. Right click in the Script Name field and select the script 
just created.

c. Start Simulation.

d. The simulation would take some time depending on 
your machine. After simulation, press F8 to enter 
postprocessing window and you may check the result 
output of the belt now.

e. Select Result Sets as Source, expand beltsys_1 
and then belt_1. Pick belt_1_span_at segment_10. 
Select Tension_force and then click Add Curves.
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Workshop Objective
Use Adams/Machinery

• Create, simulate and animate the serpentine belt system.

Software Version
• Adams 2013.2
• Adams/Machinery Plugin with belt module is required

Files Required
• serpentine_belt_start.cmd
• Located in the directory exercise_dir/Example 30

Example 30: Serpentine Belt System
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Section IV: Adams/Machinery Applications  |  Example 30: Serpentine Belt System

Problem Description
• The model represents a serpentine belt 

system.
• The crank shaft is being rotated at a given 

velocity.
• The rotation of crank shaft pulley is 

transferred to the other pulleys through the 
belt.

Tips before you start
• Deactivate Solver Compatibility Checking: 
a. When reading/writing model files Adams/View will, by 

default, check modeling elements for compatibility with 
the C++ Solver. 

b. This checking can be time consuming for models with 
many parts. 

c. Turn this check off via:

a. Tools -> Command Navigator and then

b. defaults -> solver and then

c. Compatibility Checking = Off

• Turn off Model Verify:
a. Adams/Solver checks for redundant constraints, 

massless parts, etc before simulations. This can be 
time consuming for large models. 

b. Turn off Model Verify via: 

a. Settings -> Solver -> Executable
b. Set Verify First = No

Step 1. Import File

a. Start Adams/View. 
b. From the Welcome dialog box, select Existing Model.
c. Click the file folder icon, and the Select Directory dialog 

box appears. 

d. Find and select the directory Exercise_dir/belt_
module

e.  Click OK.

f. Click on the file folder icon of the File Name, select the 
file

g. serpentine_belt_start.cmd and click Open.

h. Click OK on the Open Existing Model dialog box

Step 2. Build the Pulley Set

a. Click on Create Pulley icon under Belt ribbon. 

b. Set Belt System Name as beltsys_1. 
c. Set Pulley Set Name as pulleyset_1. 
d. Select Smooth as a Type.

e. Click on Next
f. Select 2D Links as a Method

g. Click on Next

Step 3. Geometry & Material Properties

a. Enter 4 in the field Number of Pulleys and hit Enter.
b. Select Axis of Rotation as Global Z
c. Click on tab “1” and enter Name crank_shaft_p for 

Pulley1

d. Enter 0,0,0 in field Center Location.

e. Enter 30 in the field Pulley Width
f. Enter 150 in the field Pulley pitch diameter
g. Click on tab “2”, “3” and “4” to enter values for 

Pulley2, Pully3 and Pully4.
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h. Click on Next button

i. Specify Pulley Material

j. Keep default material for Pulleys 1, 2, 3 and 4

k. Click on Next button

Step 4. Pulley Connection

a. Click on Pulley1 tab to define connection for crank_
shaft_p.

b. Select Type as Fixed to fix the pulley to crank_shaft
c. Select Existing for Body to enter existing part name 

to which pulley will be connected using selected Type 
as Fixed.

d. Right click -> Body -> Guesses -> and select part 
name crank_shaft (or Browse for existing part)

e. Click on tab “Pulley2”, ““Pulley3” and “Pulley4” to 
enter values for Pulley2, Pulley3 and Pulley4.

Step 5. Specify Pulley Outputs

a. Select default outputs for Pulleys 1, 2, 3 and 4 for post 
processing using Adams/PostProcessor

b. Click on Next button.

c. Completion-Pulleys page concludes the pulley 
specification.

d. Click on Next button.

Step 6. Geometry-Tensioners

a. Enter 3 in the field Number of Tensioner with Deviation 
Pulley and hit Enter.

b. Select Type as Fixed for tab “1”

c. Enter Name as dev1 for Deviation Pulley1

d. Select Axis of Rotation as Global Z

e.  Enter 20,240,0 in the field Center Location.

f. Enter 60 in the field Pulley radius

g. Select Out for In/Out

h. Repeat the above steps to setup Tab 2 & 3.

Additional setup in Tab 3: 
Tensioner3 Name: Ten3

Pivot Center: -50.0, 470.0, 0.0 
Length: 140 
Width: 20 
Depth: 30 
Installation Angle: 225 
Connection Between Tensioner and Deviation 
Pulley: Yes
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Step 7. Material & Connection Tensioners

a. Keep default material for Deviation Pulleys 1, 2 and 3 
and Tensioner

b. Click on Next
c. Click on Tab “3” to define connection for tensioner3.

d. Select Yes for Tensioner connector

e. Select Existing for Body to enter existing part name.

f. Right click -> Body -> Guesses -> and select part 
name tensioner_shaft (or Browse for existing part)

g. Enter 100 for Stiffness, 1 for Damping and 100 for 
Preload

h. Click on Next.
i. Click on Finish

Step 8. Create Belt

a. Click on Create Belt icon under Belt ribbon.  

b. Select the name of the existing pulleyset to be 
used. Right click -> Name -> Guesses -> and select 
pulleyset name (or Browse for existing pulleyset).

c. Select Next to advance to the next Step.

d. On the Method Step specify 2D Links for the belt 
type.

e. Click on Next.

Step 9. Belt Geometry

a. Select Axis of Rotation as Global Z
b. Enter 10 in the field for Segment Length. Note that 

the user can also choose a larger segment length to 
reduce the computation time and then gradually refine 
the model if the model has been verified.

c. Enter 3.6 for Belt height and 30.0 for Belt width
d. Enter Belt Stiffness values as shown.

e. Select the Contact Settings button and use the 
settings shown on the following page.

f. Click on Next button.

Step 10. Belt Contact Settings

In the Contact Settings screen use the values shown 
here:
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a. Specify the properties as shown. 

b. Select OK to return to the wizard tab.

Step 11. Belt Mass

a. Specify the properties as shown. 

b. Click on Next button.

Step 12. Belt Wrapping Order

a. Read the Notes below and then use the following for 
the belt wrapping order:  
.serpentine_belt.beltsys_1.pulleyset_1.pulleyset_1_
crank_shaft_p 
.serpentine_belt.beltsys_1.pulleyset_1.pulleyset_1dev_
dev2 
.serpentine_belt.beltsys_1.pulleyset_1.pulleyset_1_
alternator_shaft_p 
.serpentine_belt.beltsys_1.pulleyset_1.pulleyset_1_ac_
shaft_p 
.serpentine_belt.beltsys_1.pulleyset_1.pulleyset_1dev_
dev3 
.serpentine_belt.beltsys_1.pulleyset_1.pulleyset_1_
power_strg_shaft_p 
.serpentine_belt.beltsys_1.pulleyset_1.pulleyset_1dev_
dev1

b. Important Notes on Belt Wrapping: 
• Belts must be wrapped in a clockwise fashion with 

respect to the belt axis of rotation. 

• Right-click and ‘pick’ functionality does not currently 
work for pulleys – you must use the ‘Guesses’ and 
‘Browse’ functionality. 

• Note that pulley names are shown in the modeling 

window to help when using the ‘Guesses’ functionality. 

• Click on Next button

Step 13. Belt Output

a. Select both the Span Request and Segment 
Request checkboxes. 

b. Right click in the field and select parts, then select 
Browse/Guess. Select an arbitrary belt part from the 
list for both the belt span and segment outputs.

c. Follow the similar procedure in b and select ground as 
Reference part.

d. Click on Next button.
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Section IV: Adams/Machinery Applications  |  Example 30: Serpentine Belt System

a. Open the Solver Dynamics settings via the menu picks:

a. Settings -> Solver -> Dynamics

b. For Dynamics use these parameters: 

a. Integrator = HHT

b. ERROR = 1e-5

c. In this dialog box change the Category to be 
Executable and make the changes:

a. Choice = C++

b. Verify First = No

The changes above instruct the Solver to use the HHT 
integrator which is best for belt/chain models. 

Step 14. Belt Completion

The system with a properly wrapped belt 
should look like the following: 

Step 15. Simulation Setup

Ensure that appropriate settings are used for Adams/
Solver while handling belt (many parts) simulations. Do the 
following: 
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Step 16. Simulate & Animate

a. Ensure that there is a MOTION on the crank shaft joint, 
JOINT_1. The MOTION should be of type Velocity and 
use the following function expression to gradually spin 
the crank shaft input up:  
step5(time, 0, 0, 1, 180d)

b. Run a dynamic simulation for 2 seconds, 200 output 
steps.  

c. Animate the results.

d. Note that the simulation may take a long time 
depending on the configuration of your machine.

Step 17. Investigate System

Create further animations and plots to illustrate things such 
as: 

a. How does the belt tension (found in the belt segment 
REQUEST) vary over time? 

b. Does slippage occur in the belt tensioner? (View 
the angular velocity of the tensioner deviation pulley 
through time). 

Workshop Questions

1. When specifying a belt wrapping order, what 
orientation must be used?  
  
  
  
  
 

2. Pulleys can be connected to the model using three 
different specifications; list them:   
  
  
  
  
 

3. Which integrator is suggested for belt/chain systems 
(systems with many inter-connected parts that move 
only slightly with respect to one another)?  
  
  
  
  
 

Answers:

1. When wrapping the belt the pulleys must be specified 
in a clockwise sequence with respect to the pulley axis 
of rotation. 

2. Pulleys can be attached to the model using rotational 
joints, fixed joints or bushings (compliant). 

3. The HHT integrator is generally best for belt/chain-
type systems. Run your simulation with the default 
ERROR control (1e-5) for HHT and then re-run with 
tighter ERROR control to see if results change. If 
results change with tighter ERROR then run a solution 
convergence study on the ERROR parameter to identify 
a proper setting. 
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Workshop Objectives
• Create both the helical gear pairs and the bevel gear pair
• Get familiar with the parameters to set up the gear pair
• Learn to convert a rigid part to a flexible part
• Use dummy parts to connect a flexible part with bearings or gears

Software Version
• Adams 2013.2
• Adams/Machinery Plugin with gear and bearing module is required

Files Required
• Withbacklash.cmd
• Directory: exercise_dir/Example 31

Example 31: Gear Train
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Section IV: Adams/Machinery Applications  |  Example 31: Gear Train

Step 1. Launch Adams and Import start file

To get started: import the initial model:

a.  Launch Adams/View
b. Select Existing Model
c. Browse for Withbacklash.cmd and hit OK

Step 2. Add the gears pairs

a. Under the Machinery ribbon, select Create gear pair.
b. Select Helical as Gear Type, and click Next.
c. Select 3D Contact as Method, and click Next.
d. Set up the Geometry page as shown in Figure. Center    

location of Gear 2 is (0.0, 194.55609294, 0,0).

e. Use the default settings of Material, and click Next.
f. For GEAR1, select Fixed. Right click the content of 

Body and select Body->Pick
g. Click PART_6 in the working area, and click Gear2.

h. For GEAR2, select Fixed. Right click the content of 
Body and select Body->Pick

i. Click PART_5 in the working area, and click Next.
j. Click Finish.

k. Repeat the above steps to create the other two pairs of 
gears.

Figure: Geometry Setting of Gear Pair 1 
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Figure: Geometry Setting of Gear Pair 2 

Figure: Geometry Setting of Gear Pair 3 

Step 3. Run the simulation

a. Click on Run an Interactive Simulation.
b. Click Simulation Settings… at the bottom of 

Simulation Control panel.
c. Select Dynamics as Category, and select HHT as 

Integrator.
d. Run another simulation with 0.2 seconds and 

200 steps

Step 4. Connect a gear to a dummy part

a. Right-click Driver_1_Driven_1, and select Modify.

b. Click Next to the Connection page.

c. Under the GEAR1, replace content of the Body with 
Gshaft part.  

Step 5. Convert PART_6 to a flexible body.

a. Right-click PART_6 in the working area.

b. Select Part: PART_6 -> Make Flexible
c. Click on Create New.
d. Enter 8 in Number of Modes.
e. Check Stress Analysis and Advanced Setting.
f. Select Size in Element Specification.

g. Enter 3.0mm for Element Size and 2.0mm for 
Minimum Size.

h. Click Attachments, and then click Find 
Attachments.

i. Select the tab 1. 
j. Select Closest nodes in Selection Type and enter 

10 for Number of nodes.
k. Apply the same settings for tab 2 and tab 3.

l. Click OK
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Step 6. Show results in 
Adams/Postprocessor

a. Run the simulation again.

b. To start Adams/Postprocessor, Click Plotting in 
the Simulation Control panel. 

c. Arrange the animation and plots in the same 
window by click Page Layout 
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226   |   MSC Software

Software Version
Adams 2013.2 

Problem Description
Build the windshield wiper mechanism including electric motor and 
worm gear. Find the velocities and accelerations of the wipers as they 
travel through the wiping cycle.

Example 32: Windshield Wiper Mechanism
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Step 1. Start Adams/View.

a. Start Adams/View 2013.2.

b. Select Existing Model and browse for Windshield_
Wiper_start.cmd in the exercise start folder.

c. Click OK.

Step 2. Observe the model

a. In our completed model, the system is driving by an 
electric motor. A worm gear pair transmits the motor 
torque to the wipers through two four bar linkage 
systems sharing one common link (mot_link). The spur 
gear is fixed on the red motor shaft which is rigidly 
linked to mot_link. A worm gear fixed at the rotor of the 
motor drives the spur gear. There is a green sphere 
called Dummy_shaft which is used to locate the 
position of the motor.

b. We will build the electric motor and worm gear in the 
following steps.

Step 3. Create the Motor

a. From the Machinery Ribbon, select Create Motor.

b. Select Analytical in Method, then click Next.

c. Select DC in Motor Type, then click Next.

d. To set the motor location, right click in the blank field 
and select Parameterize->Expression Builder. From 
the drop down menu on the left, choose Location/
Orientation. Double click LOC_RELATIVE_TO. 

e. Change the Array to 0, -30, 0.

f. Delete OBJECT and leave the cursor as where it is.

g. Right click in the field of Getting Object Data and click 
Browse. Select Dummy_shaft.cm.

h. At the place where “OBJECT” was, click “Insert Object 
Name”. Then click OK.
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i. Choose CW as Direction. Right click next to Rotor 
Attach Part and go to Body->Guesses->Dummy_shaft. 
Select Fixed in the drop down menu on the right. 
Similarly, fix stator to the ground.

j. Choose Orientation as Axis of Rotation and enter 0, 90, 
0. Click Next.

k. Check Detailed Geometry. Set the Motor Geometry 
as shown in the figure below. Choose Geometry and 
Material Type to define mass for both Rotor and Stator.

l. Set the Input as shown in the table below, choose 
Shunt and then click next.

No. of Conductors 16

Flux Per Pole 0.1

Source Voltage 24

No. of Paths 20

Armature Resistance 0.35

No. of Poles 12

m. Choose Scale Factor for Multiply and set scale factor 
as 1, then click Finish. Ignore the warning.

Step 4. Create a Worm Gear Pair

a. From Machinery Ribbon select Create Gear Pair.

b. In Gear Type, select Worm, then click Next.
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c. Set Method as Simplified, then click Next.

d. Enter 1 in Module.

e. Set the Geometry as shown in the table. To set the 
Center of Location of Worm, right click in the blank field 
and select Reference_Frame and then select Browse. 
In the Database Navigator, choose Dummy_shaft.cm. 
To set the Center of Location of Worm Wheel, use the 
method illustrated in Step 11 to locate it (30,0,0) relative 
to Dummy_shaft.cm. Set 0 for Helix Angle in this 
step as the actual value will be calculated by Adams 
automatically and it will be changed later. Leave the 
rest as default and then click Next.

Worm Worm Wheel

Axis of Rotation Global Y Global Z

No of Teeth 1 50

Face Width 50 5

Reference 
Diameter 

10

Flank Form ZA

f. Choose Geometry and Material Type to define mass for 
both worm and worm wheel. Then click Next.

g. Fix the worm gear to the rotor of motor and worm 
wheel to “Shaft”. Click Next then Finish.

h. It may take some time for Adams to create the gear 
pair. The final model should look like the configuration 
below.
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Step 5. Modify Helix Angle

a. From the model tree, double click Driver_1_Driven_1.

b. Navigate to Geometry page. A warning message is 
shown.

c. Click Ok, then set Helix Angle as 5.7. Click Next and 
leave everything unchanged. Click Finish on the last 
page.

Step 6. Simulate the Model

a. From Simulation Ribbon, select Run an Interactive 
Simulation and run a simulation of 3 seconds with 300 
steps. The mechanism should run smoothly. Make sure 
that MOTION_1 is deactivated.

Step 7. Postprocessing the Result

a. Press F8 to enter postprocessing window.

b. Choose Objects as Source. Click body in Filter.

c. Browse for Wiper_left in Object and double click it to 
expand. Highlight cm.

d. Pick Angular_velocity and then select Mag as 
Component.

e. Click Add Curves.

f. Similarly, in a new page, select Angular_Acceleration, 
Mag and click Add Curves.
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Software Version
Adams 2013.2 

Problem Description
Use Adams/Machinery to model the two-stage planetary gear train 
in wind turbine’s gear box. The output shaft (high speed shaft) is 
connected to a generator, which is modelled using motor module in 
Adams/Machinery. The blades and the tower are modelled as flexible 
bodies. Torque and power generated by the generator can be studied 
in postprocessing.

Example 33: Windturbine
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d. Right click in the Center Location field, direct 
to Reference_Frame->Browse. In Database 
Navigator, find ref_stage_1_center and double click.

e. Select Global X as Axis of Rotation. 

f. Right click at Module and go to Reference Design 
Variable.

Step 1. Topology of the 
Gear Train Explained

a. The topology of the gear set is explained first. A 
planetary gear set requires two inputs to determine one 
output. In the first stage planetary gear set, the gear 
carrier (no graphical representation) is connected to the 
low speed shaft which is rotating at the same angular 
velocity as the hub. This is our first velocity input. The 
second velocity input of planetary gear set is usually a 
zero input (fixed). In stage one, the ring gear is fixed in 
the gear box which provides another velocity input. The 
output of this planetary gear set is the velocity of the 
sun gear. 

b. At stage two, the carrier is rigidly connected to the sun 
gear of stage one (also no graphical representation). 
The ring gear is fixed to gear box. These two comprises 
the required input. The predictable output is the 
rotation of the sun gear.

c. At the final stage, there is a spur gear pair. Low speed 
gear is connected to the sun gear of stage two. High 
speed gear drives the high speed shaft which is 
powering the generator.

Step 2. Start Adams/View

a. Start Adams/View 2013.2.

b. Choose Existing Model and select windturbine_
start.cmd under exercise directory.

c. Click OK.

Step 3. Build First Stage Planetary 
Gear Set: Geometry

a. From Machinery ribbon, select Gear: Planetary 
Gear.

b. Click Next.
c. Select Simplified Method.
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g. Select module_stage_1 from the list. Similarly, select 
width_stage_1 for gear width.

h. Select 5 planet gears and 0 Helix Angle.

i. The number of teeth for sun gear, ring gear and planet 
gears are 35, 105, and 35. Leave the rest of the field as 
default. Click Next.

Step 4. Build First Stage 
Planetary Gear Set: Material

a. Select Geometry and Material Type for all the parts.

b. Leave the contact and friction settings as default and 
click Next.

Step 5. Build First Stage Planetary 
Gear Set: Connection

a. In this step, connections are built according to the 
topology described in Step 1.

b. For sun gear, select Rotational and right click in the 
field to select LSS.

c. For planet gear, select Rotational.
d. For ring gear, select Fixed and pick gear_box as well.

e. For carrier, select Fixed and pick LSS as the existing 
body.

f. Click Next and then Finish. It may take while 
for Adams to build the gear set depending on the 
configuration of your machine. Be patient. When 
the gears have been built, the dialog box will close 
automatically and the gears will show up like this.
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Step 6. Build Second Stage Planetary 
Gear Set: Geometry and Material

a. Follow the similar procedures as we build the first stage 
gear sets and navigate to Geometry page.

b. Follow the same steps to define center location, 
module and gear width. This time, change all 
references from “_stage_1” to “_stage_2”. Select 
appropriate design variables for module and gear width. 

c. Pick Global X as axis of rotation.

d. Enter 30, 132 and 51 for number of teeth of sun gear, 
ring gear and planet gear.

e. Set number of planet gears to three and Helix Angel to 
0. Leave the rest settings as default and click Next.

f. Pick Geometry and Material Type for mass definition 
for all parts. Click Next.

Step 7. Build Second Stage 
Planetary Gear Set: Connection

a. Make the sun gear rotate against gear_box, following 
similar steps in Step 5b.

b. Select Rotational for planet gear.

c. Fix ring gear to gear_box.

d. Fix the carrier to the sun gear of first stage gear set.

e. Click Next and then Finish. Wait patiently until the 
gear set is created.

Step 8. Build Final Stage Spur 
Gear Set: Geometry

a. From Machinery ribbon, select Gear: Create gear 
pair.

b. Select Spur as Gear Type. Click Next.
c. Select Simplified as Method. Click Next.
d. Right click next to Module and select Parameterize-

>Reference Design Variable. Pick module_spur 
from the list
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e. Pick Global X as Axis of Rotation.

f. Right click at Center Location under Gear 1 column 
and select Reference_Frame->Browse. Select ref_
spur_1_center from the Database Navigator.

g. Enter 90 for No. of Teeth.

h. Right click at Gear Width and go to Parameterize-
>Reference Design Variables. Pick width_spur.

i. Move to Gear 2 column. Replace the reference marker 
in Step 8h to ref_spur_2_center.

j. Enter 23 for No. of Teeth and use the same Gear 
Width. 

k. Leave the rest as default and click Next.

Step 9. Build Final Stage 
Spur Gear Set: Material

a. Define mass of gear 1 and gear 2 by Geometry and 
Material Type.

b. Click Next.

Step 10. Build Final Stage Spur 
Gear Set: Connection

a. Apparently, the driver gear should be fixed to the sun 
gear of second stage planetary gear set while the 
driven gear should be fixed to high speed shaft.
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b. Right click in Body and pick the sun gear.

c. Click Gear 2 tab and right click in Body and browse for 
HSS.

d. Click Next and then Finish. Wait for Adams to build 
the gear pair.

e. The completed gear train should look like the one in the 
figure.

Step 11. Build the Generator

a. There is no built-in generator module in Adams/
Machinery but with a few modifications, we can build a 
generator using the motor module.

b. From Machinery ribbon, select Motor: Create Motor.
c. Under Method, choose Curve Based.

d. Click Next and navigate to Motor Connections.

e. Choose CW (clockwise) as Direction. Right click at 
Location and then go to Reference_Frame->Browse. 
In Database Navigator, expand gear_box and pick 
hss_b.

f. Pick Global X as Axis of Rotation.

g. Fix rotor and stator to hss (high speed shaft) and gear_
box repectively. Click Next.

h. Set rotor length and diameter to 1.5 and 0.5. Make 
sure that your current Unit System is MKS. Set the 
stator length and width to 2.5 and 1.6.

i. The mass properties of rotor and stator are shown in 
the following table. Enter the values and click Next.

Rotor Stator

Mass (kg) 3100 50000

Ixx (kg*m^2) 100 400

Iyy (kg*m^2) 50 150

Izz (kg*m^2) 50 150

j. For Inputs, select Enter Spline File. Right click in the 
Spline File Name field and browse for torque_curve.
csv under start folder. Click Next and then Finish.

k. The complete gear train and generator will look like this.
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Step 12. Modify the Generator

a. Now the motor in the model will just work like a motor. 
Furthermore, the default unit system of angular velocity 
used by the motor is not necessarily consistent with 
that of our curve.

b. The first thing we do is cut the power supply to the 
motor.

c. From the menu, select Tools->Command Navigator.

d. Navigate to variable->modify and double click.

e. Right click in Variable Name and go to Variable-
>Browse. Expand windturbine_start, then motor_1. 
Select source_voltage.

f. The value is set to 12 by default. Enter 0 in our case. 
Click OK and close the Command Navigator.

g. From the model tree, expand Motors folder and double 

click var_omega and var_spline_torque.

h. Our torque curve builds up the relationship between 
generator speed and generator torque. Function 
AKISPL returns the value of the torque at certain 
speed based on spline fitting. In our curve, the unit of 
angular velocity is deg/sec, while in the default case, 
the value var_omega is in rad/sec. 60/(2*pi) converts 
rad/sec to rpm. So in our case, we rewrite the function 
of var_omega to rtod*wz(motor_1.mar_sfo_I,motor_1.
mar_sfo_J,motor_1.mar_sfo_J). “rtod” is a function that 
converts the parameter from radian to degree. We also 
delete “60/(2*pi)” modified in var_spline_Torque function.
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Step 13. Run Dynamic Simulation

a. Concentrated forces have already been added to the 
tip of the blades.

b. Run an interactive dynamic simulation with 2 seconds 
and 200 steps.

c. We can find that the power output of the generator 
exhibits a spike trend. This is because then the motor 
speed exceeds certain speed, we suppress the power 
output of the generator to protect the generator and 
grid from overloading. Normally, there is also a brake 
system to control the speed of the shaft which is not 
modelled in our example. 
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This section introduces you the benefits of Adams/MATLAB co-

simulation. There are many systems require control systems to 

function properly. MATLAB is popular among controls engineers 

while the insight of the dynamic systems Adams will provide is 

unrivaled. The capability to run co-simulation between these 

two enables engineers to develop better products. In this 

section level, you will learn:

• How to create inputs and outputs in Adams

• How to export Adams model for co-simulation

• How to setup MATALB/Simulink for co-simulation

• How to postprocess the co-simulation result

Section V: Adams/MATLAB Co-
simulation
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Software Version
Adams 2013.2 

Problem Description
• Build a simple DC motor connected to an output shaft in both 

MATLAB/Simulink and Adams/View
• Compare the results of two different simulation methods
• Note: copy all the files in the start file to working directory before you 

start.
• This example is created in collaboration with Prof. Frank Owen at 

California Polytechnic State University.

Example 34: DC Motor
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Step 2: Simulate the Model in Simulink

a. Run the file Motor_initialize.m to set necessary 
parameters for simulation. 

Step 1: Build the Model in Simulink

a. The schematic of a permanent magnet servo motor is 
shown below. 

b. Apply Kirchoff’s Voltage Law to the circuit, where vi is 

the input voltage, vL and vR are voltage across the 
inductor and resistor separately. vb is the back EMF 
proportional to the motor’s speed, i.e.,

c. Now, substitute this and write the expression for 
voltage drop in terms of armature current,

d. The torque output by the motor is proportional to the 
armature current,

e. The dynamics of the shaft is.

f. Now we have all the necessary equations to describe 
the system. Put the higher order derivatives on the left 
hand side.

g. Now, build the model in Simulink. Open motor_full.
slxThe part highlighted by red rectangle is the 
mechanical part which will later be replaced by an 
Adams subsystem.
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b. Simulate the model for 3 seconds.

c. The scopes should show the following curves. 

Step 3: Create New Model in Adams/View

a. Open Adams/View and select New Model.

b. Set Model Name as motor_shaft.

c. Click OK.

d. Change the model unit from millimeter to meter.

Step 4: Create the Shaft

a. From the Bodies ribbon, select Rigid Body: Cylinder.

b. Select New Part and check Length and Radius. Set 
them to 10cm and 1cm respectively.

c. Pick the origin as the first end and click anywhere on 
the x axis.

d. The shaft should be created as shown below.

e. Rename the part as shaft.

Step 5: Add Constraints

a. From the tool bar, select Settings->Working Grid

b. Change the orientation of the grid to YZ plane. This 
would help us to utilize the Normal to Grid feature when 
creating the revolute joint.

c. From Connectors ribbon, select Revolute Joint.

d. Leave the settings as default (2 Bod-1 Loc, Normal to 
Grid) and pick shaft first and then ground. Pick shaft.

MARKER_1 as the location.

e. The front view (shift + F) should be similar to the figure.

Step 6: Add Rotational Damping

a. From the Forces ribbon, select Rotational Spring-
Damper.

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   245  MSC Software   |   245

b. Set the construction method to 2 Bod-1 Loc and 
Normal to Grid.

c. Do not check KT as we do not need a spring here.

d. Check CT and set it to 0.0001 (N*m*s/rad).

e. Pick shaft first then ground and choose shaft.cm as 
the location

Step 7: Add Motor Torque

a. From the Forces ribbon, select Toque.

b. Set the Run-time Direction as Space Fixed.

c. Set Construction to Normal to Grid.

d. Pick shaft as the body and pick shaft.MARKER_1 as 
the action point.

Step 8: Create Measurement 
Reference Angle

a. First check the orientation of the shaft.cm. Notice how 
X, Y, Z axes are oriented. This is important for creating 
correct measurement.

b. From the Bodies ribbon, select Construction Geometry: 
Marker.

c. Select Add to Ground and for Orientation, select X-Axis, 
Y-Axis.

d. Select shaft.Marker_1 as the origin.

e. Move your mouse around and align it with Marker_1.X.

f. Similarly, select Marker_1.Y as Y-axis.

g. A new marker should be added to ground. In the model 
tree, expand Bodies->ground and rename the new 
marker as ang_ref.

Step 9: Create State Variables

a. State variables act as the parameters that Simulink and 
Adams exchange with each other. They work either as 
input or output to the Adams model. In our model, the 
input is the motor torque and the output is the angular 
displacement, angular velocity or any other type of 
physical quantities that are the result of the motor 
torque input.

b. From Elements ribbon, select System Elements: Create 
a State Variable.

Section V: Adams/MATLAB Co-simulation  |  Example 34: DC Motor



246   |   MSC Software

c. Set the variable name as motor_torque. Leave the 
rest settings as default. The value will be passed by 
Simulink once the simulation starts.

d. Create a new variable named theta. This time, type 
AZ(shaft.cm, ang_ref) in the function dialog box.

e. Create a new variable named omega. Type WZ(shaft.
cm, ang_ref, ang_ref) in the function dialog box. Note 
that detailed information about functions AZ and WZ 
can be found in Adams Help Document.

f. The latter two will be the output of the model.

Step 10: Modify Torque and Damping

a. Right click on SFORCE_1 and select Modify.

b. Right click in the Function box and select Function 
Builder.

c. Type -VARVAL(motor_torque). This expression builds a 
function that is equal to the value of the adams variable 
motor_torque during the runtime. Since motor_torque 
is later defined as an input controlled by Simulink, we 
are controlling the shaft with a torque that is input from 
Simulink model. Note that there is a minus sign here. It 
is not necessarily to add a minus sign at this stage. If 
it is found out in later simulation that the out data has 
opposite sign as expect, a minus sign can be added 

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   247  MSC Software   |   247

then..

d. Click OK.

e. Right click on TORSION_SPRING_1 and then select 
Modify. 

f. Under Stiffness and Damping, choose No Stiffness.

g. Click Ok.

Step 11: Load Adams/Controls Plugin

a. From the tool bar, select Tools->Plugin Manager.

b. Check Adams/Controls plugin.

Step 12: Export Plant

a. From the Plugins ribbon, select Controls: Plant Export.

b. Right click in the field of Input Signals, select Adams_

Variable->Browse.

c. From the Database Navigator, double click motor_

torque.

d. Similarly, choose omega and theta for Output Signals.

e. Choose MATLAB as Target Software.

f. Leave the rest fields as default.
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g. Click OK.

h. Now in the working directory, four new files can be 
found. They are Controls_Plant_1.adm, Controls_
Plant_1.m, aviewAS.cmd, Controls_Plant_1.cmd.

Step 13: Build Co-simulation Model

a. From the exercise file directory, copy Motor_initialize.m 
and post_processing_plot.m to the working directory. 

b. Start MATLAB and run Motor_initialize.m to initialize 
motor parameters.

c. Run Controls_Plant_1.m. You will see the following lines 
in the command window.

d. Type adams_sys in the command window and 
then press Entrer. This will bring a Simulink model 
containing an Adams subsystem. This may take a while.

e. Now, open motor_full.slx and replace the mechanical 
part with Adams subsystem copied from adam_sys. 
Don’t forget to copy and replace the scopes as well 
otherwise the post_processing_plot.m in later steps 
won’t work.

f. Double click on the scope omega. Click on the gear 
icon on the upper left corner to enter parameter setting 
of scope.

g. Click on History tab. Check Save data to workspace 
and name Variable name as omega. Repeat this step 
with theta scope with Variable name theta.

h. Save the model as motor_cosim.slx.

i. Run the simulation for 3 seconds.

j. The scopes show the following results.
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Step 14: Compare Simulation Results

a. Run post_processing_plot.m.

b. It is found that the two simulation results are identical.
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250   |   MSC Software

Software Version
Adams 2013.2 

Problem Description
In Adams/View section, we have successfully built a model of airplane 
control surface flap wing. In real world application, after the position 
command has been sent by the pilot, onboard computer will control 
the hydraulic system to actuate the flap wing to control the roll of the 
plane. In this example, we will simulate this event by Adams/Matlab 
Cosimulation.

Example 35: Airplane Control Surface
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b. Double click ia_driving_force.

c. Change Function from 1.4 to VARVAL(ia_force) and 
click OK. ia_driving_force is the force the motor 
applied to the drive eye that is connected with the flap 
wing. This function relates the force the value which is 
controlled by Simulink as an input to the Adams model.

d. Similarly, change oa_driving_force to VARVAL(oa_
force). 

Step 4. Export Control Plant

a. If Adams/Controls plugin has not been loaded already, 
go to Tools-> Plugin Manager and check Adams/
Controls.

b. From Plugins ribbon, click Controls->Plant Export.
c. Change the File Prefix to Control_Surface_Plant.

Step 1. Open Adams Model.

a. Start Adams/View 2013.2.

b. Select Existing Model and browse in the exercise 
directory for Control_Surface_cosim_start.cmd. 
You can also use the model you have built. If you are 
prompt to see if you would like to use the .mnf file copy 
in working directory to replace the .mnf file that can’t 
be found, click OK.

c. Click OK. Before you start, you can check the video in 
exercise directory to view the final result.

Step 2. Check Motions.

a. Make sure that the two joint motions are deactivated.

Step 3. Check State Variables.

a. We have created four state variables already. Among 
them, oa_force and ia_force will later be used as 
input from the Simulink model to Adams model and 
oa_postion and ia_position are the output from 
Adams model to Simulink controller.
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d. Right click in the Input Signals field, go to ADAMS_
Variable->Guesses->ia_force. Similarly, add oa_
force to the input as well.

e. Right click in the Output Signals field, go to ADAMS_
Variable->Guesses->ia_position. Similarly, add 
oa_position to the output as well.

f. Select MATLAB as Target Software.

g. Click OK.

h. In your working directory, you should find several files 

with Control_Surface_Plant prefix. 

Step 5. Build Simulink Model

a. Start MATLAB and open Simulink UI as well.

b. Change your MATLAB directory to your working 
directory.

c. Make sure that you have copied initialize.m, Control_
Surface_Cosim_start.slx from start file directory to 
your working directory.

d. Run initialize.m.

e. Run Control_Surface_Plant.m. You should see the 
following lines in Command Window.

f. Enter adams_sys in the command window. Another 
Simulink window will open with an Adams subsystem 
in it. 

g. Open Control_Surface_Cosim_start.slx.

h. Copy the subsystem from adams_sys.slx to Control_
Surface_Cosim_start.slx and connect the proper 
signals to complete the model.

Step 6. Run Simulation

a. Run the simulation for 1.5 seconds. After the simulation, 
you can double click each scope to check the 
simulation results. Better control can be achieved by 
fine tuning the PID gains or implementing other control 
strategy but they are beyond the scope of this tutorial.
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Step 7. Postprocessing the Simulation

a. The scopes in Simulink model won’t provide us with 
much insight of the mechanism. We can postprocess 
the result in Adams to get more understanding of the 
operation of the control surface.

b. In Adams/View, go to File->New Database, then 
select Existing Model. 

c. Browse in your working directory, find and pick 
Control_Surface_Plant.cmd. This file is generated 
when you export the control plant in Step 4. 

d. Press F8 to enter postprocessing window.

e. Go to File->Import->Results File.

f. Select Control_Surface_Plant.res in your working 
directory. This file is created after the simulation is 
finished. Right click in the field of Model Name and 
select Model->Guesses->Control_Surface. Click 
OK.

g. Select View->Load Animation. Now you can view the 
animation with the control buttons.

Step 8. View Stress Contour Plot

a. Return to Adams/View, select Plugins->Durability-
>Nodal Plots. If you haven’t loaded the Durability 
plugin, go to Tools->Plugin Manager and check 
Adams/Durability. Right click in Flexible Body field 
and select FLEX_BODY_1. Enter 2684 in Select 
Node List. This could be any node on the flexible 
body. Click OK.
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b. Now, switch back to postprocessing window. Click 
Contour Plots tab and select Von Mises Stress 
as Contour Plot Type. Now the contour plot in the 
animation shows the stress distribution in the flexible 

body.

c. As we deactivated the external load on the wings, the 
stress distribution doesn’t show dramatic distinctions 
at different spots. We can change the Minimum and 
Maximum value of the legend to show more distribution 
of stress. Change Minimum Value and Maximum Value 
to 1 and 7e6 respectively. Change the frame to 24. 
Then we can get to know the distribution of stresses 

more clearly.

d. Go to View->Page->New and create a new page. 
Right click in the window and select Load Plot. 
Select FLEX_BODY_STRESS Result Set and pick 
node_2684_VON_MISES Component. Then click 
Add Curves. Now the time history of the stress at a 

specific node can be studied.
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Software Version
Adams 2013.2 

Problem Description
Bridge Crane is a commonly seen machinery in warehouses, ports 
and factories. A major problem that engineers are concerned with is 
the swing of the cargo when the trolley accelerates and decelerates. 
Usually, controllers are integrated into bridge crane system to reduce 
the sway angle of the load. In this example, a bridge crane system will 
be modeled using the Cable Module of Adams/Machinery, and then be 
incorporated into a MATLAB/Simulink model. Before you start, copy all 
the files in example start folder to your working directory.

This example is created in collaboration with Prof. Frank Owen at 
California Polytechnic State University and Michele Ermidoro at 
Università degli studi di Bergamo.

Example 36: Bridge Crane
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c. At the first page, Name the pulley “trolley_pulley”.

d. Enter “ (LOC_RELATIVE_TO({0.0, 0.0, 0.0}, 
MARKER_5))” at location.

e. Turn off Flip Direction.

f. Enter 200 as Diameter.
g. Right click in Pulley Property and go to cable_pully_

props->Guesses->.BridgeCrane_SimpleCable.
Cable_Sys_1.pulley1. 

h. Click on Connection tab. Select Revolute 
Connection Type. Right click at Connection Part and 
go to PART->Guesses->Part 2.

i. Click on Pulley page 2.

j. Name the pulley load_pulley.

k. Enter (LOC_RELATIVE_TO({0.0, 0.0, 0.0}, 
MARKER_6)) at Location. Leave the rest the same as 
trolley_pulley and click on Connection tab.

l. Select Revolute Connection Type. Right click at 
Connection Part and go to PART->Guesses->Part 3. 
Click Next.

Step 5. Define Cable

a. Name the cable “cable1”.

b. Enter “trolley_pulley, load_pulley” as Wrapping 
Order. You can also specify this order by right click 
and select them from Guesses list.

c. Enter 16 at Diameter. Click on Parameters tab.

Step 1. Start Adams/View 2013.2

a. Start Adams/View 2013.2.

b. Select Existing Model and browse in the example 
start folder for BridgeCrane_start.cmd.

Step 2. Build Cable System

a. From Machinery ribbon, click Cable: Create Cable.

b. At Anchor Layout page, change the Number of 
Anchors to 0. In our case, the cable is closed so we 
don’t need to define any anchors.

c. Click Next.

Step 3. Define Pulley Properties

a. In this page, the shape and contact properties of 
pulleys are defined. You can define multiple pulley 
properties which you can select in later steps.

b. Enter pulley1 as Pulley Property Name. And then enter 
the dimensions according to the table below.

Width 50

Depth 10

Radius 10

Angle 20

c. The definition of each dimension can be found in 
Adams Help.

d. Keep the contact parameters as default and click Next.

Step 4. Define Pulley Layout

a. Enter 2 in Number of Pulleys. There will be one pulley 
at the trolley and one pulley at the load.

b. Select Global Z as Axis of Rotation.
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d. Enter 1.2182e-5 in Density and 852.6 in Preload. 
Leave the rest as default. It is important to get the 
preload correct so that the model can run through 
equilibrium phase.

e. Click on Output tab. Enter 1 for both Pulley Results 
and Span Results. This means that we are getting 
the result of the first pulley and the first span. Specific 
details of the results that can be obtained in cable 
module can be found in Adams Help.

f. Click Next and then Finish. The finished system should 
look like the one below.

Step 6. Create State Variables

a. To set up the model for co-simulation, input and output 
variables should be created. In this model, the input is 
the translational motion of the trolley. The output of the 
model is the sway angle of the load. 

b. From Elements ribbon, select System Elements: 
Create a State Variable.
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c. Change Name to Input_Vel. Leave the Function as 0 
because this will be replaced by MATLAB input during 
simulation. Click Apply.

d. While the Create State Variable window is still open, 
change the name to Sway_Angle.

e. At function, enter PSI(cm_ref, MARKER_5). The 
function PSI measures the first rotation of the body 313 
system. Cm_ref is called To Marker which is the marker 
being measured and MARKER_5 is called From Marker 
whose body 313 system is referenced. More detailed 
information can be found in Adams Help. Click OK.

Step 7. Create Translational Motion

a. Now we need to add a joint motion to the translational 
joint between the trolley and the ground. This motion 
drives the trolley forward.

b. From Motions ribbon, select Translational Joint 
Motion.

c. Click on Joint 24.

d. From the model tree, right click on Motion_1.

e. At Function, enter VARVAL(Input_Vel). This means 
that the translational speed of the motion is determined 
by the value of the variable Input_Vel.

f. Change Type to Velocity.

g. Click OK.

Step 8. Export Control Plant

a. If you haven’t loaded Adams/Controls plugin, go 
to Tools->Plugin Manager and then check Adams/
Controls.

b. From Plugins ribbon, select Controls: Plant Export.
c. Enter Bridge_Crane_plant in File Prefix.

d. Check No for Initial Static Analysis.

e. Enter Input_Vel and Sway_Angle at Input Signals 
and Output Signals respectively.
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f. Select MATLAB as Target Software, non_linear 
Analysis Type and C++ solver.

g. Click OK. There should be four files with the defined 
prefix generated in your working directory.

Step 9. Build Simulink Model

a. Start MATLAB. 

b. Change the directory to your working directory.

c. Run Bridge_Crane_plant.m.

d. Enter adams_sys in the command window. A Simulink 
model with adams_sub subsystem is created.

e. Open model_start.slx.

f. Copy the adams_sub subsystem and paste it in model_
start.slx. Connect the appropriate signals.

Step 10. Run a Baseline Simulation

a. Double click on the PID controller block.

b. Change all PID controller parameters to 0.

c. Make sure that Record & Inspect Simulation Output is 
on.

d. Run the simulation for 5 seconds..

Step 11. Run Simulation with Controller

a. Double click on PID block again.

b. Change the proportional gain, integral gain and 
derivative gain to -100, -10, -10 respectively.

c. Run the simulation for 5 seconds.

Step 12. Compare Simulation Result

a. Open Simulation Data Inspector.

b. Check Inspect Signals of Run1 and Run2.
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c. On the right hand side a plot of these two runs is 
shown. It can be found that the sway angle of the load 
has been reduced significantly after a PID controller is 
implemented. 

Step 13. Postprocessing in Adams/View

a. In the Adams model in Simulink, only the sway angle of 
the load is explicitly exported. When the simulation is 
finished, we can also study other simulation results in 
Adams Postprocessor.

b. Start Adams/Postprocessor.
c. Go to File->Import->Results File and browse in 

your working directory for the .res file generated after 
simulation.

d. Click OK.

Step 14. Plot Results of Interest

a. From the Result Set column, expand Cable_Sys_1 
and then trolley_pulley. Highlight pulley_XFORM.

b. Select X Component from the right column and click 
on Add Curves. 

c. A plot showing the horizontal motion of the trolley 
pulley, i.e. the trolley will be plotted.
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Software Version
Adams/Car 2013.2 

Problem Description
This a quick example to show the workflow of Adams/Car and 
MATLAB/Simulink cosimulaiton. A vehicle is subjected to a split-mu 
brake test (the friction significantly differs between the left and the right 
wheel path). An ABS controller is designed in Simulink. A cosimulaiton 
is performed to verify the controller. Note: you may need to finish 
Example 39 first before you proceed. You should copy all the files 
under exercise start folder to your working directory. Since Adams/Car 
and MATLAB can have their working directory set up separately, it is 
advised to select a common folder as your single working directory.

Example 38: Vehicle ABS System
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f. Select locked for Steering Input.
g. Enter 70 km/h in Initial Velocity.

h. Set the rest of the parameters as shown in the figure. 
Uncheck Quasi-Static Straight-Line Setup.

i. Click OK.

Step 3. Check the Files

a. After step 2, you should be able to find a bunch of files 
under your working directory.

b. Notice that we have a .m file generated but we will 
replace this file using Adams/Controls plant export.

Step 4. Export the Plant

a. Make sure you have loaded the Controls plugin. If 
not, go to Tools->Plugin Manager, check Adams/
Controls and click OK.

b. Go to Controls->Plant Export.
c. Select New Controls Plant.

Step 1. Open the Full-Vehicle Assembly

a. Start Adams/Car 2013.2.

b. If you are prompted to select user interface, select 
Standard Interface.

c. From the menu bar, select File->Open->Assembly.

d. Right click in the field and select TR_ABS.asy from 
ABS_2013 database. If the database has not been 
added to session already, please refer to step 2 in 
example 39 to add the database to session.

e. The vehicle assembly should be like the one shown 
here.

f. Go to Tools->Plugin Manager. Check Load Adams/
Controls.

Step 2. Run a Files_Only Simulation

a. Select Simulate->Full-Vehicle Analysis->Straight-
Line Events->Braking.

b. Enter abs in Output Prefix.

c. Enter 4 and 400 in End Time and Number of Steps 
respectively.

d. Select files_only for Simulaiton Mode.

e. Right click in the Road Data File field and go to search. 
Pick ABS_2013.tbl and select 3d_road_smooth_
flat_splitmu05.xml.
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d. Enter abs_brake in File Prefix. You should enter the 
same name as that in step 3. In this way, the .m file 
generated in this step will replace the .m file from the 
last step.

e. Select No for Initial Static Analysis.

f. Right click in the blank field on the left and select 
ADAMS_Variable->Browse.

g. Expand brake_4WABS. Hold ctrl and highlight four 
ABS input variables. These are the values that will 
be passed into Adams by Simulink. In this example, 
the necessary input variables has been created for 
you. When you are building your own model for other 
applications, you should create them using state 
variables before you export the plant.

h. Click OK.

i. Similarly, right click in the blank field on the right and 
select four brake velocities.

j. Select MATLAB as Target Software and leave the rest 
as default.  

k. If you check the working directory, you should find that 
abs_brake.m has been replaced (new modification 
date).

Step 5. Build Simulink Model

a. Start MATLAB/Simulink. Copy all the files under 
exercise start folder to your MATLAB working directory.

b. Run abs_brake.m by dragging it from the current 
folder window to command window. This sets up the 
cosimulation and builds up required inputs and outputs 
as is shown in the command window.

c. Run abs_setup.m. This sets up the necessary 
parameters for abs controller and opens abs_
controller.mdl.

d. Enter adams_sys in the command window. This will 
create an adams subsystem in Simulink which uses the 
inputs and outputs in step 5b. Note that this .m file can 
be used to initiate any cosimulation.

e. Replace the subsystem adams_sub in abs_controller.
mdl with the one in adams_sys. You can click on 
adams_sub in adams_sys and press Ctrl+ C to copy 
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it and press Ctrl+V to paste it in abs_controller.mdl. 
Observe the signal connection before you delete 
the original adams_sub block in abs_controller.mdl. 
Connect the corresponding signals.

f. Now the cosimulation has been setup and we can run 
the simulation.

Step 6. Run Cosimulation

a. Run the Simulink model for 4 seconds. At each 
communication interval, inputs (brake signals) from 
Simulink is fed into Adams/Solver while the wheel 
velocities are fed into Simulink. They exchange these 
information at every simulation step to finish the 
cosimulation.

b. After the simulation, you will find that several new 
files have been generated, including abs_brake.res. 
This is the Adams result file that can be imported for 
postprocessing.

Step 7. View the Animation

a. Make sure that your assembly TR_ABS is open.

b. Go to Review->Analysis Management->Read.

c. Check Results file and right click in Analysis Name. 
Select Browse and look for abs_brake.res in your 
working directory. Then click OK.

d. Go to Review->Animation Controls.

e. Play the animation and it can be found that the vehicle 
maintains straight path on the split mu road very well

Step 8. Run a Baseline Simulation

a. Now we will run a baseline simulation without abs 
controller.

b. Create another braking simulation using the same 
set of settings. Note that Simulation Mode should be 
interactive this time.

c. Go to Review->Animation Controls.

d. Play the animation and you will find that the vehicle 
spun at the end of simulation.
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Step 9. Compare the results 

a. Press F8 to open postprocessing window.

b. Press Ctrl and highlight both simulations.

c. Browse for body_yaw_rate under testrig and select 
component Q.

d. Click Add Curves. Judging from the plot, the effect 
of ABS controller is rather significant. The yaw rate is 
controlled about zero very well while the vehicle without 
ABS spins off. In the completed folder of this example, 
you can find a video showing the comparison of these 
two simulations.
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Software Version
Adams 2013.2 

Problem Description
In Adams/Machinery Section, we have built a Windshield Wiper 
Mechanism using motor and gear module. In this example, we will built 
a basic UI in MATLAB/Simulink so that we can control the speed of the 
windshield wiper continuously while the simulation is running. Before 
you start, copy all the files in the exercise start folder to your working 
directory.

Example 37: Windshield Wiper Mechanism
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f. Pick No for Initial Static Analysis.

g. Right click in the field of Input Signals and select 
Adams_Variable->Guesses->var.motor_torque. 

h. Right click in the Output Signal field and select 
Adams_Variable->Browse. In the Database 
Navigator, expand motor_1 and select var_angacc, 
var angdisp and var_omega.

i. Select MATLAB as Target Software. Click Next and 
then Finish. 

j. Now, if you check your working directory, you will find 
that several new files with Wiper_Plant prefix has been 
created.

Step 3. Build Simulink Model

a. Start MATLAB and open Simulink UI.

b. Run Motor_initialize.m. This file sets up several 
parameters of the motor.

c. Run Wiper_Plant.m. This file sets up the simulation 
environment and creates necessary inputs and outputs 
for Adams Subsystem.

d. Enter adams_sys.m in the command window. A 
Simulink UI will be brought about and an adams_sub 
block is contained in this Simulink model.

Step 1. Start Adams/View

a. Start Adams/View 2013.2.

b. Select Existing Model and browse for Windshield_
Wiper_cosim_start.cmd in your exercise start folder.

c. Click OK.

d. It may take a while for Adams/View to import the model 
because the model contains worm gear and motor.

Step 2. Export Control Plant

a. Make sure that the Adams/Controls Plugin has been 
loaded. If not, go to Tools->Plugin Manager and 
then check Adams/Controls.

b. From the model tree, double click on Motors-
>motor_1 to modify the motor. The motor is currently 
built as an analytical motor which calculates its torque 
output by built-in formulas. We will replace it with an 
external one which receives its torque command from 
MATLAB. Click Next until Inputs Page.

c. Select Co-Simulation as External Method.

d. From the drop down menu of Plant Input/Output, 
pick User Defined.

e. Enter Wiper_Plant at File Prefix.
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e. Open wiper_control.slx. When the model is opened, 
you will notice that there is a block missing.

f. Copy the adams_sub block from adams_sys_.slx 
and paste it into wiper_control.slx. Connect matching 
signals. The completed model will look like the one 

below. 

g. Run wiper_control_ui.m. This file will create a UI with 
a slider bar. With this slider bar, you can adjust the 

speed of the wiper any time during the simulation. 

Step 4. Run the Co-simulation

a. Set a 50 seconds stop time for the Simulink model.

b. Run the simulation.

c. While the simulation starts, from the drop down menu 
in our control UI, select Continuous. 

d. Now the wiper starts to move. You can double click on 
the scope of var_omega to see the change in speed. 

e. Move the slider bar left and right to see the motor 
speed changes simultaneously. Note that you may 
want to stay at certain speed for 2-3 seconds just to 
see the change in the magnitude of the curve. 

Step 5. Postprocessing the Simulation.

a. If you have closed the Adams/View window before 
simulation, open Adams/View 2013.2 and select 
Existing Model. If not, go to File->New Database-
>Existing Model. Browse in your working directory for 
Wiper_Plant.cmd. It may take a while for the .cmd file to 
load. If you are warned that the worm and worm wheel 
are not inplane, just click OK.

b. When the model is loaded, press F8 to enter 
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postprocessing window.

c. Go to File->Import->Results File. 

d. Right click in File Name and browse for Wiper_Plant.
res in your working directory.

e. Right click in Model Name and select Model-
>Guesses->Windshield_Wiper. 

f. Click OK.

g. Right click in the page and select Load Animation. 

h. Click the play button and you can review the animation 
of the co-simulation we just performed.

i. You can also plot curves like we did in Example 32
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Adams/Car is one of the most popular dynamic simulation 

package for vehicle dynamics. Adams/Car provides template 

based strategy for vehicle design with seamless flexible 

body integration and co-simulation capability. The simulation 

result can also be used for durability analysis and all kinds of 

postprocessing.In this section level, you will learn:

• How to load Adams/Car database

• How to run full-vehicle simulation

• How to incorporate flexible body into full-vehicle simulation

• How to postprocess the full-vehicle simulation result

Section VI: Vehicle Dynamics
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Software Version
Adams/Car 2013.2 

Problem Description
Use the Formula SAE template to learn the basic full-vehicle simualtion 
work flow of Adams/Car

Example 39: FSAE Full Vehicle Simulation 
Events
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b. In the Assembly Name field, right click and select 
Search->fsae_2012/assemblies.tbl.

c. From the database, select fsae_full_vehicle.asy.

d. Click Open and then OK.

e. You may get error messages when the assembly 
is opened. It is not a problem because the 
message simply tells you that there is unassigned 
communicators. Subsystems talk to each other through 
communicators. Unassigned communicators means 
that they are not able to find the input/output. 

f. Close the message window and take your time to have 
a look at the assembly. You can use shift + S to switch 
between different rendering modes. 

Step 4. Run a Full-vehicle Simulation.

a. From the toolbar click Simulate->Full-vehicle Analysis-
>Straigh-Line Events->Acceleration. Acceleration event 
is one of the most basic simulations in Adams/Car. Use 
this simulation to check if your full-vehicle assembly is 

Step 1. Start Adams/Car.

a. Start Adams/Car 2013.2.

b. If you are prompted to select user interface, select 
Standard Interface.

Step 2. Add FSAE Database to Adams/Car.

a. From the toolbar, select Tools->Database Management-
>Add to Session.

b. Make sure that the Database Alias is set to fsae_2012  
and then select the Database Path as the path where 
the .cdb folder is located.

c. Click OK.

Step 3. Open Full Vehicle Assembly 
from the FSAE Database.

a. From the toolbar, select File->Open->Assembly.
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working fine and then proceed to more complicated 
tasks.

b. Before you start your simulation, go to File->Select 
Directory. Make sure that the working directory where 
the simulation data are stored is your desired one.

c. Now you can setup the acceleration simulation.

d. Set the output prefix as “Straight”. This will be added to 
all the files that the simulation creats.

e. Set the end time to 10 seconds and increase the steps 
to 1000.

f. Continue to set the rest of the parameters as shown. 
Note that when you are not sure what a particular 
parameter does, simply hover your mouse over the 
field and Adams will give you a hint. If no hint appears, 
click in the field and when the cursor in the current field, 
press F1.

g. Click OK.

Step 5. Review Simulation Result.

a. From the toolbar, click Review->Animation Controls.

b. You can now review the animation. 

c. From the toolbar, click Review->Postprocessing 
Window.

d. In the postprocessing window, choose data source as 
Requests.

e. Under Filter, pick user defined.

f. Under Request, pick chassis_accelerations.

g. Under Component, pick longitudinal.

h. Click Add Curves.

i. You can review other simulation results.
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Software Version
Adams 2013.2 

Problem Description
In this example, we will replace the upright of a Formula SAE race car 
with a flexible body generated in ViewFlex. After the swap, a braking 
event will be run and we will find the spot where the stress is maximum 
during the simulation event.

Example 40: FSAE Flex Body Tutorial
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of the attachment points as joints in order for ViewFlex 
to generate an .MNF file.

b. Select Settings->Working Grid. Set the orientation to 
Global XZ plane.

c. Create fixed joints between upright and ground at the 
following locations:

X Y Z

0 0 0

0 0 115

0 0 -115

85 0 -72.6
Note that after you have selected upright and ground, 
right click in the background to invoke location event 

Step 1. Start Adams/View.

a. Start Adams/View 2013.2.

b. Select New Model, and name the model as flexible_
upright.

c. Select a path of your choice for working directory.

Step 2. Import Parasolid Model.

a. From the toolbar, select File->Import.
b. Select Parasolid as File Type.

c. Browse to pick upright.x_t located in the start folder 
of this example.

d. Right click in the model name field and pick flexible_
upright.

e. Click OK.

f. Rename PART_2 as Upright.

Step 3. Create the Flexible Body Mesh.

a. The first step of creating a flexible body is to create all 
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and type the coordinates. The joints must be created in 
the same order as the table.

d. Right click on upright and select Part: upright->Make 
Flexible.

e. Select Create New.

f. Change the material to aluminum by right clicking 
the box and selecting Materials -> Guesses -> 
Aluminum.

g. Check Stress Analysis. If this is left unchecked, 
we will not be able to get the stress contour in 
postprocessor.

h. Check Advanced Settings to show the full 
parameters.

i. Select FlexBody Type as Geometry.

j. Pick Solid Element Type, and change Element 
Specification to Size, then set 5mm and 1mm for 
Element Size and Minimum Size respectively.

k. Pick Quadratic Element Order.
l. Use Mixed Edge Shape and turn on Curvature 

Based Scaling.

m. Click Mesh preview. A message window will show the 
number of nodes and elements.

n. Close the message window and select Attachments.

Step 4. Define Flex Body Attachments.

a. Click Find Attachments. 

b. For Coordinate Reference 1 (MARKER_2): pick 
Select Type: Closest Nodes, pick Attachment 
Method: Compliant (RBE3), set Number of Nodes to 
40 and then click Transfer IDs.

c. For Coordinate Reference 2 (MARKER_4): pick 
Select Type: Cylindrical, pick Attachment Method: 
Rigid (RBE2), set Radius to 5, set End Location to 0, 
0, 90, select Symmetric, and then click Transfer IDs.

d. For Coordinate Reference 3 (MARKER_6): Use the 
same settings as Coordinate Reference 2 except for 
using 0, 0, -90 as End Location.

e. For Coordinate Reference 4 (MARKER_8): Use the 
same settings as Coordinate Reference 2 except for 
using 96.26, 0, -74.93 as End Location.
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f. Select Flexbody preview to make sure everything 
looks as expected.  

g. When the upright show up like this, you can close the 
message window and click OK. The creation may 
take some time depending on the configuration of your 
machine.

h. Check your working directory and you will find a file 
named upright_0.mnf has been created.

Step 5. Copy mnf file.

a. Since we need mnf file for both left and right side, we 
need two mnf file. In our case, as the upright itself is 
symmetric about its own midplane, we can simply use 
the same mnf file.

b. Copy and paste upright _0.mnf in the same directory 
and rename it to upright_0_2.mnf.

Step 6. Start Adams/Car.

a. Start Adams/Car and select standard interface.

b. Set the FSAE database as your default writable 

database by selecting Tools -> Database 
Management -> Select Default Writable and select 
the fsae_2012 database.

c. Copy and paste the templates _fsae_frontsusp_flex.
tpl and _fsae_frontsusp_noflex.tpl to the templates.
tbl folder in the FSAE database. Copy and paste the 
subsystems fsae_front_susp_flex.sub and fsae_front_
susp_noflex.sub to the subsystems.tbl folder in the 
FSAE database. These files have been created to 
adapt the FSAE front suspension to accommodate the 
upright design. They are located in the example start 
folder.

Step 7. Use the MNF File.

a. From the toolbar, select File->Open->Subsystem. 
Browse to fsae_2012 database and pick fsae_front_

susp_flex.sub.

b. From the model tree, expand Parts->General Parts 
and right click on gel_upright and then select Make 
Flexible.
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c. Select Import MNF.

d. Right click in Current Part field and select gel_
upright. 

e. Right click in MNF File field and browse for upright_0.
mnf.

f. Click Launch Precision Move Panel.
g. Enter -500, -700, 150 for C1, C2 and C3 to bring the 

upright to position.

h. Click OK.

i. Now do the same for the right upright but using the 
upright_0_2.mnf file and making C2=700.

j. Save the subsystem with a minor role: front. 

Step 8. Create New Full-Vehicle Assembly.

a. Select File -> New -> Full-Vehicle Assembly and 
create the following assemblies.

Step 9. Run Full_Vehicle Simulations.

a. We will now look at the effect of flexible uprights on a 
harsh braking event.

b. Select Simulate -> Full-Vehicle Analysis -> 
Straight-Line Events -> Braking and run the two 
events shown below:
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Step 10. View Hot Spots Table.

a. Switch to the Post-Processor by pressing F8.

b. If you haven’t loaded Durability Plugin, go to Tools-
>Plugin Manager and then check Adams/Durability.

c. Go to Durability->Hot Spots Table. Hot Spots Table 
enables us to investigate the nodes where the stresses 
are maximum.

d. Right click at Flex Body and then go to Flex_Body-
>Guesses->gel_upright_flex.

e. Right click at Analysis and select flex_brake.Set 
Type to Von Mises Stress.

f. Leave the rest as default and click Report.

g. The top 10 hot spots are summarized in a table. The 
node having the maximum stress is node No. 19089.

h. Click Close.

Step 11. View Stress Contour 
during Simulation

a. Right click at plotting page and select Load 
Animation.

b. From the Database Navigator, double click flex_brake.

c. Click on Contour Plots tab. Change Contour Plot 
Type from Deformation to Von Mises Stress.

d. Click on Camera tab.

e. Right click at Follow Object and go to Flexible_
Body->gel_upright_flex.

f. Click on Hot Spots tab and check Display Hotspots, 
Rank, Value and Node ID. This will display the 
maximum stress point in the animation with its value 
and node ID beside it.

g. Now switch back to Adams/Car window and right 
click at the left front wheel. In Appearance settings, 
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change the Transparency to 80.

h. Switch to postprocessor and press Shift + I to enter 
ISO view. Press W and drag the mouse to enlarge the 
left front wheel assembly.

i. Your window should be similar to the figure below.

Step 12. Plot the Time History

a. It is helpful to know the moment when the stress at the 
hot spot is at its maximum.

b. Go to Durability->Nodal Plot.
c. Right click at Flexible Body and go to Flexible_

Body->Guesses->gel_upright_flex.

d. Enter 19089 at select Node List. This is the No.1 hot 
spot.

e. Click OK.

f. Create a new page.

g. Make sure the Source is set to Result Sets. Enter 
*flex* at the Filter.

h. Double click fsae_front_susp_flex on the right and 
highlight gel_upright_flex_stress.

i. Highlight node_19089_Von_MISES and click Add 
Curves.

j. There is a sharp increase of stress at the initiation of 

brake action.
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Software Version
Adams/Car 2013.2 

Problem Description
Use Adams/Insight to arrange suspension hard points in order to 
achieve desired roll center height. Note: you should have finished the 
first example in this section to proceed.

Example 41: Adams/Insight Example
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Step 3. Run a Trial Parallel 
Travel Suspension Analysis.

a. From the toolbar, select Simulate->Suspension 
Analysis->Parallel Travel.

b. Set up a simulation with zero bump and rebound travel 
with 1step. This helps us to know if the suspension is 
at design postion.

Step 1. Start Adams/Car.

a. Start Adams/Car 2013.2.

b. If you are prompted to select user interface, select 
Standard Interface.

Step 2. Open Front Suspension 
Assembly from the FSAE Database.

a. From the toolbar, select File->Open->Assembly.

b. In the Assembly Name field, right click and select 
Search->fsae_2012/assemblies.tbl.

c. From the database, select fsae_front_suspension.
asy 
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Step 4. Create a Design Objective.

a. From the toolbar, select Simulate -> DOE Interface 
-> Design Objective -> New.

b. Change the name from OBJECTIVE_1 to front_RC_
height. Right click in the field of Result Set Comp. and 
then browse for roll_center_location/vertical.

c. Change “Design Objective’s value is the” to value at 
simulation end.

Step 4. Export the Simulation 
to Adams/Insight.

a. Click Simulate -> DOE Interface -> Adams/Insight 
-> Export.

b. Change Experiment name to front_roll_center_
height.

c. Change Simulation Script to simulation_script.
d. Click OK.

e. Now Adams/Car will close and Adams/Insight will open 
with a new experiment called front_roll_center_height.

Step 5. Promote Hardpoints 
to Factor Inclusions.

a. Expand the model tree to locate the candidates: hpl_
uca_front/rear.z, hpr_uca_front/rear.z.

b. After selecting each one, press the promote button:
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c. The final model tree will look like this.

d. Highlight all of the points and press the tie button.

e. Highlight Tie_01 and change the settings as follows. 
Keep the original nominal value and set the range 

(settings) to -100,100. Pick Relative Percent as Delta 
Type. Click Apply.

Step 6. Promote RC Height 
to Response Inclusions.

a. Locate front_RC_height in the model tree.

b. Promote it the same way as previous step.

c. Change the Abbreviation to front_RC_height. And then 
click Apply.

Step 7. Set Design Specification.

a. Click Set Design Specification.

b. Under Investigation Strategy, pick Sweep.

c. Under Model, pick Cubic.

d. Under Run Order, pick Standard.

e. Use 25 steps.

f. Click Apply.

Step 8. Generate Workspace and Run.

a. Click Generate Workspace.
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b. Run the design study.

c. Now we switch to Adams/Car again and as the 
simulation running, you can observe the inboard 
hardpoints of upper control arms changing with each 

iteration.

Step 9. View DOE Results.

a. Go to Simulate->DOE Interface->Adams/Insight-
>Display.

b. Fill in front_roll_center_height.
c. Highlight Work Space and notice that the column of 

front_RC_height has been filled.

Step 10. Fit and Optimize Results.

a. Click Fit Results.

b. Click Optimize.

c. Under Design Objectives, change Oper to Equal.

d. Keep Target as 0.

e. Click Run.

f. In Design Variables window, notice that column Value 
has changed to 271.61. Step 10c to Step 10e is an 
iteration that asks Adams/Insight to interpolate the DOE 

result and find the height of UCA inboard hardpoints 
that will give us a roll center height of 0.

g. Keep changing the value of Target and record how the 
value of hardpoint height changes. You should get the 
following results.

Roll Center Height: UCA_Inboard_Height:

0 271.61

25 248.5

50 224.49

75 199.5

100 173.5

125 146.44
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150 118.28

175 89.018

200 58.643

225 27.19

h. Notice that these values are the result of fitting the 
DOE result. As the problem gets more non-linear, the 
interpolated result is not necessarily exact.
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Software Version
Adams/Car 2013.2 

Problem Description
Find the load history on the front subframe of a Humvee cruising 
across a rough road.

Example 42: Humvee Durability Analysis
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b. Right click in the field and search from the database 
added in previous steps.

c. Select Humvee_Rigid.asy.

d. Click Open and then click OK.

Step 3. Replace Subframe 
with a Flexible Part.

a. Right click on the subframe and select Make flexible.

b. Then choose Import MNF.

c. Right click to search the database and select the MNF 
file- HV_demo_subframe_front.mnf

d. Click Align Flex Body CM with CM of Current Part. 
e. The flex body is now aligned with the subframe.

Step 1. Add Database to Session.

a. Start Adams/Car 2013.2.

b. Choose Standard user interface.

c. From the tool bar, click Tools->Database 
Management->Add to Session.

d. Type Humvee_Workshop as Database Alias and 
choose the location of .cdb folder as the Database 
Path.

Step 2. Open Assembly.

a. From the tool bar, click File->Open->Assembly.
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f. Select Connections tab.

g. It is found that the connection has already been done 
in Adams.

h. Click OK.

Step 4. Configure Solver Settings

a. From the tool bar, click Settings->Solver.
b. From Category, select Dynamics and choose HHT 

as Integrator. Leave the rest of the settings as default.

c. From Category, select Equilibrium and reduce 

Tlimit and Alimit to 10 and 5 respectively. This would 
help to find equilibrium but may take more iterations. 
So change the MAXIT to 500 as well.

d. Click Close.

Step 5. Run an Adams/SmartDriver Event.

a. From the tool bar, click Simulate->Full-Vehicle 
Analysis->Adams/SmartDriver.
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b. Set the End time to 9 and output 9000 steps.

c. Then choose 3D spline for course type. For the road 
data file, search from the current database and select 
Belgian_block_extended_2.crg 

d. Use 25 km/hr as initial velocity and choose 2nd 
gear.

e. Uncheck Quasi-Static Straight-Line Setup.

f. Click OK.

Step 6. Export.DAC File.

a. From the tool bar, click Tools->Plugin Manager, then 
check Adams/Durability. Click OK.

b. From the tool bar, click Durability->FE-Fatigue-
>Export.

c. Choose the flex body in the assembly.

d. a. Uncheck FES file, then click OK.
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e. Now in your working directory, you should be able to 
find a list of .dac files.

f. Now the files are ready for fatigue analysis.
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Software Version
Adams 2013.2 

Problem Description
In previous examples, we have studied Formula SAE race cars using 
Adams/Car. Another popular racing competition among students 
is the Baja SAE Series. Unlike Formula SAE, Baja race cars run on 
rough roads and hill climbs. Thus, Baja teams are faced with different 
problems. In this example, we will show how to use Adams to create 
flexible bodies and incorporate them in the simulation. This tutorial is 
intended for intermediate to advanced Adams user. Please finish basic 
examples of Adams/View and Adams/Car before you proceed.

Example 43: Mini Baja Example
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b. Select Create New.

c. Make sure the material is set as steel and then check 
Stress Analysis and Advanced Settings.

d. Make the following setups.

Element Type Solid

Element Shape Tetrahedral

Element Order Quadratic

Element Specification Size

Edge Shape Straight

Element Size 2

Minimum Size 1

e. Click on Mesh Preview. It can take a while depending 
on the configuration of your machine.

Step 4. Create Flexible 
Body-Attachements

a. When the mesh is generated, click on Attachments.

b. Click on Find Attachments. 

c. Adams will automatically find the attachment points we 
defined previously.

d. Click on Coordinate Reference 1. 

e. Change Selection Type to Spherical.

Step 1. Start Adams/View 2013.2

a. Start Adams/View 2013.2.

b. Select Existing Model and browse for UCA_Flex_start.
cmd.

c. Click OK.

d. Expand the model tree to locate the ground points.

Step 2. Create Fixed Joints

a. We now need to create all of the attachment points as 
joints in order for ViewFlex to generate an MNF file.

b. From Connectors ribbon, select Joints: Fixed.

c. Click on uca and then ground. Click on Point_3 to set 
the location.

d. Create fixed joints at Point_4 following the same 
procedure. 

Step 3. Create Flexible Body-Meshing

a. Right click on part: uca and select Make Flexible. 
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f. Set Attachment Method as Rigid (RBE2).

g. Set Radius to 7.

h. Click Transfer IDs. 

i. Click on Coordinate Reference 2. Change Selection 
Type to Cylindrical.

j. Set Attachment Method as Rigid (RBE2).

k. Set Radius to 5.

l. Enter -1320.8, -198.12, 353.86 at End Location.

m. Check Symmetric

n. Click on Transfer IDs. 

o. Click on OK. The final generation of MNF File may take 
a while.

p. There should be a file named uca_0.mnf created in your 
working directory.

Step 5. Create a Mirror Mesh

a. Since there are a set of control arms, it is necessary to 
create a mirror of the current mesh.

b. From Bodies ribbon, select Flexible Bodies: MNF 
XForm.

c. Right click at Flexible Body Name and go to Flexible_
body->Guesses->uca_flex.

d. Enter uca_1 at Output File and uncheck Create Flexible 
Body.

e. Select Mirror: Plane Normal to Vector.

f. Select Global Y as Direction.

g. Enter 0,0,0 at Point on mirror plane.

h. Click OK.

i. At your working directory, a new file named uca_1.mnf 
has been created. 

Step 6. Load MiniBaja Database.

a. Start Adams/Car 2013.2.

b. Load the MiniBaja database using the steps in the first 
example of this section.

c. Go to File->Open->Assembly.

d. Right click at Assembly Name and search in 
<MiniBaja>/assemblies.tbl. 
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e. Double click on baja_full_vehicle_rdw.asy.

f. Click OK.

Step 7. Replace Rigid Parts 
with Flexible Parts

a. When the assembly is loaded, switch to view the front 
suspension subsystem. 

b. Right click on gel_upper_control_arm and select Make 
Flexible. 

c. Select Import MNF.

d. Right click at MNF File and browse for uca_0.mnf you 
have created.

e. Click on connections, make sure that the connections 

are shown like the figure below. 

f. Click OK.

g. Now the left upper control arm has been replaced by a 
flexible body shown in white. 

h. Repeat the steps for ger_upper_control_arm. This time, 
browse for uca_1.mnf.

i. The completed suspension will look like the figure 
below. 
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Step 8. Run Full-Vehicle Simulation

a. Switch back to Assembly view.

b. Go to Simulate->Full-Vehicle Analysis->Course Events-
>3D Road.

c. Enter baja_flex at Output Prefix.

d. Enter 6 at End Time and 600 at Number of Steps.

e. Select Interactive Simulation Mode.

f. Right click at 3D Road Data File, go to Search-><acar_
shard>roads.tbl  and browse for road_3d_ramp_
example.rdf.

g. Enter 20 as Initial Velocity.

h. Choose 2 as Initial Gear.

i. Choose DCD File for Speed Control.

j. Right click at Diver Data File and go to Search-><acar_
shard>driver_data.tbl  and browse for velocity .dcd.

k. Check Quasi-Static Straight-Line Setup and click OK.

Step 9. Check Hotspot

a. If Adams/Durability plugin has not been loaded, go to 
Tools->Plugin Manager and check Adams/Durability.

b. Click Durability->Hotspots Table.

c. Right click at Flex Body and browse for ger_upper_
control_arm.

d. Right click at Analysis and browse for baja_flex_3D_
road.

e. Select VonMises Stress at Type. Leave the rest as 
default.

f. Click Report.

g. From the table, we find that Node No.45580 of front 
right upper control arm is the number one hot spot 
with maximum stress of 131.424 MPa.

Step 10. Generate Nodal Plots

a. Click on Durability->Nodal Plots.

b. Again, Select baja_flex_3d_road as Analysis and ger_
upper_control_arm as Flexible Body.

c. Enter 45580 at Select Node List and check Stress and 
Von Mises.
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d. Click OK. This will enable us to plot the time history of 
stress at Node 45580 of front right upper control arm.

Step 11. Postprocessing

a. Press F8 to enter postprocessing window.

b. Go to View->Page->Page Layouts.

c. Select 2 Views: Over and Under. The plot page will be 
divided into two windows.

d. Change Data Source to Result Sets.

e. Enter *flex* at Filter.

f. In the Result Set window, expand baja_front_

suspension and click on ger_upper_control_arm.

g. Click on node_45580_VON_MISES on the right column 
and click Add Curves. A plot will be added at the upper 
plot window.

h. Right click at the lower plot window, select Load 
Animation. From Database Navigator, double click at 
baja_flex_3d_road.

i. Click on Camera Tab. Right click at Follow Object and 
go to Flexible_Body->ger_upper_control_arm.

j. Click on Contour Plots Tab and change Contour Plot 
Type to Von Mises Stress.

k. Adjust your view to focus on the front right upper 
control arm.

l. Click on the play button of the animation and you can 
observe the status of the vehicle when the stress at the 
hotspot is at its maximum.

m. Now, you can either proceed to check other results or 
save the front suspension subsystem and full vehicle 
assembly as new files.
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Software Version
Adams/Car and Adams/View 2013.2 

Problem Description
Adams/Car is not only a powerful tool for engineering teams in 
automotive industry, but also a good package for academic purposes. 
In this example, we will show the benefits of Adams/Car and Adams/
View for vehicle dynamics courses. You will learn to customize the 
vehicle assembly so that you can conduct various standard tests 
to have a better understanding of vehicle dynamics. Please use the 
Adams Database we provided in example to follow the steps. You are 
advised to finish Example 39 first before you proceed.

Example 44: Adams for Vehicle Dynamic Course
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a. In this example, we will focus on a few parameters that 
are paramount to vehicle dynamics courses. They in-
clude: wheelbase, cg location (relative position fore and 
aft), mass, inertia, tire lateral stiffness.

b. We have also provided FWD vehicle assembly.

Step 3. Adjust Wheelbase

a. To adjust wheelbase, it is necessary to know the cur-
rent default wheelbase.

b. Go to Adjust->Hardpoint->Table. 

c. In the dropdown menu, select VD_Course.TR_Front-
Suspension.

d. Note that the x location of hpl_wheel_center is 267.

e. From the dropdown menu, change the subsystem to 
VD_Course.TR_Rear_Suspension.

f. Note this time that the x location of hpl_wheel_center is 
2827.

g. Thus, the current wheelbase is 2827-267=2560.

h. In order to change the wheelbase, go to Adjust->Shift.
i. From the Subsystem dropdown menu, select rear 

suspension.

j. Select Aft Translation and enter 500. 

Part 1: Using Adams/Car for Longitudinal and 
Lateral Dynamics Analysis

In this part, you will learn how to change 
vehicle parameters such as mass, wheelbase, 
inertia, tire property, etc. Their influence on 
the vehicle dynamics will be reflected through 
several simulations including acceleration, 
braking, constant radius cornering, step steer, 
etc.

Step 1: Open Assembly

a. Before we introduce the simulation events provided by 
Adams/Car, it is important to learn how to customize 
the vehicle assembly so as to conduct design studies 
of parameter change.

b. Start Adams/Car 2013.2.

c. If prompted, select Standard Interface. Otherwise, fol-
low steps in Example 39 to load the VD_Course and 
VD_Course_FWD database.

d. Go to Tools->Database Management->Set Default 
Writable and select VD_Course. This will save all the 
changes we make to the VD_Course vehicle assembly 
at its own database.

e. Go to File->Open->Assembly. Right click in the field 
and search in VD_Course folder for VD_Course.asy. 
Then Click OK. When the assembly is loaded, you 
should fine the following configuration. 

Step 2. Things to Do
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k. Click OK and you will find that the rear suspension 
assembly has been moved backwards. You can 
check this by looking at the wheel center position of 
rear suspension. Notice that the engine block hasn’t 
changed. This is not a big issue since the engine block 
is merely a graphical representation. Now restore the 
rear suspension to its original position by doing a Fore 
Translation shift.

Step 4. Adjust Mass Properties

a. In this step, we will adjust mass properties, inertia 
properties.

b. Go to Simulate->Full-Vehicle Analysis->Vehicle 
Set Up->Adjust Mass.

c. In the window, enter 0, 0, 0 at CG Location.

d. Right click at Relative to Marker and go to Marker-
>Browse.

e. In the Database Navigator, expand TR_Body->ges_
chassis and double click mas_chassis_cg_marker.

f. ges_chassis has already been selected automatically 
as Modify Part.

g. After the above steps, we have relocated the cg 
position to mas_chassis_cg_marker, which can be 
changed later.

h. Enter 1500 at Mass, 3e8 at Ixx, 1.5e9 at Iyy and 1.5e9 
at Izz.

i. Click OK. 

Step 5. Adjust CG Location

a. Go to Adjust->Hardpoint->Table.

b. From the dropdown menu, select TR_Body subsystem.

c. Change hps_Chassis_CG to 1500, 0, 400.

d. Click OK. It is advised that you input a reasonable 
value of CG location with respect to vehicle mass and 
inertia properties. Otherwise it will cause the static 
equilibrium at initial simulation to fail. 

Step 6. Adjust Tire Properties

a. Another factor affects vehicle performance is tire prop-
erty.

b. Right click at one of the front tires graphics and select 
Modify.

c. Notice that in the property file field, a tire property with 
Pacejka ’89 is selected.

d. Click at            to view the property.

e. You will find a list of coefficients that define the tire 
property curve shape.

f. Under Lateral Coefficients, we find coefficients from 
a0 to a13. From our knowledge of Pacejka tire model, 
changing a3, a4 and a5 will affect the initial slope, i.e. 
lateral stiffness of the tire within linear region.

g. Close the information window.

h. Right click at Property File and search in <VD_
Course>/tire.tpl/ for TR_front_pac_89_stiff.tir.

i. Check the property file again and it can be found that 
a3 has been increased to 8000. To create your own 
tire property file, open .tir file with any kind of text editor 
and change any of the value of your interest. More in-
formation about Pacejka tire model can be found both 
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in Adams Help and other source of literature.

Step 7. Longitudinal Dynamics Events

a. After you have customized the vehicle to your inten-
tion, it is time to perform full-vehicle analysis. Adams/
Car provides a number of Full-Vehicle Simulations. For 
longitudinal dynamics, typical events include accelera-
tion test and braking test.

b. Go to Simulate->Full-Vehicle Analysis->Straight-
Line Events->Acceleration.

c. Enter VD_Course at Output Prefix.

d. Enter 10 at End Time.

e. Enter 500 at Number of Steps.

f. The default Road Data is 2d_flat.rdf. This is a simple 
straight line course. You can right click at the field and 
search in acar_shared database for other road profiles 
such as 2d_ramp. Rdf.

g. Enter 40 mph at Initial Velocity.

h. Enter 1 at Start Time. This is the time that the accelera-
tion starts.

i. Enter 75 at Final Throttle.

j. Enter 1 at Duration of Step. These two parameters 
defines how intense the acceleration maneuver is.

k. Select 2nd gear. 
l. Click OK. 

Step 8. Postprocess the Result

a. Press F8 to enter postprocessor.

b. Under the Request column, locate and highlight 
chassis_velocities.

c. Select longitudinal under Component.
d. Click Add Curves.

e. Notice that it took the vehicle about 4 seconds to ac-
celerate from 40 mph to 70 mph. The plot unit is km/hr. 
Plot any other curves of your interest.

Step 9. Braking Analysis

a. Go to Simulate->Full-Vehicle Analysis->Straight-
Line Events->Braking.

b. Enter VD_Course at Output Prefix.

c. Enter 5 at End Time.

d. Enter 250 at Number of Steps.

e. Keep the Road Data as the default 2d_flat.rdf.

f. Enter 90 km/hr at Initial Velocity.

g. Enter 0.5 at Start Time.

h. Enter 100 at Final Brake and 0.05 at Duration of Step.

i. Select 6th gear and click OK. 
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Step 10. Postprocess the Result

a. Press F8 to enter postprocessor.

b. Highlight VD_Course_brake under Simulation.

c. Change Source to Result Sets and highlight til_
wheel_tire_kinematics on the right.

d. Select longitudinal_slip_rear under Component 
and click Add Curve. 

e. Immediately it is spotted that the rear wheels locked up 
(-100 percent slip) during the braking event.

f. Create a new page. Right click in the page and select 
Load Animation.

g. Select VD_Course_brake from the Database Naviga-
tor.

h. Switch back to Adams/Car window.

i. Go to Review->Animation Controls. Check Tire 
Forces at the bottom and then switch to postproces-
sor. Now you can find the tire forces in red. 

j. Click Camera tab. Right click at Follow Object and 
go to Part->Browse, select ges_chassis under 
TR_Body. 

k. Press shift+S to change render mode to wireframe. 
This will help us to spot the wheel lock up.

l. Play the animation and you can find the large amount 
of weight transfer occurred during the event. 

Step 11. Change the Brake Bias.

a. The wheel lock up could be the wrong brake bias dis-
tribution with respect to specified cg location and road 
friction coefficient.

b. Go to Adjust->Parameter Variable->Table.
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c. From the dropdown menu, select TR_Brake_System.

d. Increase pvs_front_brake_bias from 0.6 to 0.7. 

e. Run the braking event with output prefix VD_Course_
bias and the same set of settings.

f. In the postprocessor, in a new page, plot the tire slip 
curve of both front and rear tire.

g. This time, none of the tires lock up.

h. In fact, there are quite a number of parameters that 
you can adjust through Adjust->Parameter Variables. 
Change any one of your interest and check how it af-
fects the dynamics of the vehicle!

Step 12. Lateral Dynamic Events

a. Adams/Car also provides tests for lateral dynamics 
analysis.

b. We will run a Constant Radius Cornering event first. 

This skidpad event is a helpful test to determine the ve-
hicle’s capability to negotiate a corner and its cornering 
characteristics.

c. Go to Simulate->Full-Vehicle Analysis->Cornering 
Events->Constant Radius Cornering.

d. Enter VD_Course at Output Prefix.

e. Enter 0.05 at Output Step Size.

f. Choose 2nd gear.
g. Enter 20m at Turn Radius.

h. Enter 10 at Duration of Maneuver and 30 km/hr, 80 km/
hr at Initial and Final Velocity respectively.

i. Check Shift Gears and click OK.

Step 13. Postprocess the Result

a. Press F8 to enter postprocessor.

b. Highlight VD_Course_crc under simulation and 
change Source to Result Sets.

c. Highlight condition_sensors in Result Set and select 
steering_wheel_angle.
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d. Click at Data on the right.

e. In the Independent Axis Browser, highlight condi-
tion_sensors and select velocity as component.

f. Click OK and then Add Curve.

g. Zoom into the region where the vehicle hasn’t spun.

h. The steering angle increases as the vehicle velocity to 
maintain a constant radius. Apparently the vehicle has 
an understeer characteristic.

Step 14. Change the Tire Property

a. Now, change the front tire property as instructed in 
previous step. Select TR_front_pac_89_stiff.tir.

b. Run the simulation again and plot the same curve in 
the same plot.

c. This time, the steering angle needs little increase and 
even decreases a little as the speed increases. This in-
dicates that the vehicle has geared towards neutral and 
slightly oversteer characteristic because of the increase 
of front tire lateral stiffness.

Step 15. Single Lane Change

a. Another commonly seen testing event is single lane 
change. The steering wheel is subject to a sinusoidal 
input in a short time. This is useful for testing ABS, ESP 
system because it replicates a maneuver similar to 
obstacle evasion.

b. Change the front tire property back to default. Go to 
Simulate->Full-Vehicle Analysis->Open-Loop 
Steering Events->Single Lane Change.

c. Enter VD_Course at Output Prefix.

d. Enter 5 at End Time and 250 at Number of Steps.

e. Enter 100 km/hr at initial Velocity and select 4th gear.

f. Enter 150 at Maximum Steer Value.

g. Enter 1 at Start Time and 1 at Cycle Length. The cycle 
length determines how fast the steering maneuver is.

h. Click OK.
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i. A number of plots can be generated such as yaw rate 
and roll angle. They are useful for investigating the 
effect of cg height, cg position, mass and other prop-
erties on the response of a vehicle considering DOFs 
including roll.

Step 16. Step Steer

a. Engineers are always interested in the step response of 
any kind of system. Vehicles are no exception.

b. Go to Simulate->Full-Vehicle Analysis->Open-
Loop Steering Events->Step Steer.

c. Enter VD_Course at Output Prefix.

d. Enter 5 at End Time and 250 at Number of Output 
Steps.

e. Enter 50 km/hr at Initial Velocity and select 3rd gear.

f. Enter 150 at Final Steer Value.

g. Enter 1 at Step Start Time.

h. Enter 0.2 at Duration of Step. Again this value deter-
mines how fast the step steer is going to occur. There 

is no ideal step steer input.

i. Check the yaw response in postprocessor and it can 
be found that the vehicle yaw response to step steer 
input is satisfactory in both settling time and maximum 
overshoot.

Part 2. Using Adams/View for Quarter Car 
Model Analysis

In this part, a quarter car model in Adams/
View is provided. Instructions on how to 
modify parameters of the model so as to 
investigate their impact on vertical dynamics 
are given.

Step 1. Start Adams/View
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a. Vertical dynamics, i.e ride analysis is also an interesting 
topic in vehicle dynamics. A quarter car model is com-
monly used for this type of analysis. Although Adams/
Car provides four post analysis testrig, we can also 
build a standard quarter car model in Adams/View.

b. Start Adams/View 2013.2 and select Existing Model.
c. Browse in example start folder for Quarter_Car_Mod-

el.cmd.

d. Click OK. 

Step 2. Examine the Model

a. The model contains an unsprung mass (green), a 
sprung mass (red) and a road input (maize). They are 
interconnected by two sets of spring-dampers. There is 
also an active force acting between the sprung and un-
sprung mass for active suspension analysis. Its default 
value is set to zero.

b. In the model tree on the left, under Bodies folder, 
double click either Sprung_Mass or Unsprung_Mass.

c. You can find that we have set the mass of the body to 
be defined by user input. Hence, the mass property 
can be modified independent of the geometry. 

d. Similarly, double click the spring-dampers under 
Forces folder and then you can define preload, spring 
stiffness and damping coefficient. 

e. There is a Motion called Input. It is applied at the trans-
lational joint between the Road_Input and the ground. 
The input type can be displacement, velocity or accel-

Supplemental Adams Tutorial Kit  |  for Design of Machinery Course Curriculum



Company Overview Brochure  |   313  MSC Software   |   313

eration depending on the problem you are studying. 

Step 3. Instructions on How 
to Use the Model

a. The model can be used for all kinds of quarter car 
model ride analysis. Simply change the values of mass, 
stiffness and damping and the difference will show in 
postprocessing. Please refer to Section I of the tutorial 
kit to learn more about building measurements and 
postprocessing.

b. The model can also be used for Adams/MATLAB co-
simualtion. The active force can be input from Simulink. 
Please refer to Section V of the tutorial kit to learn more 
about how to build inputs and outputs, export control 
plants, set up cosimulation and postprocess the simu-
lation.
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